summaryrefslogtreecommitdiff
path: root/dev-python/pycxx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/pycxx
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/pycxx')
-rw-r--r--dev-python/pycxx/Manifest4
-rw-r--r--dev-python/pycxx/pycxx-7.1.2-r2.ebuild2
-rw-r--r--dev-python/pycxx/pycxx-7.1.5.ebuild35
3 files changed, 39 insertions, 2 deletions
diff --git a/dev-python/pycxx/Manifest b/dev-python/pycxx/Manifest
index 40f275a8f150..aa3efb27fbe3 100644
--- a/dev-python/pycxx/Manifest
+++ b/dev-python/pycxx/Manifest
@@ -1,3 +1,5 @@
DIST pycxx-7.1.2.tar.gz 150865 BLAKE2B bbf78d88ca13fafee1239c354167b56cef2f1d56d20b0fc81d9a5d7d82096ab5d6a88802f411719cc490179314f87ef89b1e53c2b8a3a784566f9ff9d16d7cc8 SHA512 67f8d8d1ec6ce63c39695cd56c3276767d5cb4b6cc2fcf7daf5aea4bac11114f5a1fa4784ecdb35be708859cf07fc88c8e9f00b7fc808169708fd0eef1056a63
-EBUILD pycxx-7.1.2-r2.ebuild 914 BLAKE2B 80ec862b65e927b84b3ca24b0ca7e9d56e5c7ada92606960bb4226217d28650e0e0de12fa48f30bea86f9dff13c14e137623c547eb529aa2aabe32343be7d1fc SHA512 e095ab760ab31d523e066a06502a4d51c6f55141e10cb7d50c207ded94d6fc8a2df3a137c20c0fd59508d583910062a42ea2e3dfc3fede42d698c08a626062c3
+DIST pycxx-7.1.5.tar.gz 156343 BLAKE2B 099de7f88c19ec86aea67b503e6fbdc0df66bbdd3bdc0ff7f8ce77425be9486e6abebed8548f9ac764688a85e62cda77d3832f460e5678b4c07b1c6d2123b257 SHA512 0f980298739886d0c05ddd5ee23ebb234014b8276d811e62dc5b0a738666c6a011ad3f4aeeb7b1b404d8bff87dddfc30f68eec9c6bd13d5f262a2f7c53e273be
+EBUILD pycxx-7.1.2-r2.ebuild 916 BLAKE2B 723d0ceac9c91cfb1e804802688a8df7b8090a8c05305001392b002c3e11b234894ca94568ca1fcdc6a9648cb9c8346cd8901b4e8f36109e937a6f82735ff782 SHA512 7fcdaf0ad47fa1835799cba9f2737a02f0de91189da07d25a7301882892314c99de63f4e973a12ecca7491f840a2b01f1f59c13d438b199835e79c9d5ad155ed
+EBUILD pycxx-7.1.5.ebuild 920 BLAKE2B f272ec40a63328845ea0c0b3b126e43bb2cdef89f9d9b9f92acec6c492d55009d9223409cfdc3f22cf18f8989c1b55839c1a4ff35bab09aed285c531521371aa SHA512 8f19f3f9af119f1b5d02641bd449a79e2afada5483321d3c6e4124674931d0c01a06bd870a4617ba1b8130f1bd5842f6ac1625a35b2aa8aa91b4f74fcecb4f2d
MISC metadata.xml 666 BLAKE2B 0a8399e3ae824bcc0eb1e3de5975bd8f13784b23e4f46cb721759ac443c814e431883a99c997f58cca0b9cde91ebc483e1723968ade62fb52d5347f8193cccb1 SHA512 4a948f43e4d44c47982f3ad341b60390bd57e1c1aa3eafd0e20bdf1a8bf4f861c446db90bfa3bcd6c7c206220ea3d5b884805b02ee6efddfb8c5dab4578aaab4
diff --git a/dev-python/pycxx/pycxx-7.1.2-r2.ebuild b/dev-python/pycxx/pycxx-7.1.2-r2.ebuild
index bd80c6f4cd7e..6054ebaa5c9c 100644
--- a/dev-python/pycxx/pycxx-7.1.2-r2.ebuild
+++ b/dev-python/pycxx/pycxx-7.1.2-r2.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
diff --git a/dev-python/pycxx/pycxx-7.1.5.ebuild b/dev-python/pycxx/pycxx-7.1.5.ebuild
new file mode 100644
index 000000000000..24dbb09ec861
--- /dev/null
+++ b/dev-python/pycxx/pycxx-7.1.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="http://cxx.sourceforge.net"
+SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="doc examples"
+
+python_prepare_all() {
+ # Without this, pysvn fails.
+ # Src/Python3/cxxextensions.c: No such file or directory
+ sed -e "/^#include/s:Src/::" -i Src/*.{c,cxx} || die "sed failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Doc/. )
+ if use examples ; then
+ docinto examples
+ dodoc -r Demo/Python{2,3}/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}