summaryrefslogtreecommitdiff
path: root/dev-python/pycxx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-03 13:50:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-03 13:50:40 +0100
commita2c1a301b2ea85c230b30ef69ff667f230a1bf88 (patch)
tree72b20e59998ee19c32c86634c05e02790faaf20f /dev-python/pycxx
parent24d75f43d3d4caf76f2448bb277e89a3b3ae0d99 (diff)
gentoo auto-resync : 03:08:2022 - 13:50:40
Diffstat (limited to 'dev-python/pycxx')
-rw-r--r--dev-python/pycxx/Manifest3
-rw-r--r--dev-python/pycxx/pycxx-7.1.5-r1.ebuild2
-rw-r--r--dev-python/pycxx/pycxx-7.1.5.ebuild35
3 files changed, 38 insertions, 2 deletions
diff --git a/dev-python/pycxx/Manifest b/dev-python/pycxx/Manifest
index 6fdbe8517037..a30a5dc226c2 100644
--- a/dev-python/pycxx/Manifest
+++ b/dev-python/pycxx/Manifest
@@ -1,3 +1,4 @@
DIST pycxx-7.1.5.tar.gz 156343 BLAKE2B 099de7f88c19ec86aea67b503e6fbdc0df66bbdd3bdc0ff7f8ce77425be9486e6abebed8548f9ac764688a85e62cda77d3832f460e5678b4c07b1c6d2123b257 SHA512 0f980298739886d0c05ddd5ee23ebb234014b8276d811e62dc5b0a738666c6a011ad3f4aeeb7b1b404d8bff87dddfc30f68eec9c6bd13d5f262a2f7c53e273be
-EBUILD pycxx-7.1.5-r1.ebuild 916 BLAKE2B d81ef87e677e63cf27b7771240091a743e48384ac4339e16aa7a76af938f21ada1cccd3b5ab3d20ef144dcd524acf1167f138809dd4340f34dcfe1f8f851bbc4 SHA512 7ca22d46fd8646df4dc7e52836abe53d45561d2b5125d09e5ccf88b7b7f1c2e1a2a9205d656ee214ab096f8ddeb67454c17153c41f19403d0330ba2d8278ec29
+EBUILD pycxx-7.1.5-r1.ebuild 920 BLAKE2B 9efc0b254e906f85d1f1efb749e9f2e3b469fe482f4b181ade62374dac30e2308f46949062d3894253ba1143e36ec673f483f0a89e30bf82dd1aa752786afbe3 SHA512 10672ecfb951098d926f76cca8a19f8b11dc7206e6cfa8aa66abb23e64644263f43b7f4db1ed19e6b595d9e88f498998599df7037bf7278b679ebeace8d9f33f
+EBUILD pycxx-7.1.5.ebuild 916 BLAKE2B 723d0ceac9c91cfb1e804802688a8df7b8090a8c05305001392b002c3e11b234894ca94568ca1fcdc6a9648cb9c8346cd8901b4e8f36109e937a6f82735ff782 SHA512 7fcdaf0ad47fa1835799cba9f2737a02f0de91189da07d25a7301882892314c99de63f4e973a12ecca7491f840a2b01f1f59c13d438b199835e79c9d5ad155ed
MISC metadata.xml 667 BLAKE2B 1d5c679b2fcac7f5f302c35517f3903e0b3e3fdf5b65ec0005e0f1b2137ebc2a2e175031100c1bca997a6b2d7aa20ce3642c5dfcd7245c607d70d57b890694fe SHA512 2dc5bce4a24791956ca064750f7998556796af5afdb8cb24eaacd1e6485e6b92c939f053e410507e3fe3d6c29e320061c897f8ea0972ba04e4ed46f60876663c
diff --git a/dev-python/pycxx/pycxx-7.1.5-r1.ebuild b/dev-python/pycxx/pycxx-7.1.5-r1.ebuild
index 42470d114ccf..20eddf8c6d66 100644
--- a/dev-python/pycxx/pycxx-7.1.5-r1.ebuild
+++ b/dev-python/pycxx/pycxx-7.1.5-r1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
IUSE="doc examples"
python_prepare_all() {
diff --git a/dev-python/pycxx/pycxx-7.1.5.ebuild b/dev-python/pycxx/pycxx-7.1.5.ebuild
new file mode 100644
index 000000000000..6054ebaa5c9c
--- /dev/null
+++ b/dev-python/pycxx/pycxx-7.1.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="http://cxx.sourceforge.net"
+SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="doc examples"
+
+python_prepare_all() {
+ # Without this, pysvn fails.
+ # Src/Python3/cxxextensions.c: No such file or directory
+ sed -e "/^#include/s:Src/::" -i Src/*.{c,cxx} || die "sed failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Doc/. )
+ if use examples ; then
+ docinto examples
+ dodoc -r Demo/Python{2,3}/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}