summaryrefslogtreecommitdiff
path: root/dev-python/pycxx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pycxx
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pycxx')
-rw-r--r--dev-python/pycxx/Manifest4
-rw-r--r--dev-python/pycxx/files/pycxx-6.2.3-installation.patch25
-rw-r--r--dev-python/pycxx/metadata.xml18
-rw-r--r--dev-python/pycxx/pycxx-6.2.6.ebuild36
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/pycxx/Manifest b/dev-python/pycxx/Manifest
new file mode 100644
index 000000000000..c3d125364c57
--- /dev/null
+++ b/dev-python/pycxx/Manifest
@@ -0,0 +1,4 @@
+AUX pycxx-6.2.3-installation.patch 1248 BLAKE2B 8f91ad3bec34739bf3e23efda7b671d8be12a2fb6c9920b89f7ed582c81e9230475281efbd69361a9d1d862804144a4bc779caa01bf303c35d7d7e8b0ca60df7 SHA512 34eaf885611dddb4b7a650d9b2d162fbe559b5f0fcf19f514e1d9cf65e15944c43a9e0c988da815c00a92652495ef9a94a98634d11d9291d28b1f41289fb9d81
+DIST pycxx-6.2.6.tar.gz 141547 BLAKE2B e067d2a3f7ce58200c3b97f971692f64545f224929308c6e9a668a15eb775580060e860cf8ba1f894ae61320aa3454622f15fcc6fbdc601251c9b9ce576b611d SHA512 9a6c30acb99c112497c02fb0826dc0197bbf4b813d25eab3f7d6537dfd83db8150c94f617f79810bbcca64496b8d6e67b1a41446523d66031c54c21e0425ea0c
+EBUILD pycxx-6.2.6.ebuild 984 BLAKE2B 11597387594e48cf97ef37bc4bddc0299076007134e06e4d8cad78ca8b15f335569d68ef5b9e6e97472fab19d33fa4b8c8cdfbb594fa1a528b4fc2c3edc9b634 SHA512 b250150f61d4fa1f20238e3232f277bcc7aecbe5da5a1b00413b1df6bfa1e469feb9a5602b7f5bf0a71a8f30767850f849f124d76ce98fce7a476db43a16706f
+MISC metadata.xml 696 BLAKE2B f57a1d36e0c332a2a47ffc5c2c52b633b6312045f609e33a1c8c48720b8585d77500655966edbb3e537c5af1e27f3644ceda208e816d4e321602852a491348df SHA512 2940210b11c88f7d1ddb4be1da8cd49893b728d1512793f783fe32998e4189b4734fa3587662c0f16f9f9e82b0cd25217670c6f911012ae9a0c4e3d907206d3d
diff --git a/dev-python/pycxx/files/pycxx-6.2.3-installation.patch b/dev-python/pycxx/files/pycxx-6.2.3-installation.patch
new file mode 100644
index 000000000000..5f6bfa74f4be
--- /dev/null
+++ b/dev-python/pycxx/files/pycxx-6.2.3-installation.patch
@@ -0,0 +1,25 @@
+--- setup.py
++++ setup.py
+@@ -3,10 +3,18 @@
+ from distutils.command.install import install
+ from distutils.core import setup
+
+-headers = (glob( os.path.join( "CXX","*.hxx" ) )
+- +glob( os.path.join( "CXX","*.h" ) ))
+-sources = (glob( os.path.join( "Src", "*.cxx" ) )
+- +glob( os.path.join( "Src", "*.c" ) ))
++headers = (glob( os.path.join( "CXX", "Python%s" % sys.version_info[0], "*.hxx" ) )
++ +glob( os.path.join( "CXX", "Python%s" % sys.version_info[0], "*.h" ) ))
++headers += [header for header in
++ glob( os.path.join( "CXX", "*.hxx" ) ) +
++ glob( os.path.join( "CXX", "*.h" ) )
++ if os.path.sep.join((os.path.split(header)[0], "Python%s" % sys.version_info[0], os.path.split(header)[1])) not in headers]
++sources = (glob( os.path.join( "Src", "Python%s" % sys.version_info[0], "*.cxx" ) )
++ +glob( os.path.join( "Src", "Python%s" % sys.version_info[0], "*.c" ) ))
++sources += [source for source in
++ glob( os.path.join( "Src", "*.cxx" ) ) +
++ glob( os.path.join( "Src", "*.c" ) )
++ if os.path.sep.join((os.path.split(source)[0], "Python%s" % sys.version_info[0], os.path.split(source)[1])) not in sources]
+
+
+ class my_install (install):
diff --git a/dev-python/pycxx/metadata.xml b/dev-python/pycxx/metadata.xml
new file mode 100644
index 000000000000..1ae41d3ea2f0
--- /dev/null
+++ b/dev-python/pycxx/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ PyCXX is a set of C++ facilities to make it easier to write Python
+ extensions. The chief way in which PyCXX makes it easier to write
+ Python extensions is that it increases the probability that
+ your program will not make a reference-counting error and will not
+ have to continually check error returns from the Python C API.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">cxx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pycxx/pycxx-6.2.6.ebuild b/dev-python/pycxx/pycxx-6.2.6.ebuild
new file mode 100644
index 000000000000..a0dad6d120af
--- /dev/null
+++ b/dev-python/pycxx/pycxx-6.2.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="http://cxx.sourceforge.net"
+SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="doc examples"
+
+python_prepare_all() {
+ # Without this, pysvn fails.
+ # CXX/Python2/Config.hxx: No such file or directory
+ sed -e "/^#include/s:/Python[23]/:/:" -i CXX/*/*.hxx || die "sed failed"
+
+ # Remove python2 print statement
+ echo > Lib/__init__.py || die
+
+ local PATCHES=(
+ "${FILESDIR}/${PN}-6.2.3-installation.patch"
+ )
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Doc/. )
+ use examples && local EXAMPLES=( Demo/Python{2,3}/. )
+ distutils-r1_python_install_all
+}