summaryrefslogtreecommitdiff
path: root/dev-python/pycurl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
commite2db47eaae00ec33f8971db44b68645c5d3b9590 (patch)
tree3ec0cf16ddb5854017e134fabebe14bf8cb94a34 /dev-python/pycurl
parent616579b5d773c50af31ee56f00105d96ce641ca2 (diff)
gentoo resync : 17.08.2021
Diffstat (limited to 'dev-python/pycurl')
-rw-r--r--dev-python/pycurl/Manifest2
-rw-r--r--dev-python/pycurl/pycurl-7.44.1.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/pycurl/Manifest b/dev-python/pycurl/Manifest
index 70dba076bb17..6b5dc31706b1 100644
--- a/dev-python/pycurl/Manifest
+++ b/dev-python/pycurl/Manifest
@@ -1,5 +1,7 @@
DIST pycurl-7.43.0.6.tar.gz 222895 BLAKE2B 5a923a3d7a57aa553361206fd0c0e43e6ad66a70af72540c08a29903a9a71ed6b9460c06ab6e50fc2a01d1badd45edf41eb36f6dd97fca3c83bef30f12e41c40 SHA512 5625d9e38159fb785afaf539372a8ac658d9118fb25f581f11629859fde400b6fccf65e03a19e182534a78169531304639b1e6f1bfdd2cb09bce95d581b52850
DIST pycurl-7.44.0.tar.gz 227443 BLAKE2B b0c19058f3df74702221d01320d6c2c389f67b41c1fa5728aba50266f4120d736d38e510ee20f66e163fad14957e8ec38c9cfcd217845b4a5c4d2253afaec175 SHA512 9e371796650cd698ec50236714cba203782d793154f8325c8b2f106d2ce9b1a60766d7641b84702ec32dc83fa6e3ffe16cb774cb9ccba9747cfb089d9caec8e6
+DIST pycurl-7.44.1.tar.gz 227562 BLAKE2B 7dcbde563140f28382768b89b95422f873d5396a1f050dfcd3686d87b0ca2c3f3871281ed87b1dfbe7e4268728c2ec3ba7a76e7d7ef57754af5c185bf2a6fbe8 SHA512 e251db332791de07364695b5fd59b3a290486eabbde8be9914b5edeefa8702b4dd9ab678739ad765f76ededeb7192444fefe2a076d3977f454259dfd06731059
EBUILD pycurl-7.43.0.6.ebuild 2945 BLAKE2B 91ab9abecb719a80f7bad6f55fdf65494760ac46b1ce46890ffec7d4b65f06cefda60b22a0163a664f4a4b22ffe0458f29955e290ebfcc6fcd134a6e894bd1ab SHA512 c195ea3d041ce9924306e54bcb15158a142df057c3c0bcdebd8d6c2712bd26b64eab858509b414649e4befb433d8a5e8e52b1df87572b0450e688814d4cee9d7
EBUILD pycurl-7.44.0.ebuild 2690 BLAKE2B 4e13f13dfec1d1eaafad487d630eb05d0899a86726599046641da11c9f027ac70207700d84c8149fb8505b88e35a4a6c3404457261e906d2dc41bd50aec91abd SHA512 74ced6873d82f6242b39b433958b266746d0d742788b9e712e6ec651830321979924422345cacbc716ecb22ba0c02e37899d1e6bc824050211ea43f5496f2fe7
+EBUILD pycurl-7.44.1.ebuild 2519 BLAKE2B 718f070ea9adf84afca102078f73fb7343881327a36a5685acc6280b81c442ffca627b5b8a29c0c8eb1881b5342129ab73f887fb8e5487e3b3ef3e12ff1f1386 SHA512 5fa1585fdeeba89857bc19d23f9d802101349291794e1269c5120d94e097caf4dc0bbb6c74600bddd4c40e6f969404762a3d36e63ab71cdbb39c97d0fe88ff43
MISC metadata.xml 1099 BLAKE2B d96159920135d8d85a01449423d1638889d2c6ed9f84d08eabd7405a3271efe85315cece0fc4f6832bd43b622089c819df3d20fd725150c89a0910ec26ac339a SHA512 8f8b3a10d2f72aa67d1b5f7462ea62803d9150cab3d96792adbd65b379a45c074d68809b25d4a2b558bf28dae72e095c598bd0485fce4c5dafba0784de517a6c
diff --git a/dev-python/pycurl/pycurl-7.44.1.ebuild b/dev-python/pycurl/pycurl-7.44.1.ebuild
new file mode 100644
index 000000000000..74935e36c25d
--- /dev/null
+++ b/dev-python/pycurl/pycurl-7.44.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="python binding for curl/libcurl"
+HOMEPAGE="
+ https://github.com/pycurl/pycurl
+ https://pypi.org/project/pycurl/
+ http://pycurl.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="curl_ssl_gnutls curl_ssl_nss +curl_ssl_openssl examples ssl test"
+RESTRICT="!test? ( test )"
+
+# Depend on a curl with curl_ssl_* USE flags.
+# libcurl must not be using an ssl backend we do not support.
+# If the libcurl ssl backend changes pycurl should be recompiled.
+# If curl uses gnutls, depend on at least gnutls 2.11.0 so that pycurl
+# does not need to initialize gcrypt threading and we do not need to
+# explicitly link to libgcrypt.
+RDEPEND="
+ >=net-misc/curl-7.25.0-r1:=[ssl=]
+ ssl? (
+ net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-)]
+ curl_ssl_gnutls? ( >=net-libs/gnutls-2.11.0:= )
+ curl_ssl_openssl? ( dev-libs/openssl:= )
+ )"
+
+# bottle-0.12.7: https://github.com/pycurl/pycurl/issues/180
+# bottle-0.12.7: https://github.com/defnull/bottle/commit/f35197e2a18de1672831a70a163fcfd38327a802
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),http2]
+ >=dev-python/bottle-0.12.7[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # docs installed into the wrong directory
+ sed -e "/setup_args\['data_files'\] = /d" -i setup.py || die
+ # TODO
+ sed -e 's:test_socks5_gssapi_nec_setopt:_&:' \
+ -i tests/option_constants_test.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ # Override faulty detection in setup.py, bug 510974.
+ export PYCURL_SSL_LIBRARY=${CURL_SSL}
+}
+
+src_test() {
+ emake -C tests/fake-curl/libcurl CC="$(tc-getCC)"
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ nosetests -a '!standalone,!gssapi' -v --with-flaky || die "Tests fail with ${EPYTHON}"
+ nosetests -a 'standalone' -v --with-flaky || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ local HTML_DOCS=( doc/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}