summaryrefslogtreecommitdiff
path: root/dev-python/pycurl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-19 23:39:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-19 23:39:38 +0000
commitcc5ddec0bbae3bf2151f62ef22d19b5e85cb8f35 (patch)
tree0ecbd113fafef1c07a494eb72954a4768ea4040a /dev-python/pycurl
parent9aa795a0179b29f7489bd04584bc8d2914da467b (diff)
gentoo auto-resync : 19:02:2024 - 23:39:38
Diffstat (limited to 'dev-python/pycurl')
-rw-r--r--dev-python/pycurl/Manifest2
-rw-r--r--dev-python/pycurl/pycurl-7.45.3.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/pycurl/Manifest b/dev-python/pycurl/Manifest
index 97a06850e2fa..af5ac80aa537 100644
--- a/dev-python/pycurl/Manifest
+++ b/dev-python/pycurl/Manifest
@@ -1,4 +1,6 @@
AUX pycurl-7.45.2-skip-http3-test.patch 1116 BLAKE2B 9852580ab51cd978501d966292827c6f7739d52f65eb4cb01b3cd9517aa1b7f522c58dd0703264d662f431292ef55188f16d50f9f8df5b0dd1b7e32f0a185e64 SHA512 51567f97f96d94878a0af446a89a032aa79c6a062d2efbe1d32c8a9b70d1ba75eada54fff53ea9de37c739635225310d067976d4883937914dc2708de4837789
DIST pycurl-7.45.2.tar.gz 234245 BLAKE2B 16257a967d2867de08d83478f602d00b54316d37b6a544804e606a814f61507530fb7e1ef3247be824dfa22b9487a69bbfc9b1038b2b776ebc556b18ed2d93ca SHA512 8a82346395acfc0bd37a8c4d8d2b17e5ab4602710308ed50f9ed88c223c73f15f5b1c95fc6191708e3bd9d647e4bc5ec91f740de433dd87e2ae0796ac79879ac
+DIST pycurl-7.45.3.tar.gz 236470 BLAKE2B 690e49f92f569352e26d95a0fa58508c4e96c845c7e3ae1169b8bc55036902f64859987880565217df56a57031dc2775e3c6979b4cfdf8a8c9a94c67ae94cb79 SHA512 12a55070602a1fd22b160ad582a4001bdd28531d2b2ccd365ff0136bc13dd23af80b19488bdbbc60a902a3a362b64383b9ae6acce6ed328c74dcffc8a6a3f4ad
EBUILD pycurl-7.45.2-r1.ebuild 2505 BLAKE2B 6e9938c43afbfa8f76f3b92546835e4dc9e81458474ba85afae455cad220e003a58089b0b926aef69e1b7ae5e4d81acbca2de69210e20db250bcca0ab761a3d5 SHA512 23d2d0557d6ceb9443cd2414d17e41d0e23eed0285294b9daa7f438400392d1be95342d17e03a0f436783b852fcdda2456eacc3c30d63f08377ae0f0cbe1e80c
+EBUILD pycurl-7.45.3.ebuild 2732 BLAKE2B 2ba6a9bc1a07f894e46e8d2f5573d39c95f1b6145dacc57e7caa5963938419398d7febcf84f2780595bd332f0fdceeb5244460f1e2ec10e2f7492bcaa0cd2b1b SHA512 62cba55564d2adc5a34b6451f5f537f2794b6646d0f661d947fa3f51e6e46a271e4eea7aea5e33a69f05ea92fd3a39a80e05f714f80e256b2833968a007d44f3
MISC metadata.xml 1100 BLAKE2B dfc7fe054c7cc34c61bf58fef0378df304a539c28cbc0dff4ffff65ccc8892c38aaf1e275885fc54d2854d9acc6b382947038041f815b5941859be7cfe75523f SHA512 f1de0dccd625ae0b02ff9a55cbc1bbf7944faa24dba28ffd711c728001f180afa598a255132aea860ad616637325cdc653577af531b1a954a3994e8902c774aa
diff --git a/dev-python/pycurl/pycurl-7.45.3.ebuild b/dev-python/pycurl/pycurl-7.45.3.ebuild
new file mode 100644
index 000000000000..648cbccc1c07
--- /dev/null
+++ b/dev-python/pycurl/pycurl-7.45.3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi toolchain-funcs
+
+DESCRIPTION="Python bindings for curl/libcurl"
+HOMEPAGE="
+ http://pycurl.io/
+ https://github.com/pycurl/pycurl/
+ https://pypi.org/project/pycurl/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="curl_ssl_gnutls +curl_ssl_openssl examples ssl"
+
+# Depend on a curl with curl_ssl_* USE flags.
+# libcurl must not be using an ssl backend we do not support.
+# If the libcurl ssl backend changes pycurl should be recompiled.
+# If curl uses gnutls, depend on at least gnutls 2.11.0 so that pycurl
+# does not need to initialize gcrypt threading and we do not need to
+# explicitly link to libgcrypt.
+DEPEND="
+ >=net-misc/curl-7.25.0-r1:=[ssl=]
+ ssl? (
+ net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-)]
+ curl_ssl_gnutls? ( >=net-libs/gnutls-2.11.0:= )
+ curl_ssl_openssl? ( dev-libs/openssl:= )
+ )
+"
+
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ >=dev-python/bottle-0.12.7[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),http2]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # docs installed into the wrong directory
+ sed -e "/setup_args\['data_files'\] = /d" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ # Override faulty detection in setup.py, bug #510974.
+ export PYCURL_SSL_LIBRARY=${CURL_SSL}
+}
+
+src_test() {
+ emake -C tests/fake-curl/libcurl CC="$(tc-getCC)"
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local EPYTEST_DESELECT=(
+ # refcounting tests are unreliable
+ tests/memory_mgmt_test.py::MemoryMgmtTest::test_readdata_refcounting
+ tests/memory_mgmt_test.py::MemoryMgmtTest::test_writedata_refcounting
+ tests/memory_mgmt_test.py::MemoryMgmtTest::test_writeheader_refcounting
+ # broken with curl 8.4.0+
+ tests/multi_callback_test.py::MultiCallbackTest::test_multi_socket_action
+ tests/multi_socket_select_test.py::MultiSocketSelectTest::test_multi_socket_select
+ # TODO
+ tests/option_constants_test.py::OptionConstantsTest::test_proxy_tlsauth
+ tests/option_constants_test.py::OptionConstantsTest::test_socks5_gssapi_nec_setopt
+ )
+
+ epytest -p flaky -p timeout --timeout=30 tests
+}
+
+python_install_all() {
+ local HTML_DOCS=( doc/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}