summaryrefslogtreecommitdiff
path: root/dev-python/pycurl/files/pycurl-7.43.0.5-cc-cflags.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-17 14:32:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-17 14:32:10 +0100
commit51c50bd4c895ebf56d81fecae8e45ec3b5fc3efa (patch)
tree753b6b08624c34d1ed8414bbe22c45409f7741b9 /dev-python/pycurl/files/pycurl-7.43.0.5-cc-cflags.patch
parentbe9d77d3ac6af8f4ead98d89706f356b65578c93 (diff)
parentdeba8115d2c2af26df42966b91ef04ff4dd79cde (diff)
Merge branch 'edge' into next
Diffstat (limited to 'dev-python/pycurl/files/pycurl-7.43.0.5-cc-cflags.patch')
-rw-r--r--dev-python/pycurl/files/pycurl-7.43.0.5-cc-cflags.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pycurl/files/pycurl-7.43.0.5-cc-cflags.patch b/dev-python/pycurl/files/pycurl-7.43.0.5-cc-cflags.patch
new file mode 100644
index 000000000000..b1e66e0942d1
--- /dev/null
+++ b/dev-python/pycurl/files/pycurl-7.43.0.5-cc-cflags.patch
@@ -0,0 +1,34 @@
+From 861ba3143001caf2623ce5d84a1d04a69b502339 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Mon, 11 May 2020 08:52:04 +0200
+Subject: [PATCH 1/2] Support overriding CC, respect *FLAGS in fake-curl
+
+The shipped libraries (obviously) do not work on non-amd64 platforms,
+and rebuilding without the correct compiler and flags does not work
+on more complex setups such as ppc64 with 32-bit userland. Make
+the Makefile permit CC override while preserving the current default,
+and use user-provided CFLAGS, CPPFLAGS and LDFLAGS.
+---
+ tests/fake-curl/libcurl/Makefile | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/tests/fake-curl/libcurl/Makefile b/tests/fake-curl/libcurl/Makefile
+index b05bc89..8ece206 100644
+--- a/tests/fake-curl/libcurl/Makefile
++++ b/tests/fake-curl/libcurl/Makefile
+@@ -7,8 +7,11 @@ all: \
+
+ .SUFFIXES: .c .so
+
++CC = `curl-config --cc`
++CFLAGS += `curl-config --cflags`
++
+ .c.so:
+- `curl-config --cc` `curl-config --cflags` -shared -fPIC \
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -shared -fPIC \
+ -Wl,-soname,$@ -o $@ $<
+
+ show-targets:
+--
+2.26.2
+