summaryrefslogtreecommitdiff
path: root/dev-python/pycuda
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-05 17:31:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-05 17:31:39 +0100
commit8b5a92f1e1eccecfa61db8a4744e1b9d449522b6 (patch)
tree427b7c54371dc36d63e7fa3590ec577ad265eac9 /dev-python/pycuda
parent3023707d355581e5dc6945aa9c8f4d59e508a8b5 (diff)
gentoo auto-resync : 05:05:2023 - 17:31:39
Diffstat (limited to 'dev-python/pycuda')
-rw-r--r--dev-python/pycuda/Manifest4
-rw-r--r--dev-python/pycuda/metadata.xml1
-rw-r--r--dev-python/pycuda/pycuda-2022.2.2.ebuild93
3 files changed, 97 insertions, 1 deletions
diff --git a/dev-python/pycuda/Manifest b/dev-python/pycuda/Manifest
index 03d92d00d077..ef4b80696f98 100644
--- a/dev-python/pycuda/Manifest
+++ b/dev-python/pycuda/Manifest
@@ -1,3 +1,5 @@
DIST pycuda-2021.1.tar.gz 1682423 BLAKE2B 0ebd7554a5f92cd0d39ce7b5f64218f0b0dcfa1f3e63d3180306a149ad0581150630813eee7fbc17e32bb35ea711a46b84332705d6ffece7b11e7e928ef07aad SHA512 1df09f59e254f7e39b630ff41d22237ab0c81c0e6e7b7611c57eb98ade8531356b9cb3e381e6fa7e8495a46c465458febaf8ad56ceb8d570b5b25defb6dd55a9
+DIST pycuda-2022.2.2.tar.gz 1682953 BLAKE2B d60e83ac2faa183e0fa022c3d901c9d97ec2f9a59195425b9d71467c24b154d48d5735223220b41aa58b0898800d382d9ead54166d0a59db9c2a777e03e574be SHA512 c62aafe473e44339ac2147d86b51fc9bc2429310450b6d99e78a127828cc3a42dc74f20e1bdf8261f6652aed6d07ee3a871ce371f89f33fbcc4014f551af0b96
EBUILD pycuda-2021.1.ebuild 2308 BLAKE2B d709ad40a285a2cd83e49ce0ff1d3fada6813df2591c207bc3395c92eeb370f64e3860c9e96d1eeb2a32f88c082f8a3247de2ea6061ad666577231d2251e7031 SHA512 5a0b252cf22afb862c19eeb7e79258791b414c1ae3eac7b65fce7a99f5b36ab82bd954c61e0ee41ca09739763ba9b30d856ce46e99fd7b878d190346390a2581
-MISC metadata.xml 333 BLAKE2B fcbf9c2b3c4fe1261c4576c8b95ce0ec1e8182e8377205927acfdb803668d70653e1572d50be0c9d1c2400b81a7db9003db3aba9e85cc6892f5f1f048a546a9c SHA512 b05c6924e1a322ebba353240ddc5392f4c8b5172c291f259c0d149e644fded7f48056f3950651d73782fd4b0c88b5bcf33aec772e9f61bdd41b6d4cfad1568d5
+EBUILD pycuda-2022.2.2.ebuild 2343 BLAKE2B cf2526ee176a7b30cd349e68bb310781a37b01c03b5bc23cc45be313eb4c59e14293811c9c4f784975c89b7db4b2c16851dbcd68af174ad1c14c6c8f4bd8f804 SHA512 28900ad6f60c6403a67f7226d09173fb9103d3b8bfb6124e23b28dfeb302e5cc885dc121b6a7230a78c0593e5960edd1ae815be4a7442bf789efaa1bce8e3698
+MISC metadata.xml 389 BLAKE2B 2788434c5a24679e345fa8bde0e5a77332d9a0e640388e6e4361aedc37d0f1ee26db7d0f79775f290b9423283fb6b587fea1b1ab03ab7c0f3fcc80850b234d03 SHA512 fb34b68887425831b0e34426334db19c7906aa8c4f5161a473c6a98939ad5e4883dc76c5f2f2bea37f30b3b6abb057b182535386ca13804f6733430c5bbacc51
diff --git a/dev-python/pycuda/metadata.xml b/dev-python/pycuda/metadata.xml
index c00cc96a7de1..a0f336da0a4a 100644
--- a/dev-python/pycuda/metadata.xml
+++ b/dev-python/pycuda/metadata.xml
@@ -7,5 +7,6 @@
</maintainer>
<upstream>
<remote-id type="pypi">pycuda</remote-id>
+ <remote-id type="github">inducer/pycuda</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/pycuda/pycuda-2022.2.2.ebuild b/dev-python/pycuda/pycuda-2022.2.2.ebuild
new file mode 100644
index 000000000000..f4343e6daa31
--- /dev/null
+++ b/dev-python/pycuda/pycuda-2022.2.2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit cuda distutils-r1 pypi
+
+DESCRIPTION="Python wrapper for NVIDIA CUDA"
+HOMEPAGE="https://mathema.tician.de/software/pycuda/ https://pypi.org/project/pycuda/ https://github.com/inducer/pycuda"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples opengl test"
+
+RDEPEND="
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytools[${PYTHON_USEDEP}]
+ dev-util/nvidia-cuda-toolkit[profiler]
+ x11-drivers/nvidia-drivers
+ opengl? ( virtual/opengl )
+"
+DEPEND="${RDEPEND}"
+
+# We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
+# user is (usually) not in the video group
+RESTRICT="test? ( userpriv ) !test? ( test )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ cuda_sanitize
+
+ sed "s|\"--preprocess\"|&,\"--compiler-bindir=$(cuda_gccdir)\"|" \
+ -i pycuda/compiler.py || die
+
+ > siteconf.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_configure() {
+ mkdir -p "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+
+ local conf=(
+ "${EPYTHON}" "${S}"/configure.py
+ --boost-inc-dir="${ESYSROOT}"/usr/include
+ --boost-lib-dir="${ESYSROOT}"/usr/$(get_libdir)
+ --boost-python-libname=boost_${EPYTHON/./}.so
+ --boost-thread-libname=boost_thread
+ --cuda-inc-dir="${ESYSROOT}"/opt/cuda/include
+ --cuda-root="${ESYSROOT}"/opt/cuda
+ --cudadrv-lib-dir="${ESYSROOT}"/usr/$(get_libdir)
+ --cudart-lib-dir="${ESYSROOT}"/opt/cuda/$(get_libdir)
+ --no-use-shipped-boost
+ $(usev opengl --cuda-enable-gl)
+ )
+ echo ${conf[*]}
+ "${conf[@]}" || die
+}
+
+python_test() {
+ # we need write access to this to run the tests
+ addwrite /dev/nvidia0
+ addwrite /dev/nvidiactl
+ addwrite /dev/nvidia-uvm
+ addwrite /dev/nvidia-uvm-tools
+
+ EPYTEST_DESELECT=(
+ # needs investigation, perhaps failure is hardware-specific
+ test/test_driver.py::test_pass_cai_array
+ test/test_driver.py::test_pointer_holder_base
+ )
+
+ cd "${T}" || die
+ epytest "${S}"/test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}