summaryrefslogtreecommitdiff
path: root/dev-python/pycuda
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/pycuda
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/pycuda')
-rw-r--r--dev-python/pycuda/Manifest4
-rw-r--r--dev-python/pycuda/pycuda-2019.1.2.ebuild81
-rw-r--r--dev-python/pycuda/pycuda-2021.1.ebuild93
3 files changed, 95 insertions, 83 deletions
diff --git a/dev-python/pycuda/Manifest b/dev-python/pycuda/Manifest
index 7179b42373b9..65ebd4a54b39 100644
--- a/dev-python/pycuda/Manifest
+++ b/dev-python/pycuda/Manifest
@@ -1,3 +1,3 @@
-DIST pycuda-2019.1.2.tar.gz 1584807 BLAKE2B 3250430ad626b28242ff44ab9576cf1f5ecf77530e789470dfebab324de95a735c0f56e67134891bace44b1f9b7a25133ffcb74c652c6568c5afedce26907fdb SHA512 22829daa5923342eec400a24342b1d738226073bb676476e4af97629d9311426b5d2465e60811696e55401568b90e152ac96d877c6262c416099a609862db742
-EBUILD pycuda-2019.1.2.ebuild 2218 BLAKE2B 060c482016d93534327e5e45fdc0560be24339490b642c2837a93194787e9f032710b090d92f421085ef95e04d37f4d0313c91590a4eafeac0385bb6ebf0bec8 SHA512 56cf00ec1761d1b8b2a6ba72cfc1ea43f1a64d4537dc56701c28758584e7e7516b924ec31be6862aad3e69117fb7f7505db7e6a408ab0b48bc1093b415fb8046
+DIST pycuda-2021.1.tar.gz 1682423 BLAKE2B 0ebd7554a5f92cd0d39ce7b5f64218f0b0dcfa1f3e63d3180306a149ad0581150630813eee7fbc17e32bb35ea711a46b84332705d6ffece7b11e7e928ef07aad SHA512 1df09f59e254f7e39b630ff41d22237ab0c81c0e6e7b7611c57eb98ade8531356b9cb3e381e6fa7e8495a46c465458febaf8ad56ceb8d570b5b25defb6dd55a9
+EBUILD pycuda-2021.1.ebuild 2353 BLAKE2B cf5e625a9bede76f3df86394ec8a71095301cd916669bf19e6d0bfe895f6ed2c8051b2235404cf9032c302dbeb937315b2eec19dc4fae8498459e3038ef5cae2 SHA512 3bf6a3688da755a4fc53ac200dfceaddb120c568d1db70626b0baca0d1b305211ea2eb51b4169be2f25d9a061234ac33a37299ea38ca2dff4c9de8dd5a59f880
MISC metadata.xml 333 BLAKE2B fcbf9c2b3c4fe1261c4576c8b95ce0ec1e8182e8377205927acfdb803668d70653e1572d50be0c9d1c2400b81a7db9003db3aba9e85cc6892f5f1f048a546a9c SHA512 b05c6924e1a322ebba353240ddc5392f4c8b5172c291f259c0d149e644fded7f48056f3950651d73782fd4b0c88b5bcf33aec772e9f61bdd41b6d4cfad1568d5
diff --git a/dev-python/pycuda/pycuda-2019.1.2.ebuild b/dev-python/pycuda/pycuda-2019.1.2.ebuild
deleted file mode 100644
index a2d14a91432d..000000000000
--- a/dev-python/pycuda/pycuda-2019.1.2.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=no
-
-inherit cuda distutils-r1
-
-DESCRIPTION="Python wrapper for NVIDIA CUDA"
-HOMEPAGE="https://mathema.tician.de/software/pycuda/ https://pypi.org/project/pycuda/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="examples opengl test"
-
-RDEPEND="
- dev-libs/boost:=[python,${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/pytools-2013[${PYTHON_USEDEP}]
- dev-util/nvidia-cuda-toolkit
- x11-drivers/nvidia-drivers
- opengl? ( virtual/opengl )"
-DEPEND="${RDEPEND}"
-
-# We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
-# user is (usually) not in the video group
-RESTRICT="userpriv !test? ( test )"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- cuda_sanitize
- sed -e "s:'--preprocess':\'--preprocess\', \'--compiler-bindir=$(cuda_gccdir)\':g" \
- -e "s:\"--cubin\":\'--cubin\', \'--compiler-bindir=$(cuda_gccdir)\':g" \
- -e "s:/usr/include/pycuda:${S}/src/cuda:g" \
- -i pycuda/compiler.py || die
-
- touch siteconf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_configure() {
- mkdir -p "${BUILD_DIR}" || die
- cd "${BUILD_DIR}" || die
- "${EPYTHON}" "${S}"/configure.py \
- --boost-inc-dir="${EPREFIX}"/usr/include \
- --boost-lib-dir="${EPREFIX}"/usr/$(get_libdir) \
- --boost-python-libname=boost_${EPYTHON/./}.so \
- --boost-thread-libname=boost_thread \
- --cuda-root="${EPREFIX}"/opt/cuda \
- --cudadrv-lib-dir="${EPREFIX}"/usr/$(get_libdir) \
- --cudart-lib-dir="${EPREFIX}"/opt/cuda/$(get_libdir) \
- --cuda-inc-dir="${EPREFIX}"/opt/cuda/include \
- --no-use-shipped-boost \
- $(usex opengl --cuda-enable-gl "") || die
-}
-
-src_test() {
- # we need write access to this to run the tests
- addwrite /dev/nvidia0
- addwrite /dev/nvidiactl
- addwrite /dev/nvidia-uvm
- addwrite /dev/nvidia-uvm-tools
-
- distutils-r1_src_test
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/pycuda/pycuda-2021.1.ebuild b/dev-python/pycuda/pycuda-2021.1.ebuild
new file mode 100644
index 000000000000..ffc9b069deb9
--- /dev/null
+++ b/dev-python/pycuda/pycuda-2021.1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit cuda distutils-r1
+
+DESCRIPTION="Python wrapper for NVIDIA CUDA"
+HOMEPAGE="https://mathema.tician.de/software/pycuda/ https://pypi.org/project/pycuda/"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples opengl test"
+
+RDEPEND="
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytools[${PYTHON_USEDEP}]
+ dev-util/nvidia-cuda-toolkit[profiler]
+ x11-drivers/nvidia-drivers
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}"
+
+# We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
+# user is (usually) not in the video group
+RESTRICT="test? ( userpriv ) !test? ( test )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ cuda_sanitize
+
+ sed "s|\"--preprocess\"|&,\"--compiler-bindir=$(cuda_gccdir)\"|" \
+ -i pycuda/compiler.py || die
+
+ > siteconf.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_configure() {
+ mkdir -p "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+
+ local conf=(
+ "${EPYTHON}" "${S}"/configure.py
+ --boost-inc-dir="${ESYSROOT}"/usr/include
+ --boost-lib-dir="${ESYSROOT}"/usr/$(get_libdir)
+ --boost-python-libname=boost_${EPYTHON/./}.so
+ --boost-thread-libname=boost_thread
+ --cuda-inc-dir="${ESYSROOT}"/opt/cuda/include
+ --cuda-root="${ESYSROOT}"/opt/cuda
+ --cudadrv-lib-dir="${ESYSROOT}"/usr/$(get_libdir)
+ --cudart-lib-dir="${ESYSROOT}"/opt/cuda/$(get_libdir)
+ --no-use-shipped-boost
+ $(usev opengl --cuda-enable-gl)
+ )
+ echo ${conf[*]}
+ "${conf[@]}" || die
+}
+
+python_test() {
+ # we need write access to this to run the tests
+ addwrite /dev/nvidia0
+ addwrite /dev/nvidiactl
+ addwrite /dev/nvidia-uvm
+ addwrite /dev/nvidia-uvm-tools
+
+ EPYTEST_DESELECT=(
+ # needs investigation, perhaps failure is hardware-specific
+ test/test_driver.py::test_pass_cai_array
+ test/test_driver.py::test_pointer_holder_base
+ )
+
+ cd "${T}" || die
+ epytest "${S}"/test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}