summaryrefslogtreecommitdiff
path: root/dev-python/pycryptodomex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/pycryptodomex
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/pycryptodomex')
-rw-r--r--dev-python/pycryptodomex/Manifest2
-rw-r--r--dev-python/pycryptodomex/pycryptodomex-3.9.9.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/pycryptodomex/Manifest b/dev-python/pycryptodomex/Manifest
index 9e4767cf9548..af6eb3fdd201 100644
--- a/dev-python/pycryptodomex/Manifest
+++ b/dev-python/pycryptodomex/Manifest
@@ -1,4 +1,6 @@
AUX pycryptodome-3.9.4-parallel-make.patch 756 BLAKE2B 06a79eff056ecb983131838287563d4d60896f27e28d5c2534f4ab008e50017694ac9355b43f8f387cc29abfd21ffd648233c3dbae33a06fcedb12a6c7e11e80 SHA512 06b42ea780bd374cf5cb5d6cef3fade5d695c1ee0d765e2659408da7645ad311eef2028f17d8ec0289d49c3a5851b4c63503d7c922de15873dbbf16d0db58b08
+DIST pycryptodome-3.9.9.tar.gz 15551299 BLAKE2B ac89bcc2bbe707cb2a9cf2496a2eb74ff5685f11017d60d67558de7ac6cad5c24c43b4074bff01e99378d7c88462e88e88f363c5329fb800e1a7872ad8a34dab SHA512 a1aad4d52256220fe3d5d7f399c2c5e7338d6eb88058da0571fe1c686d74d33ff4bc1c275d4b9373e0ff22f4ddcded75a25387e76fc65047f8612f8856c1bd4d
DIST pycryptodomex-3.9.8.tar.gz 15633485 BLAKE2B 3d7b8a74d2f7cc0f47c73f3f3d1dcf13c8b9feb9f2f532dc48751c4a73915aa081ecf273a81731076070f054f5b2037a5eba9054ca71e549aad18ed0c3148c74 SHA512 bcc5fb27a89c00e6348eacc744a23d687d0b308d5c8ad8f6d955fe2b9e84288a592206336e7fef699800948f8ea7b1ac06d2bec60df0b9ff0fa32d0a05380869
EBUILD pycryptodomex-3.9.8.ebuild 1326 BLAKE2B 2ad09640a04fc98b7ed803a3b843d52edd55bf14b8b62de34dfd35fd63fdf5979a5fa5d745fd8f675048b130e504aa7f87799f303be6a5efacb30f6f8f1b496c SHA512 5ae9a1e0a9f7db68fa43d13bfc6489f680fb400c651e08ec651c33e94d0181f1a5411b5f0ad31859a66c08f753661034b30aa40da7926fa0e614a98f2d4c8101
+EBUILD pycryptodomex-3.9.9.ebuild 1510 BLAKE2B 1139a7ff5c924c04175db63903eeaea57b3f00c5c1869eb012810243097f1c40fbd78c1421d0366eb8ea0fe531b745061fd1132a9764bec268792dd48137901c SHA512 448c19f7bcca190b531015e0ea25d927d0b456fdc0b44a3c6b4d0d44a159e30579c45395e37683180477bb6d8b9e9c233a3ae38facf913a4741694d240cfc08a
MISC metadata.xml 445 BLAKE2B 0486ce910a7107f8fd04a495f27f6c830ac8e2176442c3be759aaedfa43439050e8da73d0a0e58343e0fd0fa5ff1845dbe55bfeef814b395cea764104dea52a7 SHA512 957a228f0f1d67f803d5faf5f143bca871f3e83849b5d02ef6b5454247e085f93776eb14880dd9e4eaa18da149a34ff2f9b1e783df40f2a749ac6be813d3ac2a
diff --git a/dev-python/pycryptodomex/pycryptodomex-3.9.9.ebuild b/dev-python/pycryptodomex/pycryptodomex-3.9.9.ebuild
new file mode 100644
index 000000000000..b3b8e7593c3d
--- /dev/null
+++ b/dev-python/pycryptodomex/pycryptodomex-3.9.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+MY_P=${P/x/}
+DESCRIPTION="A self-contained cryptographic library for Python"
+HOMEPAGE="https://www.pycryptodome.org
+ https://github.com/Legrandin/pycryptodome/
+ https://pypi.org/project/pycryptodomex/"
+SRC_URI="
+ https://github.com/Legrandin/pycryptodome/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD-2 Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="
+ dev-libs/gmp:0"
+BDEPEND="
+ virtual/python-cffi[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${DEPEND}
+ ${BDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/pycryptodome-3.9.4-parallel-make.patch"
+)
+
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ # parallel make fixes
+ # Multiple targets were compiling the same file, setuptools doesn't
+ # understand this and you get race conditions where a file gets
+ # overwritten while it's linking. This makes the files look like separate
+ # files so this race won't happen
+ ln src/blowfish.c src/blowfish_eks.c || die
+ ln src/mont.c src/mont_math.c || die
+
+ # create the magic file to build cryptodomex from the sources
+ echo > .separate_namespace || die
+
+ distutils-r1_python_prepare_all
+}