summaryrefslogtreecommitdiff
path: root/dev-python/pycryptodome
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-04 04:27:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-04 04:27:18 +0100
commitfa275aeb316ed5e68498ca0057b27a1e9c887e26 (patch)
tree1a167f06787ef709edff61d90f369164a0683705 /dev-python/pycryptodome
parent9b22dab88308071d43d47cd078b37903900f47d3 (diff)
gentoo auto-resync : 04:10:2024 - 04:27:17
Diffstat (limited to 'dev-python/pycryptodome')
-rw-r--r--dev-python/pycryptodome/Manifest2
-rw-r--r--dev-python/pycryptodome/pycryptodome-3.21.0.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/pycryptodome/Manifest b/dev-python/pycryptodome/Manifest
index e71dc374769c..7e4c0f93d423 100644
--- a/dev-python/pycryptodome/Manifest
+++ b/dev-python/pycryptodome/Manifest
@@ -1,4 +1,6 @@
AUX pycryptodome-3.10.1-system-libtomcrypt.patch 1729 BLAKE2B 57a2022ef17e0b86e98b085336f5ce815304e326a5a2bd5cc8ff5d33b6efba440505767517b79c2f0bba39ab33f04d7434a3f0ee529b880ff7552aee2805dab5 SHA512 d53677c0ad96f161f9aed14b8f353a8cc12c92f31de9733789f9c4151710376d33e974fd611b763de94c631796d7a57cd8787656e3c1e985696e20537b34760e
DIST pycryptodome-3.20.0.gh.tar.gz 17173888 BLAKE2B 7706a7f512579b4edf080b5074a9f226b2f0ef18a8f1faf74e890cfccff85d0599b4883cd5011a5cc0296b5a10cccce94cb2b948de29d785f6add04e54215a5a SHA512 0d65ccd93f9f78548c04aa3af01cb65b6a39e81bb3dfa4bb08acc5a5a731b17f9c5b07a1d1780739b3f358402a3596b04e446fc7b39345a4c6f03fd5a2de7ff9
+DIST pycryptodome-3.21.0.gh.tar.gz 17464067 BLAKE2B 5fcf62317053ae3d1dddd90bb223e9866944b4c4325ae146c17c48d2345c06c3fc9951dc72c135ec5a61043b7eced92b69c9bc5f43d47e1f512b9c9ce94fa310 SHA512 cfb66b1e53547992b9405bc6a2d90ed3bc3d1857a01ef619069b9d1aa24d809a9d46d8b0d824999588dd6c0de9a5e39db70b572a9954f0ead0dd39f9b7cedbcc
EBUILD pycryptodome-3.20.0.ebuild 1362 BLAKE2B af3957849ac67c97dd06e6c48fdafedccca1437ec2f91fe91cd90a34650fe4e050ed6379dace8ddfd66300e23b9cc7bae2d95fe5e90edfa2d28cfbd5d803d80d SHA512 f38397be9d7c4779775efa81fd965eb20aaa550d34dd4fd8eb26f0b0636bd2678dc1cf943c41cad2adb67b301520461caa6134638741a53fd2d1af9383ca0e7a
+EBUILD pycryptodome-3.21.0.ebuild 1369 BLAKE2B ec99ff795a456aecda59ca92426149ae47e918f2cac87e9b88844d89073e9bbeade94937a865e750f9a8a342342f6018422584b23d6e70f47f0f6bc0e6ffc518 SHA512 63e10aa4093053980b9a11164f4cb2766eeef401246bb34d379c81afb1af774b5505a873d5f7f8c4ce6e74237a611514a6ceb43f18b3cccdf89e1c33e40889e0
MISC metadata.xml 386 BLAKE2B 1ec04c0cb752414f063177e637f1fc3e3c401db0c1f245cb33a3690e25597098b25fb2cd5f3ab99838a8bf8339906e2b23e325af5c7248fd880563c872c6fb60 SHA512 f19e2537c5a985389182860eaa45ae68a37ef1167c4b76b452513987fae6fcfb3534d102a079a003770372bbdb4f1997460c982b355f76d09f2387996e18091b
diff --git a/dev-python/pycryptodome/pycryptodome-3.21.0.ebuild b/dev-python/pycryptodome/pycryptodome-3.21.0.ebuild
new file mode 100644
index 000000000000..e4e2740433f5
--- /dev/null
+++ b/dev-python/pycryptodome/pycryptodome-3.21.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A self-contained cryptographic library for Python"
+HOMEPAGE="
+ https://www.pycryptodome.org/
+ https://github.com/Legrandin/pycryptodome/
+ https://pypi.org/project/pycryptodome/
+"
+SRC_URI="
+ https://github.com/Legrandin/pycryptodome/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2 Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+DEPEND="
+ dev-libs/gmp:=
+ >=dev-libs/libtomcrypt-1.18.2-r1:=
+"
+BDEPEND="
+ $(python_gen_cond_dep 'dev-python/cffi[${PYTHON_USEDEP}]' 'python*')
+"
+RDEPEND="
+ ${DEPEND}
+ ${BDEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}/pycryptodome-3.10.1-system-libtomcrypt.patch"
+)
+
+python_prepare_all() {
+ # make sure we're unbundling it correctly
+ rm -r src/libtom || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTHONPATH=${S}/test_vectors:${PYTHONPATH}
+ "${EPYTHON}" - <<-EOF || die
+ import sys
+ from Crypto import SelfTest
+ SelfTest.run(verbosity=2, stream=sys.stdout)
+ EOF
+
+ # TODO: run cmake tests from src/test?
+}