summaryrefslogtreecommitdiff
path: root/dev-python/pycpio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-16 00:13:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-16 00:13:18 +0000
commitf2bdc27fe0f79f8f9a3945eb2b1163ce75c56439 (patch)
treedd0f7da0455831dffb2cb662e7dae760f92e68ad /dev-python/pycpio
parent770d63f36dbe1722e0ff9ab55eeca49986f01527 (diff)
gentoo auto-resync : 16:02:2025 - 00:13:18
Diffstat (limited to 'dev-python/pycpio')
-rw-r--r--dev-python/pycpio/Manifest4
-rw-r--r--dev-python/pycpio/pycpio-1.5.0.ebuild31
-rw-r--r--dev-python/pycpio/pycpio-9999.ebuild7
3 files changed, 38 insertions, 4 deletions
diff --git a/dev-python/pycpio/Manifest b/dev-python/pycpio/Manifest
index 68e7e64f3a40..013b1c1e97b4 100644
--- a/dev-python/pycpio/Manifest
+++ b/dev-python/pycpio/Manifest
@@ -1,4 +1,6 @@
DIST pycpio-1.4.2.gh.tar.gz 22690 BLAKE2B 244145dabdee1fa50e54f98327608b96afef354d53e1405e2e54c47d9cc8a71c80e4adfe8f1c7a079a9acdd30751f125e7b5db61cd34baf375433248c7370757 SHA512 7fe6b7e6597a8733d740348888b5c41aa37f08e2ecd5843ab32751e8a5cd6ce9390201ba5a47c3febd2f61562db4ce6724404f9359238de91f94f4bc12b9c41b
+DIST pycpio-1.5.0.gh.tar.gz 23293 BLAKE2B a01a62f2caf687956be65256a5ebde9c65d084a425f7777cc253f233e3ddd479b8220173417573b665d0271eb77397eadb2a8698f33d3794efd3243a96d0d63c SHA512 ae8ab8dcb852f40721f8cccac6235824d01349d0372d2931d456297cbe9899b071030fac46f564fe5f0e7ecf77b325245f5153e726520f16bbb4832c44eb34a2
EBUILD pycpio-1.4.2.ebuild 561 BLAKE2B dc15d00fc269e3102f518a2d54f4c2c8ba19f4ddc10242e23142a7a9220de09f41b129121782156b437e502e936aaad937533ace4f7e862cbc3d545d18d2227f SHA512 5a603af1a6c2619aeb1925ba79ed8255eae3b69ec28fb8c2c68dcde56cdd0054cae9ca024b1f41f11ab8e09c3d8018ff3aef38b2a847a215a73f3d2529c4f937
-EBUILD pycpio-9999.ebuild 495 BLAKE2B 078968c053cdfc5c1495097dd0aa6ce9544956a55198059b12f4cabcc1c76ffc591cc60db1f25411d9e1f27d15d4458d575a6732f3e1a40be6cdbde49a3b8d59 SHA512 e7233323ef2f643e1441ad8bb31b9322060078a0529a3f2a4745617b7641d120abb4539a05640e7265c373ab80f05baa4d65d95e3dde8e9e1b5c89ed990fc53a
+EBUILD pycpio-1.5.0.ebuild 608 BLAKE2B b166ae64b1f4fb4a273be9f1a9a19494fb80cb18220e4ca36e5feaa02ece139e7c21a0b352611665b6d926428407031abc9b37473ea37fa30275f6eca8576d39 SHA512 d453a42a717bd790b94117005f0eac544fa6c3dc6f92f93b6b8dbc9998c79174e6d4f28e3d1492963ec3fe0db29fa973aeaeb1716388a9e70442b009b9ad9748
+EBUILD pycpio-9999.ebuild 541 BLAKE2B f61d7408643fca829a886de541ed4f42b94c8576ebb5a27621d2996ecb704c0ee9411cda50ee21d765b932d9c891596a20ddb4c646eaa8978eba1aedfc284160 SHA512 12f71e22fcd0420a2f459bfbd66f2bafabb3ffa363fa35dda8b87d949a94e6c46d8ca7b7f7019137a5ea46c52b62ec31c87cb8207481b283248fb179570de23d
MISC metadata.xml 448 BLAKE2B 4324185ef695587de96b7df3e5edfbb8046c8d40902181fa581d3f1f02fa0085d6fdbc15d59032a28f0145a5bb6aa939b38b353168d5a69b6032950876b97f5f SHA512 a80d14c870ead81264b4e8295825955fbecc7f2296fe2fbd880dd5fb2e4c41e84378690737db7b13cd4736c15cac510ff56c5fd87fba75c5c38d7b7be84da6bb
diff --git a/dev-python/pycpio/pycpio-1.5.0.ebuild b/dev-python/pycpio/pycpio-1.5.0.ebuild
new file mode 100644
index 000000000000..6914a2fb9163
--- /dev/null
+++ b/dev-python/pycpio/pycpio-1.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python CPIO library"
+HOMEPAGE="https://github.com/desultory/pycpio/"
+SRC_URI="
+ https://github.com/desultory/pycpio/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ >=dev-python/zenlib-3.0.2[${PYTHON_USEDEP}]
+ >=dev-python/zstd-1.5.6.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest tests
+}
diff --git a/dev-python/pycpio/pycpio-9999.ebuild b/dev-python/pycpio/pycpio-9999.ebuild
index 0ff538ec120d..7f8c13e6a025 100644
--- a/dev-python/pycpio/pycpio-9999.ebuild
+++ b/dev-python/pycpio/pycpio-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2023-2024 Gentoo Authors
+# Copyright 2023-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,14 +9,15 @@ PYTHON_COMPAT=( python3_{11..13} )
inherit distutils-r1 git-r3
DESCRIPTION="Python CPIO library"
-HOMEPAGE="https://github.com/desultory/pycpio"
+HOMEPAGE="https://github.com/desultory/pycpio/"
EGIT_REPO_URI="https://github.com/desultory/${PN}"
LICENSE="GPL-2"
SLOT="0"
RDEPEND="
- >=dev-python/zenlib-2.3.2[${PYTHON_USEDEP}]
+ >=dev-python/zenlib-3.0.2[${PYTHON_USEDEP}]
+ >=dev-python/zstd-1.5.6.1[${PYTHON_USEDEP}]
"
distutils_enable_tests unittest