summaryrefslogtreecommitdiff
path: root/dev-python/pycpio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-18 12:24:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-18 12:24:45 +0100
commit16be64511bd21e32a29645b49e37611507709790 (patch)
treebfb80060e55c09b383ac0257408890c961550171 /dev-python/pycpio
parent4d6e1311ded368813dc93f130293f64148e22c45 (diff)
gentoo auto-resync : 18:08:2024 - 12:24:44
Diffstat (limited to 'dev-python/pycpio')
-rw-r--r--dev-python/pycpio/Manifest4
-rw-r--r--dev-python/pycpio/pycpio-1.3.1.ebuild24
-rw-r--r--dev-python/pycpio/pycpio-9999.ebuild6
3 files changed, 33 insertions, 1 deletions
diff --git a/dev-python/pycpio/Manifest b/dev-python/pycpio/Manifest
index 69a1b4a36c69..d0eb2f0d8a7f 100644
--- a/dev-python/pycpio/Manifest
+++ b/dev-python/pycpio/Manifest
@@ -1,4 +1,6 @@
DIST pycpio-1.2.1.tar.gz 18512 BLAKE2B e835e3810d174d8f4cd5afc2984c0d84d55f9492725c16afdcd1b760dc8c58b4b83a1d13c0b266c8ec9407ab5c1114fe95468d742b202ba99e3c4a76a69dff15 SHA512 4611829339a45a848deb0c5c35098215ac7c378714e4fb1e10975e00b386e5e6bcd295fde83f361998f234f506276b906a4424a7d4aa925fe2bd92a0d7311d86
+DIST pycpio-1.3.1.tar.gz 22457 BLAKE2B de24a569d7114e31e9093d05f7b3651e9ee1e77c233d46114bd53e0821b1c7bbaac61691dd8abfb0ade23bdc15c8e5f35f2c8c7cb8e1160b82450dcc7e8280bc SHA512 5672ed515434e94c4812532d4405db172eaa54ed9ef497b31fe354eb374157b070ab50481cc852e04312d01aa821fe0c4aeb2824cfc246c68c841288a92a25d9
EBUILD pycpio-1.2.1.ebuild 480 BLAKE2B 896f72a8ef9df5e0ebbdc9f8d16c9da8f5bf836ea3079b04f7bc38ba5a8dc36d9ec923a2b845db8ddb048ca471618b8aa1e5ec563e1fa9f428a83a6df7b8e84c SHA512 90fb452fce57ffefe1e9089d56e604908eef62fc24dba00e823059a49d68b67f0d03f68f2ad417d4c789393e3cd0566bac5e20f07f1ed2f6dc6346416e9368c5
-EBUILD pycpio-9999.ebuild 421 BLAKE2B 95f729c042841f6fd7a70b5779fdd160a6a1d6f73b0cfc1e5dd0a9393c697b02d77d124ad0ba44a6802d64a2a9caa2d78e517f82ccbb3c1de8f5907a8f22a87f SHA512 21b3941465c505119e147e6cdcdd980258c87a698057a9a0bb5ea1ca39a792dcf21f3383a3c0ebb734b64c069c6f43d44f3930a8f4f4bf0ec2e6a43b8bbdb103
+EBUILD pycpio-1.3.1.ebuild 550 BLAKE2B 27a61860a4d0050cd36312202295f5d4d3a7a742628b930de46a06aeb2f390f99a61cf142e25b1a6e3f88cd9e724292163a640ae149d1c5be05eec86af0af2d1 SHA512 e9e4f0f5217693508cca492da0557af9f932cf5ca90987d01eebcab06fb41edeb0cef4b50a8a54c525563c10d0cfa88a8dffe7ebd1919cab7d4af577e31be43a
+EBUILD pycpio-9999.ebuild 491 BLAKE2B 90d0d47eb15968ecf16ce194cde38a8e0e9eb25439a38f2039e3bb80536df4f76532b5ab1d2349295b48b5bee653f8ec377f6588cfdcd49240a8d1b311fa8bb1 SHA512 45d9f27d9c4f969ad87050bf473ddace3009039fe7549c4386a6c80e20d6e58b65ef72fcac0926899d9d16357f2434fbede2d39d45901762f53c86a818d4661a
MISC metadata.xml 461 BLAKE2B 9a8cbd11b569f3357ec70357d03545274f1f3532ad47ad1284fd6f657d0680bdef37a2e73efaa4781f8f22266caa271cfc74fe92797ade23e872352d930fe6e1 SHA512 7e534ff6f145a90c54317ad00165aaeecd00a807481ad5fba92b410f39fa5c9cd0c8f3d451d37ab9ad5861c383c6e051e487b6e3ef9a3c63531462c975d1713b
diff --git a/dev-python/pycpio/pycpio-1.3.1.ebuild b/dev-python/pycpio/pycpio-1.3.1.ebuild
new file mode 100644
index 000000000000..837c98d10d5d
--- /dev/null
+++ b/dev-python/pycpio/pycpio-1.3.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+inherit distutils-r1
+
+DESCRIPTION="Python CPIO library"
+HOMEPAGE="https://github.com/desultory/pycpio"
+SRC_URI="https://github.com/desultory/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND=">=dev-python/zenlib-2.1.2[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest tests/
+}
diff --git a/dev-python/pycpio/pycpio-9999.ebuild b/dev-python/pycpio/pycpio-9999.ebuild
index a025a3b5791e..140af15820ae 100644
--- a/dev-python/pycpio/pycpio-9999.ebuild
+++ b/dev-python/pycpio/pycpio-9999.ebuild
@@ -15,3 +15,9 @@ LICENSE="GPL-2"
SLOT="0"
RDEPEND=">=dev-python/zenlib-9999[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest tests/
+}