summaryrefslogtreecommitdiff
path: root/dev-python/pycparser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/pycparser
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/pycparser')
-rw-r--r--dev-python/pycparser/Manifest2
-rw-r--r--dev-python/pycparser/pycparser-2.20.ebuild19
2 files changed, 6 insertions, 15 deletions
diff --git a/dev-python/pycparser/Manifest b/dev-python/pycparser/Manifest
index 4335550d586a..fd3e4d36eb9b 100644
--- a/dev-python/pycparser/Manifest
+++ b/dev-python/pycparser/Manifest
@@ -1,3 +1,3 @@
DIST pycparser-2.20.tar.gz 161330 BLAKE2B 9a114e4b73e6c3c495bd78c393957146ec425eb5b15d72266cbf424f15e8d2e2e6402ef36d60a9dff41b393aab80fe1356befd25549517f398e129836a76b037 SHA512 ff0853c9f981b43b4f2e879350715c07b02cf9dab223d4980d8fe0a3138c98041b5f848a9355ae4f1cb45e7f137c03a88843008e18d77af9250e0d9c55f5ca1b
-EBUILD pycparser-2.20.ebuild 1885 BLAKE2B 905f59a68a8c9f98716a34040de4f43094538177b13bc45e14191841fe78ff3f8bb2f8b84974d275aef49c3a87c40c39693527e4de16c7bcdfacc3c346db59f0 SHA512 6ac245ddc31f4e37e7865dbc460ac3ef5c6f8c0f89df375b35d9088ec3589318eb38ba8632efd2c228b95b4fd134b3234235d932666b10716f263f5578e59a43
+EBUILD pycparser-2.20.ebuild 1676 BLAKE2B 3ebcf538175273151c08e46e0d9be1c2f7ec80f9be5678c0e6f74b7e1f1dee72e349474573d33b424ea7b17b926813683148765ed820eb6233f8556a00de40fa SHA512 87d9174b8b8f5dfa4adc0abe9a4c214984e99709fc22f602561c750e7525b66e5cad21533d92e2a3e81d23d30f1b92510e75d39bd1fdbf853890c4ea5a10fd9b
MISC metadata.xml 380 BLAKE2B b013fa2cb5c61b39b122c1c051ce40a8c002d4d4c6995ab78e0f3a35cec07d2f81cb5b05326ddac9c2526eb3ebcf90bc2660f588c4ebe5bacbd1a861fcf91985 SHA512 98ca8c63733123ae6a1d1c8b338d5f98a679b8f84b1e0abed8dc7fefa5549735a7f4de9a5851a26507a6169336fa46689616e46a49df0e9a52f6efb669eac865
diff --git a/dev-python/pycparser/pycparser-2.20.ebuild b/dev-python/pycparser/pycparser-2.20.ebuild
index 4227f14e0bf5..f70df58cbc19 100644
--- a/dev-python/pycparser/pycparser-2.20.ebuild
+++ b/dev-python/pycparser/pycparser-2.20.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
-inherit distutils-r1 toolchain-funcs
+inherit distutils-r1
DESCRIPTION="C parser and AST generator written in Python"
HOMEPAGE="https://github.com/eliben/pycparser"
@@ -41,20 +41,11 @@ python_compile() {
}
python_test() {
- # Trick the tests into using CPP variable
- # https://bugs.gentoo.org/719934
- local CPP="$(tc-getCPP)"
- mkdir -p "${T}"/bin || die
- cat > "${T}"/bin/cpp <<-EOF || die
- #!/bin/sh
- exec ${CPP} "\$@"
- EOF
- chmod +x "${T}"/bin/cpp || die
- local -x PATH="${T}/bin:${PATH}"
-
+ # Skip tests if cpp is not in PATH
+ type -P cpp >/dev/null || return 0
# change workdir to avoid '.' import
cd tests || die
- ${EPYTHON} -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}
python_install() {