summaryrefslogtreecommitdiff
path: root/dev-python/pycountry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/pycountry
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/pycountry')
-rw-r--r--dev-python/pycountry/Manifest2
-rw-r--r--dev-python/pycountry/pycountry-20.7.3.ebuild19
2 files changed, 6 insertions, 15 deletions
diff --git a/dev-python/pycountry/Manifest b/dev-python/pycountry/Manifest
index 5976e5814852..23a701bb5956 100644
--- a/dev-python/pycountry/Manifest
+++ b/dev-python/pycountry/Manifest
@@ -1,4 +1,4 @@
AUX pycountry-20.7.3-fix-tests-for-pypy3.patch 740 BLAKE2B 64113481df5b7fb385604f16d7b3be066a12b6a5e1dab38cdf879101da132bcacf407fdf773d5f15381789114be265c7e1ee3ab880c38dae6e904e6820923ee5 SHA512 0df7756ac4d3dd3ccc409307f21a95021c93851ad3b6ce07ce244eade4957d9906dc6aaabdbafe671cf6f9619623cdd22097119642c0c926376e4991eb6a1a4f
DIST pycountry-20.7.3.tar.gz 10137217 BLAKE2B 2b32d450a1d16eab95e0c1ab6cae3bf89c07742d48cf6f8473854119ac0483b5490523e03e823c9b314231983f39d1c8bf595aac201756fee9897a8d15a84c08 SHA512 df88a34307a4275267a7f3af282b73ca5e762c49ad158bfcd39b97c5d852bf045bcfe72351fc6f232c55003a7c4b0a04801eb562ba65ed5d599bd45b2bd3bc58
-EBUILD pycountry-20.7.3.ebuild 989 BLAKE2B aac94be1413cbfdfa49d70b0fb0b6a9970eb59d63efcc01c8837bd7d28706ed6e610709daa068c24bad50b4202172fb82aed53669b4cfa4fee59971f67339e53 SHA512 9f79ec0c5750330db1e1a4d120bccac26e79a5082f839d7af66dd7d4bd2b68f13d98ce32b9f68dd9eb2b687ac017771718d2dcf95311cbafd0e2d5c42da8df8b
+EBUILD pycountry-20.7.3.ebuild 755 BLAKE2B 27af61c68eba4eb538030409a16d5d7fda2c9550986a2a94697cd459d4779f394059e331c618ff597de8f9f9b032a62b7d26bf8eb7e17e61a701658b3f692274 SHA512 714d10f2236a8c8f4b6e3b0e661134da4871793d2438b1e80ce8828b9e6dc100566028b5d87ae393d03268490f7d4ab2a972b37f0ffddd5cca9bf3eefb047f4f
MISC metadata.xml 472 BLAKE2B fb2aab31ad673be9f39cc21bcbed26d06525a6bb905855b297f3f4aee7be246db9bab4344dd38dd0e903e63a8548795c26925e742635150600b26cf9f0c563e1 SHA512 83ff7cb703819ed92c8b2ba08ada6941f9accc30208f12ec9c35bf58c4dc772de34bec00646b6f188fe9cddd0d3e89ae540e8d0936629dc2075bf66442986024
diff --git a/dev-python/pycountry/pycountry-20.7.3.ebuild b/dev-python/pycountry/pycountry-20.7.3.ebuild
index 24c4be17dd8d..124a682416fb 100644
--- a/dev-python/pycountry/pycountry-20.7.3.ebuild
+++ b/dev-python/pycountry/pycountry-20.7.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
# The package uses pkg_resources to determine its version
DISTUTILS_USE_SETUPTOOLS=manual
@@ -16,20 +16,11 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 arm64 ~ia64 ppc ~sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests --install pytest
# https://github.com/flyingcircusio/pycountry/pull/51
PATCHES=( "${FILESDIR}/${P}-fix-tests-for-pypy3.patch" )
-
-python_test() {
- # The package uses pkg_resources to determine its version
- distutils_install_for_testing
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}