summaryrefslogtreecommitdiff
path: root/dev-python/pycountry/pycountry-23.12.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-08 11:11:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-08 11:11:23 +0000
commit909e6f36d5376b253aba44edc8f2af1a5acd0c11 (patch)
tree048569e21e5eb27492bcd1fa73bbc1cc462b3ce5 /dev-python/pycountry/pycountry-23.12.7.ebuild
parentac778f2cf394586c43beb5d753a19ff3f6063556 (diff)
gentoo auto-resync : 08:12:2023 - 11:11:23
Diffstat (limited to 'dev-python/pycountry/pycountry-23.12.7.ebuild')
-rw-r--r--dev-python/pycountry/pycountry-23.12.7.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/pycountry/pycountry-23.12.7.ebuild b/dev-python/pycountry/pycountry-23.12.7.ebuild
new file mode 100644
index 000000000000..f7e6413409d0
--- /dev/null
+++ b/dev-python/pycountry/pycountry-23.12.7.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Database of countries, subdivisions, languages, currencies and script"
+HOMEPAGE="
+ https://github.com/pycountry/pycountry/
+ https://pypi.org/project/pycountry/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests pytest