summaryrefslogtreecommitdiff
path: root/dev-python/pycollada
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /dev-python/pycollada
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'dev-python/pycollada')
-rw-r--r--dev-python/pycollada/Manifest1
-rw-r--r--dev-python/pycollada/pycollada-0.6.ebuild69
2 files changed, 0 insertions, 70 deletions
diff --git a/dev-python/pycollada/Manifest b/dev-python/pycollada/Manifest
index accfd837708c..3552d722a720 100644
--- a/dev-python/pycollada/Manifest
+++ b/dev-python/pycollada/Manifest
@@ -1,4 +1,3 @@
DIST pycollada-0.6.tar.gz 3109963 BLAKE2B 92e9b3a28c959700fad4f4af1c6375f47b1a3cabb4ff3b8eec47a5625bd680d7088b7c9677e0d395f3be296d555996e5e5819f11ab82a0fa37b0c6fbec33795f SHA512 043eaafbd97a588897870e89202e281777094e4bf63ea56a979b6f7aef7ad549fc2b71f3b575c0b9c413bc10756ba36e02cc7cbd497a6cbaa51f06e99b34f0cd
EBUILD pycollada-0.6-r1.ebuild 1367 BLAKE2B e59f3f30f4cf54192109ad6f490753ca86ed6a14bed4754b55f85193374ecb9a586d5b11bb8b502b159cbcae9ac690b766946af71baa9625b865f89a3f5db7c0 SHA512 3e6a2d5d17a692e763d70091756c77e927b73e37fe384df441e8663ef705390760b4d8dcaf4bb95035bee97259916cbce9e9c0379062f2d48fa3b6dcd8eb2fb9
-EBUILD pycollada-0.6.ebuild 1494 BLAKE2B 43e055d11615a8e4fb9e1ae447807daa37e3d6e636f6c4538c43050cba6262004b09ed704aa694b36981c9d214d98d4dae61be83c451044a9c1078a9d3a4eae1 SHA512 9409bd3e77fc969ab7b328d2ab73c1357993dbabe9d66e1693e0a6c3f1a3e8439869e8a6a292212a3a3fd6a4cbd6c6a8d32b924ddbd36debdd5419dab096a637
MISC metadata.xml 559 BLAKE2B 4a6983c74b48af34e314f348e781cde10d22c7419f11932f40e28d47cdd0bd5b940cbff2431cba17793a813bc3d8a697a7cd3dea4e4d122834ce91fbff79fa53 SHA512 401e7df61bebe47ef2f8de32766df5013994c624285ff5f352195e0b316f2c831ecb43e513efc29b4a5710de6c810b8f80add2b57513d5cd5aa6904aebc0ec7f
diff --git a/dev-python/pycollada/pycollada-0.6.ebuild b/dev-python/pycollada/pycollada-0.6.ebuild
deleted file mode 100644
index 1cd5c01d2d92..000000000000
--- a/dev-python/pycollada/pycollada-0.6.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-PYTHON_MULTIPLE_ABI=1
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for reading and writing COLLADA documents"
-HOMEPAGE="https://pycollada.readthedocs.org/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-RDEPEND="
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.2[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/python-dateutil[${PYTHON_USEDEP}] )
-"
-
-REQUIRED_USE="${PYTHON_REQ_USE}"
-
-DOCS=( AUTHORS.md CHANGELOG.rst COPYING README.markdown )
-
-src_compile() {
- distutils-r1_src_compile
-
- if use doc ; then
- pushd docs > /dev/null || die
- emake html
- popd > /dev/null || die
- fi
-}
-
-src_install() {
- distutils-r1_src_install
-
- use doc && local HTML_DOCS=( docs/_build/html/. )
- einstalldocs
-
- if use examples ; then
- insinto /usr/share/${P}/
- doins -r examples
- fi
-
- install_test_data() {
- insinto $(python_get_sitedir)/collada/tests/
- doins -r collada/tests/data
- }
- python_foreach_impl install_test_data
-}
-
-src_test() {
- test_collada() {
- for script in "${S}"/collada/tests/*.py ; do
- PYTHONPATH="${S}" $EPYTHON "${script}"
- done
- }
- python_foreach_impl test_collada
-}