summaryrefslogtreecommitdiff
path: root/dev-python/pycollada
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-08 06:56:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-08 06:56:53 +0000
commit1fbaf1314579f2155166bebd1ddfe6131d400807 (patch)
treeb034ac67fab73c50b138ed5a57e5823cda058299 /dev-python/pycollada
parentf50726afc610727258a31ddfa8b3b32639b20a10 (diff)
gentoo auto-resync : 08:01:2024 - 06:56:53
Diffstat (limited to 'dev-python/pycollada')
-rw-r--r--dev-python/pycollada/Manifest2
-rw-r--r--dev-python/pycollada/pycollada-0.8.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/pycollada/Manifest b/dev-python/pycollada/Manifest
index 0df738be1bb4..1df719871aca 100644
--- a/dev-python/pycollada/Manifest
+++ b/dev-python/pycollada/Manifest
@@ -1,3 +1,5 @@
DIST pycollada-0.7.2.gh.tar.gz 3526845 BLAKE2B 3d8b4d2478fa4937756db69afbd8716ccd2dd4e0bec8e7dc045e84f06573605c0872d31bdee3d6ccca4b800699746877530f2fa81b5790c3f5c0cb3e7583fa66 SHA512 5c21155d52d54de62d192d4da0385bc7110ddd3962fe3e0e9e5904bbcd0e66cb1a95765c9996cdc5beef0edb30ee2123ae23b904d029be1c119e902d2fc4e7fe
+DIST pycollada-0.8.gh.tar.gz 3586706 BLAKE2B 533a2a309b4c7ee60671edfd241b80e7128330b2cd85d2707fc4f83b0aceb2d792d8efec77f9a6a8600eec0704878a4342449fde68f77e42617eff30965973a5 SHA512 7171469b8434a7c24ec2ebadefa9ad5268382659cb5b2b3712cf0ba73c7948e7fa4061ecfa02001862c76e1139293ab68cf425472222348e28efa28bc75f844f
EBUILD pycollada-0.7.2-r1.ebuild 1120 BLAKE2B 1d015ef90b31153e9decb783eb65665ef4ff1baa14dfde1ed0d7aa447ca2c4fb2224a932b8025e2a1e4c7b6030dce2682d2113fbcb8977b73a64d877e3cabefc SHA512 fdcaadc07719b67a7a812d981cbf5b82b6843bd45575d2fd3c702e1d09a46a49fc70df0dae8c68512b09b4ad253320bea8139acea63420930ec8030de5d22190
+EBUILD pycollada-0.8.ebuild 1122 BLAKE2B fb5a2e05f1bd368da154a4926d4fbad60509fc5187810830408b7877791ac6f4cac5f310785dbb9d7eb97b6eba659512785cfbfca1d78cc2e3ae6e9a19415855 SHA512 dd342296f6cc19b3e7e8930f6ccf4570b37607f19a148b979c34ce5f530c1b06fe4b4f0e5230e30b04f3803114db5abde8ab700178c24f40b4112b93c4055dce
MISC metadata.xml 905 BLAKE2B 9e1283685c76cd27ff971ab68ef51f56cf296aa44fe3dbb5bf74a3e6b4ea69abb927603acc16747bd1bf8db906b4437cf792330df5e7803a211b1699a01034d3 SHA512 686ffa6bb798bd4387106cdb461f0abdc2a685c53c4552c95c86febd6789e4b323ae1ac9717109fea96287ac100a93b33e3ce37eea37e6de3e4f4e704e40e9e8
diff --git a/dev-python/pycollada/pycollada-0.8.ebuild b/dev-python/pycollada/pycollada-0.8.ebuild
new file mode 100644
index 000000000000..396c0f814d49
--- /dev/null
+++ b/dev-python/pycollada/pycollada-0.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for reading and writing COLLADA documents"
+HOMEPAGE="
+ https://pycollada.readthedocs.io/
+ https://github.com/pycollada/pycollada/
+ https://pypi.org/project/pycollada/
+"
+SRC_URI="
+ https://github.com/pycollada/pycollada/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.2[${PYTHON_USEDEP}]
+"
+
+DOCS=( AUTHORS.md COPYING README.markdown )
+
+distutils_enable_sphinx docs
+distutils_enable_tests unittest
+
+python_install_all() {
+ if use examples ; then
+ insinto /usr/share/${PF}/
+ doins -r examples
+ fi
+
+ distutils-r1_python_install_all
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # ensure data files for tests are getting installed too
+ python_moduleinto collada/tests/
+ python_domodule collada/tests/data
+}