summaryrefslogtreecommitdiff
path: root/dev-python/pycodestyle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /dev-python/pycodestyle
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'dev-python/pycodestyle')
-rw-r--r--dev-python/pycodestyle/Manifest4
-rw-r--r--dev-python/pycodestyle/metadata.xml2
-rw-r--r--dev-python/pycodestyle/pycodestyle-2.7.0.ebuild25
3 files changed, 29 insertions, 2 deletions
diff --git a/dev-python/pycodestyle/Manifest b/dev-python/pycodestyle/Manifest
index 889f6a52b39f..6c639938c8f4 100644
--- a/dev-python/pycodestyle/Manifest
+++ b/dev-python/pycodestyle/Manifest
@@ -1,3 +1,5 @@
DIST pycodestyle-2.6.0.tar.gz 100213 BLAKE2B 484cad34de86ae50f8efaffe590e79fa52ca7f13a3a9d5c9d52f52aef7a940a9eee8cff74b3bd1f711c3a01155f0ce6794196817d1b0e941b8afc77de4804387 SHA512 3bf9904752170135ca399a1b25470a531adb5b85dfd8df7ffbbc86b5875bc3a507cd8732158bc9cb7fd5b44b48c9a32d63d621856d55a15bc3104a99ca4bd271
+DIST pycodestyle-2.7.0.tar.gz 103640 BLAKE2B 5b1ad351aadff101732748fd4d3a4d34c3eabc058dd9d0c7551afde0dbb169ddce82ccc539e71b72ea2df0dc199b3c2213d259910a18b5acd892782e1314cc19 SHA512 26502480e5855f0fd9378664ec813bb38dc2f8ac22e01767fc8bf75e52fa7a7691382fd4f6f1edaeb5f41d150ed71ee87e0d7f525bf06acbf4b3034cec3a227a
EBUILD pycodestyle-2.6.0.ebuild 896 BLAKE2B 9cdff512bde9d6728005fed91d5246076749dae9d3bf90aa6bd408fe997366eac83d11ab97dd527798068be87a12d4e23a281f0f8fe1c2e0759a9abb757a08eb SHA512 60c98a82bbbbde8873f5d5f2d2ff49a2a0fb8787f22a392793decde5453bb887f31d3c7c1e2000c51aac0f192a8b400282903926cb05c20f0831c70d855244d1
-MISC metadata.xml 360 BLAKE2B f3f8ecb3bc2ed8eab2e2283967a5a7a94a5149302e8651e819204810bfc7fe43689f0b1c35824a737fbffbd5967845ca089a539dcd0b50704b6d5a219e3406a6 SHA512 2364901eb99136d33c8343c14fdd7d0f83e6328c311a5a8395068724a2d15d8dc6c6ade8026336ee92cf105e589d7fc960780f70c938f67f48c797503a956e5a
+EBUILD pycodestyle-2.7.0.ebuild 872 BLAKE2B b3796226136f4c0ba08cbee34fa7ac0983c2fec94bc58d3ba67217636f08a475eccd21d5736837c4fbfae1431318a93526803c5aef9baba57747684cddbab620 SHA512 3a3d33aaf458a61460dab66ad6a892d3a17309923e8b5404d05949d14b25916a6e1b19f61ce57e60cdfdff961b42583b08a7cb3aa1962554012c695c36736a90
+MISC metadata.xml 360 BLAKE2B 87e79216747cc8ad94f6862c47bc9dc89f7f2060f8386f4d7c8cc4ba27ac7da428bd90cb4ba063883e5ed158b82d50276579ea7201ce84bb165fd70018747225 SHA512 45f5de422ab2b65a88d3baa6c87411d4f5bb5adfd7c7d45fe1c28bfd45d8c3ab0b391eca1e5117c1301b32ca62ba023b04199ed5efe13b84d176004ef6ebe3ff
diff --git a/dev-python/pycodestyle/metadata.xml b/dev-python/pycodestyle/metadata.xml
index 27bc28dc8541..588a34161552 100644
--- a/dev-python/pycodestyle/metadata.xml
+++ b/dev-python/pycodestyle/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
diff --git a/dev-python/pycodestyle/pycodestyle-2.7.0.ebuild b/dev-python/pycodestyle/pycodestyle-2.7.0.ebuild
new file mode 100644
index 000000000000..e873c0815a43
--- /dev/null
+++ b/dev-python/pycodestyle/pycodestyle-2.7.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python style guide checker (fka pep8)"
+HOMEPAGE="https://pypi.org/project/pycodestyle/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py -v --statistics pycodestyle.py || die
+ PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py -v --max-doc-length=72 --testsuite=testsuite || die
+ PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py --doctest -v || die
+}