summaryrefslogtreecommitdiff
path: root/dev-python/pycodestyle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-30 22:42:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-30 22:42:58 +0100
commit3b4199328e240d392ef1f03900219cb88bdafcff (patch)
tree06007a008d485a5e0a169f2807b68f456e9df1b3 /dev-python/pycodestyle
parentaca0af8133e724b7edf0b5c6efe12c39077a3dc9 (diff)
gentoo auto-resync : 30:07:2023 - 22:42:58
Diffstat (limited to 'dev-python/pycodestyle')
-rw-r--r--dev-python/pycodestyle/Manifest2
-rw-r--r--dev-python/pycodestyle/pycodestyle-2.11.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pycodestyle/Manifest b/dev-python/pycodestyle/Manifest
index aa03ab723ed8..6180751c6b6b 100644
--- a/dev-python/pycodestyle/Manifest
+++ b/dev-python/pycodestyle/Manifest
@@ -1,3 +1,5 @@
DIST pycodestyle-2.10.0.tar.gz 101916 BLAKE2B 1dbf4c2ea9b1c606740fe1e9804b29100056bad25935182b43dd07d694bf3d321d63b17d2e308dc1ffaca1f4e3e46a4e8df3998424adc4e4a1a33862e608e153 SHA512 b0c3ee7ac56942db1e8cb5f3a59c2bd2a44b7467e73b46ab7b6f932603beefbbd29f2760ee49907447af1a5987dc1961f00788b01456bdd0aed7690e2d54446b
+DIST pycodestyle-2.11.0.gh.tar.gz 79772 BLAKE2B 5995cae91a9e1109b697fae840d1dccd4778096dded7357bdbca1a56b06a031fc524f638e91192564f127b2bc52e94c9e80b2437daac5a129db48f99ca701e48 SHA512 fd688544a7fb01a7e3f4f8cb411cf7bc5b6dfc357de616a2ef61944748ad670c239148766b8ea48a3c316396251ed8a8d8937446f400c28e631621a0d16d3cf5
EBUILD pycodestyle-2.10.0.ebuild 974 BLAKE2B 80a71f238f4b9835a7a54f6d7a837ab4d5ca50862a56bc58183decc4153206c463328ab0132161e0103a95bb4aabe0a15a8379410a4eb12c2352fbe50be8dc95 SHA512 45200bd20a0415c06119dbdf26ac561886d3b4dbc8c674c8cc2091d86a73e2e0a89b5aee3153d779fc8387d2cc868ab92f41fdc5ef6ab5ae80f7f00103619ec4
+EBUILD pycodestyle-2.11.0.ebuild 835 BLAKE2B 6f4b4d5a8275e554ec59079275b65d489cb88c6fbcb9fc8c960e6e014db66de2f87ca3de7acffef3d39a545188c8d44218e6e8b15fc53fdba10fdc91e1b865b8 SHA512 db32d903443cbf2ab4bfe0e77ee709821a7204acdba763afc4c3fa976ab049618d1a9e800bbeb0d60881e7cf825f3d58e4d18387e0faf465ced4e30b96b0f326
MISC metadata.xml 409 BLAKE2B 86d114cb53a68c8c24caebef1287bce1ae99cd652bca1fe2f19cce870c66490521329133a1fea47c79bd8c64d2bcd945022e31ac7db7885e9a4dea4d50f19a04 SHA512 e1de2014c44c8fdaf71ac26af406d27ab76cfd377dc20bb36e36bfbeab79f8e8981e8834e04b8e0bddd92d231b275e56e91d87570fee5ad426418a4abd00d4be
diff --git a/dev-python/pycodestyle/pycodestyle-2.11.0.ebuild b/dev-python/pycodestyle/pycodestyle-2.11.0.ebuild
new file mode 100644
index 000000000000..efb9462cf118
--- /dev/null
+++ b/dev-python/pycodestyle/pycodestyle-2.11.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python style guide checker (fka pep8)"
+HOMEPAGE="
+ https://pycodestyle.pycqa.org/en/latest/
+ https://github.com/PyCQA/pycodestyle/
+ https://pypi.org/project/pycodestyle/
+"
+# 2.11.0 broke sdist
+# https://github.com/PyCQA/pycodestyle/issues/1183
+SRC_URI="
+ https://github.com/PyCQA/pycodestyle/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest