summaryrefslogtreecommitdiff
path: root/dev-python/pyclipper
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/pyclipper
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/pyclipper')
-rw-r--r--dev-python/pyclipper/Manifest2
-rw-r--r--dev-python/pyclipper/pyclipper-1.1.0_p3-r1.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pyclipper/Manifest b/dev-python/pyclipper/Manifest
index 6ea28b3cdf94..d0984731b076 100644
--- a/dev-python/pyclipper/Manifest
+++ b/dev-python/pyclipper/Manifest
@@ -1,3 +1,5 @@
DIST pyclipper-1.1.0.tar.gz 53916 BLAKE2B 53b7b6609d602cdcbd8c8f4ceaed999c97e155747f7daeb630333f18fd2719040d118c8fa3d0e60a1ccd92c20aecb355ec9d4f9c22f66dc07b14a919f981f667 SHA512 53371bc2e0439f72ac4ebf96f833c4451d2b1924d7f9cddcbac79a0a6d6bd95ac1fb3fb08e3ea3fcf3ffe22cd718d31c7c528016605b275a3e80642e58546d74
+DIST pyclipper-1.1.0_p3.tar.gz 53353 BLAKE2B 1e510ab97ef98b83c763d4bc1154eb32f94bb035823ddcffef09fe32861c2384ccd6ffd29e5a31c0cabf71c801dd90d0176a68e93c6c2e2c9bff03c2be3fff33 SHA512 0b3c3f18593bafedaedf8a91411ba5d3d1c2ac55c949bca21e3a527ca0930eae5ea033a0f57337573a1106e2871a50dcb0176b959b98ad8ac58636c6d45f94a9
EBUILD pyclipper-1.1.0.ebuild 697 BLAKE2B eb94f08accf6b67bd82bcde3b794e49daaec73c905937bea4f31ec03446b8b4d3f72298ab1e891d79fbc260588ec47eb3e629774cb875868c22dd88688cf1355 SHA512 fd81e4272d19c9b9b67a3cd74a216ef84e9af8150b176235bfa320cca385fc9603e143b9f079591943cfd222e679d1207a11012cb6397732c8e9577ecf3dec4c
+EBUILD pyclipper-1.1.0_p3-r1.ebuild 933 BLAKE2B d20ce163bc0e9ca8907681b0532c19beacf20798d5d1be46c73d3339c380ca6f63550708d31ae34887e7b99b89c79803c18703d0e4d72c554c54f757c289932e SHA512 c90158af961554a99303a55eac43864b20a03af9201d5d2d81c7ea2289aa6994ca8f733c620a77555547b39487b14c895213b4328add1af4b4daa4fc828f4a31
MISC metadata.xml 243 BLAKE2B f40c5d69470d5136cba32e1ea6b2351ca1842a5d83381e0bef3e063e266c64bebb9ba85e1f155010e219b136c2827c989d9adf3b2c6b2f6ca265f03339c9a7ce SHA512 640630eb9d42c319ca1da37b03a03677a3dd4e48f28ce2690b64f6e4e7d5885cfda41d439f3f9d8b009be04891b043a5b0ac6f9d43b701f65c8fcc0e0613b04a
diff --git a/dev-python/pyclipper/pyclipper-1.1.0_p3-r1.ebuild b/dev-python/pyclipper/pyclipper-1.1.0_p3-r1.ebuild
new file mode 100644
index 000000000000..8aeb8a431546
--- /dev/null
+++ b/dev-python/pyclipper/pyclipper-1.1.0_p3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Cython wrapper for the C++ translation of the Angus Johnson's Clipper library"
+HOMEPAGE="https://github.com/fonttools/pyclipper"
+SRC_URI="https://github.com/fonttools/pyclipper/archive/${PV/_p/.post}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=""
+DEPEND=""
+
+distutils_enable_tests pytest
+
+S="${WORKDIR}/${P/_p/.post}"
+
+src_prepare() {
+ distutils-r1_src_prepare
+ export SETUPTOOLS_SCM_PRETEND_VERSION="${PV/_p/.post}"
+}