summaryrefslogtreecommitdiff
path: root/dev-python/pychroot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pychroot
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pychroot')
-rw-r--r--dev-python/pychroot/Manifest4
-rw-r--r--dev-python/pychroot/metadata.xml11
-rw-r--r--dev-python/pychroot/pychroot-0.9.18.ebuild49
-rw-r--r--dev-python/pychroot/pychroot-9999.ebuild46
4 files changed, 110 insertions, 0 deletions
diff --git a/dev-python/pychroot/Manifest b/dev-python/pychroot/Manifest
new file mode 100644
index 000000000000..caf8dac98440
--- /dev/null
+++ b/dev-python/pychroot/Manifest
@@ -0,0 +1,4 @@
+DIST pychroot-0.9.18.tar.gz 32879 BLAKE2B 769b3347bae3f7dfb47c0335015cc898ec851a3d45f774a4e21aeaf9b8d7937331bc69aa5bcbb298e76e7e51ffc2e55f049336fd90f6b08fc3bba87089f2205d SHA512 59c8750c9ba8d601eca485079c04d4153bba92531dbd30fba0104694e4435d76e65b762b76ef89a6a6f8908dd6054d1d95fe4be74825ac1c5a56e473370dfa41
+EBUILD pychroot-0.9.18.ebuild 1149 BLAKE2B 3a77de87563d777b6fb44603de847a5a8637949c10050d74e0217e76b045b59509a814df9c8585bde111a07930c92c79d2b9507ba8acc3002851689bb8f7164a SHA512 c019b5e5d73cec26a74cd363c2784a4ccb3e8bda0aa5ae472e60f6165b533ead1ad54a67740c3021c17980d11729b66460f7a0ca244eec62c576ba649ab3bd97
+EBUILD pychroot-9999.ebuild 1071 BLAKE2B 8634887e73de39ac708432b0f0a96e613325f938d68ae82a361e6f56a9eb50db4d7722f7e068379d768e92ddc5ba69e1b58008a2ce0ffa3386b827af42b0eafd SHA512 2009fd14e347b0f543b239568b7a3775bbd9fa3e1b70510cd45d43c4c687cf4c5af5c551e23a141a8bd2e716480a59937b6a050508e76a80ebb9a007a2a5f957
+MISC metadata.xml 337 BLAKE2B 3c60605dbe9296fe7f6c285123fa649b47c4997af6f715cefcb5047817ddff55f15c4813c2c33dcffa4e771ab3d0afb83bd88506d915e313b237e51ca4729c70 SHA512 4b0da70f35cd4983f6f5cd8aa02e5555b770d3bc2b7e90a8e8287c64593fadf1fe532cef6becce24de96766f94d24d8ec731ac3acff6f42a2c7b06c3e1e1e4d0
diff --git a/dev-python/pychroot/metadata.xml b/dev-python/pychroot/metadata.xml
new file mode 100644
index 000000000000..3f73551c788d
--- /dev/null
+++ b/dev-python/pychroot/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pkgcore/pychroot</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pychroot/pychroot-0.9.18.ebuild b/dev-python/pychroot/pychroot-0.9.18.ebuild
new file mode 100644
index 000000000000..6cb401faea51
--- /dev/null
+++ b/dev-python/pychroot/pychroot-0.9.18.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pychroot.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a python library and cli tool that simplify chroot handling"
+HOMEPAGE="https://github.com/pkgcore/pychroot"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND="=dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND=">=dev-python/snakeoil-0.7.4[${PYTHON_USEDEP}]"
+fi
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+[[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ esetup.py build_man
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst README.rst )
+ distutils-r1_python_install install_man
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pychroot/pychroot-9999.ebuild b/dev-python/pychroot/pychroot-9999.ebuild
new file mode 100644
index 000000000000..57a2af631a20
--- /dev/null
+++ b/dev-python/pychroot/pychroot-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pychroot.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a python library and cli tool that simplify chroot handling"
+HOMEPAGE="https://github.com/pkgcore/pychroot"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND="=dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND=">=dev-python/snakeoil-0.8.0[${PYTHON_USEDEP}]"
+fi
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+[[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ esetup.py build_man
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst README.rst )
+ distutils-r1_python_install install_man
+ distutils-r1_python_install_all
+}