summaryrefslogtreecommitdiff
path: root/dev-python/pychm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pychm
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pychm')
-rw-r--r--dev-python/pychm/Manifest3
-rw-r--r--dev-python/pychm/metadata.xml22
-rw-r--r--dev-python/pychm/pychm-0.8.4-r1.ebuild20
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pychm/Manifest b/dev-python/pychm/Manifest
new file mode 100644
index 000000000000..4204c2bb2fdc
--- /dev/null
+++ b/dev-python/pychm/Manifest
@@ -0,0 +1,3 @@
+DIST pychm-0.8.4.tar.gz 28803 BLAKE2B c6b66c83b1bd5b20280cb60636ccf2780f665fd589b107542c887fc791642f780701b84c8863883e02496c626b92552e3bbfdacd025723fccdb7947de62ada61 SHA512 0c0c107e59ea9f5fef97a0c2869349b5e90fc9eb7a37c35e8a929eaf764c7abe5a06a389340a912b9ba2f71172f3c94a78da016707bb201bbd07bdc3feddfe0d
+EBUILD pychm-0.8.4-r1.ebuild 428 BLAKE2B bc58690f32d7f106dfe4ec6f665fe240352ea747324c1c208b79ef6eee7f414663370621d5a4d23bda08aa80e3f99d156b74b1f3433d226a42e86f1534c7e9e9 SHA512 b854fa1ef64b8f82d589e0018014548570d89f981c9e47dccd10e3d23e891b08b4e4bc16b89ddadf6ceaaa798046024f14a58433354a7eee454c91f80ec0466e
+MISC metadata.xml 981 BLAKE2B 94814a08cf697f65b50efcb43de52d9271f75bda4b058cfc6b5010cf5a159f1d48add1c305ca4318aeb7993c9e689ebe09ad0c1fbc0eb485ad58868fe427428e SHA512 1ff1b79c5b18961a5ed7aefc06c367968d05e14c47e3b4ac898c62ef8b444c75d092b1a10213197523bb107e8d2a5e04fc19c90b1381420a8d40659c6f950ebe
diff --git a/dev-python/pychm/metadata.xml b/dev-python/pychm/metadata.xml
new file mode 100644
index 000000000000..5c6fd6400c88
--- /dev/null
+++ b/dev-python/pychm/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+The chm package provides three modules, chm, chmlib and extra, which
+provide access to the API implemented by the C library chmlib and some
+additional classes and functions. They are used to access MS-ITSS
+encoded files - Compressed Html Help files (.chm).
+</longdescription>
+ <longdescription lang="ja">
+Chmパッケージは、C言語ライブラリChmのAPI実装とそれに幾つか拡張されたクラスと関数
+にアクセスする手段のchm, chmlib, extraの3つのモジュールを提供します。MS-ITSSエン
+コード・ファイルに使われています。-- Compressed Html Help ファイル (.chm)。
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">gnochm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pychm/pychm-0.8.4-r1.ebuild b/dev-python/pychm/pychm-0.8.4-r1.ebuild
new file mode 100644
index 000000000000..eccfb6bb99ae
--- /dev/null
+++ b/dev-python/pychm/pychm-0.8.4-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the chmlib library"
+HOMEPAGE="http://gnochm.sourceforge.net/pychm.html"
+SRC_URI="mirror://sourceforge/gnochm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="dev-libs/chmlib"
+RDEPEND="${DEPEND}"