summaryrefslogtreecommitdiff
path: root/dev-python/pychm/pychm-0.8.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-python/pychm/pychm-0.8.6.ebuild
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-python/pychm/pychm-0.8.6.ebuild')
-rw-r--r--dev-python/pychm/pychm-0.8.6.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/pychm/pychm-0.8.6.ebuild b/dev-python/pychm/pychm-0.8.6.ebuild
index 90adc71074bd..3957210dc1f6 100644
--- a/dev-python/pychm/pychm-0.8.6.ebuild
+++ b/dev-python/pychm/pychm-0.8.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
@@ -19,3 +19,11 @@ RDEPEND="dev-libs/chmlib"
DEPEND="${RDEPEND}"
distutils_enable_tests pytest
+
+src_test() {
+ # need to avoid relative import of 'chm' directory but tests rely
+ # on locating files relatively via tests/...
+ mv tests .. || die
+ cd .. || die
+ distutils-r1_src_test
+}