summaryrefslogtreecommitdiff
path: root/dev-python/pycdio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/pycdio
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/pycdio')
-rw-r--r--dev-python/pycdio/Manifest4
-rw-r--r--dev-python/pycdio/metadata.xml1
-rw-r--r--dev-python/pycdio/pycdio-2.1.0.ebuild6
3 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/pycdio/Manifest b/dev-python/pycdio/Manifest
index 8018a496d4d1..ec818c08d644 100644
--- a/dev-python/pycdio/Manifest
+++ b/dev-python/pycdio/Manifest
@@ -1,3 +1,3 @@
DIST pycdio-2.1.0.tar.gz 241434 BLAKE2B eb981fdf52b205e14c6dd353ac4aca9a9e82dba6967a53b9059f8a265ef80832fe7236d68b2af7a6e408665fce0f5ed3541289e0b7d282834c4feb8e6b428fc4 SHA512 dc18fbd212f7040b8b06efaf263b17568e9c2d089cff7dfc4dda50a7225059e44c9c86e2d81ade92cf09c823f7189b5723fb601cb12f0884dc04e9f5418c5927
-EBUILD pycdio-2.1.0.ebuild 1058 BLAKE2B c47bd149fd052b14aa2fc46420fd576d4aa734f7d58fc28a0f4337698701812e643d1924419120565bf420ddeef52e3534ddc3675ea3c5ab544fe97d82d1e14f SHA512 c252cf5cd93d192d4f1089a94a3f2175abc64826a73d800ca293b2737d1435948701f5564294361e7836b60787828dbb066c4cd512a4d567a1ed38d3af0d4106
-MISC metadata.xml 551 BLAKE2B cb87788bd6a8cd15e83547dba1f44f710a27db24b962790484b252553e6e3563493000a8f9e17ad72bdc205d7692aac19f6aefefd4b586dc2c5469c6045aff1a SHA512 e74e3c72794ff1356a6d91482162adfbed24320821e8df6ea4043416f586f6e30f91980e4c15281e59c6428a64550986eb69007da30390de6d7de51b250900c7
+EBUILD pycdio-2.1.0.ebuild 1089 BLAKE2B d50db41fa7d845782e0f22972c7888362bb7fd52192445685499ec131b0d7c35e109ae2fe061a67fdb0be1019d15d0478fbdfd4f1eec37209b6902e1650a744a SHA512 8725ca8e1de99a411a78b88a0a58f23af4c8da843f79c0c0d39312326d0190c88a7925c8badbd2d2ae3c5f332b0fd79a8b596223690bd8b7f93b3761bf15870d
+MISC metadata.xml 603 BLAKE2B cb7f62b66b44c9e5a0f761b69c44d94a8d55c178b65499c1ed5cf6854a2ef4ff774aa35ef047d84b03450ed9bad349f5591c13294e2676fde1e5a36b6643236d SHA512 6a259fc05469d51ca3ae442570ac2d1170bebae2c01466dd626579a83f9e7adc615c9eecfd2cba1542728cfdbc3e5a4f41671038c4a6584504b96a4be01fa979
diff --git a/dev-python/pycdio/metadata.xml b/dev-python/pycdio/metadata.xml
index 6d6623b91d3b..c20b0e40f33b 100644
--- a/dev-python/pycdio/metadata.xml
+++ b/dev-python/pycdio/metadata.xml
@@ -10,5 +10,6 @@
device-dependent properties of a CD-ROM can use this library.</longdescription>
<upstream>
<remote-id type="pypi">pycdio</remote-id>
+ <remote-id type="github">rocky/pycdio</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/pycdio/pycdio-2.1.0.ebuild b/dev-python/pycdio/pycdio-2.1.0.ebuild
index 827ab2874412..5652e3e6c98c 100644
--- a/dev-python/pycdio/pycdio-2.1.0.ebuild
+++ b/dev-python/pycdio/pycdio-2.1.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
DESCRIPTION="Python OO interface to libcdio (CD Input and Control library)"
@@ -19,6 +19,8 @@ BDEPEND="dev-lang/swig"
RDEPEND=">=dev-libs/libcdio-2.0.0"
DEPEND="${RDEPEND}"
+distutils_enable_tests nose
+
python_prepare_all() {
# Remove obsolete sys.path and adjust 'data' paths in examples.
sed -i \