summaryrefslogtreecommitdiff
path: root/dev-python/pycdio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /dev-python/pycdio
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'dev-python/pycdio')
-rw-r--r--dev-python/pycdio/Manifest2
-rw-r--r--dev-python/pycdio/pycdio-2.0.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pycdio/Manifest b/dev-python/pycdio/Manifest
index edc58bbabb27..15d098f6c004 100644
--- a/dev-python/pycdio/Manifest
+++ b/dev-python/pycdio/Manifest
@@ -1,3 +1,5 @@
DIST pycdio-0.20.tar.gz 197736 BLAKE2B 98ca603dba80a13dc3d1805869e190b9defa1a5c50b398ac4c7122629101df92ca8ad0071101bd8d53cbf48f41211017350a89944944028052899911b32d54e8 SHA512 b53a535440008dc637b31fd2cda22845c91b98e78c30f90c866af3b9bf7cb3faad39f0784b5063a39bd97bb18fc58c75ad0833d53421182d408c2889c491846b
+DIST pycdio-2.0.0.tar.gz 242131 BLAKE2B cbe014ea42ecf2b84f736d4b714f0fa76c94b10e0b16da148334521ac4a141db606793be541ee532b7542e58256377bbc6139945232942ef2ef0beeda4b66ef5 SHA512 b73d49e143e4b5ebf5e8514d526a57f71d004b9ce4298743bb109902ee9551fa586384a236b26da9cd86284b2aa8c31fb02a324a1cebc03f2071d06fbd3e3285
EBUILD pycdio-0.20-r1.ebuild 1111 BLAKE2B 7fa1e7b201a208f754bbfaff91279e52f6cb31ce907f7550511baf52ad8436729fcc2433b420940cd775cd8f05cb71ffaa8cfd1b7c1e0724a081a1392ddbd51a SHA512 d543af529927c957600b6a15404c851aec2b5a32589f1960ec45fdc5031450cdbd5af0428837a273db8304b59c4eb255c438201b21971da00cae6bba8a336f37
+EBUILD pycdio-2.0.0.ebuild 1114 BLAKE2B 9a8056133113ae74c11492eb999a887ade703aadb8d85b39bcbf947dbb51c7ef0c93b6a80aaac1336594b40493c977422962fbf35b35e7d53d5183c8f273ff67 SHA512 4c22364664fbc7b263ba35fd0ac645c49a411022cfb67476495993206a6aa527089ddcd18ef83555ccd0d6e358608f95cb3f504ef464a6dc824d013fe304b4c8
MISC metadata.xml 551 BLAKE2B cb87788bd6a8cd15e83547dba1f44f710a27db24b962790484b252553e6e3563493000a8f9e17ad72bdc205d7692aac19f6aefefd4b586dc2c5469c6045aff1a SHA512 e74e3c72794ff1356a6d91482162adfbed24320821e8df6ea4043416f586f6e30f91980e4c15281e59c6428a64550986eb69007da30390de6d7de51b250900c7
diff --git a/dev-python/pycdio/pycdio-2.0.0.ebuild b/dev-python/pycdio/pycdio-2.0.0.ebuild
new file mode 100644
index 000000000000..38c8a750aa2a
--- /dev/null
+++ b/dev-python/pycdio/pycdio-2.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python OO interface to libcdio (CD Input and Control library)"
+HOMEPAGE="https://savannah.gnu.org/projects/libcdio/ https://pypi.org/project/pycdio/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-libs/libcdio-0.90"
+
+DEPEND="
+ ${RDEPEND}
+ dev-lang/swig
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RESTRICT="test" # currently tests fail
+
+python_prepare_all() {
+ append-cflags -fno-strict-aliasing
+ # Remove obsolete sys.path and adjust 'data' paths in examples.
+ sed -i \
+ -e "s:^sys.path.insert.*::" \
+ -e "s:\.\./data:./data:g" \
+ example/*.py || die
+
+ # Disable failing tests.
+ sed -i -e "s/test_get_set/_&/" test/test-cdtext.py || die
+ sed -i -e "s/test_fs/_&/" test/test-isocopy.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all(){
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}