summaryrefslogtreecommitdiff
path: root/dev-python/pycdio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-31 20:20:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-31 20:20:25 +0000
commitc4b414ba84991b36b62c066b701385eaf44cdd49 (patch)
tree5cbdb7a51f1abb965fdfe90b686f8130e100afaa /dev-python/pycdio
parentea5bad4d0ba1eb937df22adb7f6cc57ea77f03d8 (diff)
gentoo auto-resync : 31:12:2022 - 20:20:25
Diffstat (limited to 'dev-python/pycdio')
-rw-r--r--dev-python/pycdio/Manifest1
-rw-r--r--dev-python/pycdio/pycdio-2.1.1-r1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pycdio/Manifest b/dev-python/pycdio/Manifest
index 00ecba9a2e66..782bcb2fe526 100644
--- a/dev-python/pycdio/Manifest
+++ b/dev-python/pycdio/Manifest
@@ -1,3 +1,4 @@
DIST pycdio-2.1.1.tar.gz 246562 BLAKE2B 7dbbf384f9d70aade922172c6dd070229c1ffc65a76a491c45f91ec176bced9af0dc0e08f50f8ad78828273de14166eae886b402f282a10bdad3f8302276ef01 SHA512 4c756b1c2f39332add86e01af129ccb608178306be42c9719c163b6bad0ba4de3916ac477c6866450890e094b14a2689a24e7d19bcf13846330555c2bb1feaa7
+EBUILD pycdio-2.1.1-r1.ebuild 1051 BLAKE2B 36975259c16998802678cfb73a4e6c90d6a7336e585050d84c47ef52a9b58453b5ed9a437aadc0d6b7f5c529ef1ef7f9f2c5ef9271ed82619c7f7500293ccb6e SHA512 b8f6cba3eaf47936c32e4ea734fa996354e7c3c2c95792b8defb0cd612ae6908d92e368ff58a798acde40d9e567cad002276be133b75ead15cfd7ac3168cd3bc
EBUILD pycdio-2.1.1.ebuild 948 BLAKE2B 8649bda8abe1d245b80abd9a4058d36fd0ce40fc7187768f16a86527b22b1ed8b7faee778cb4ab33644a9eff0d1ea7f5179eb31637d13ee454ee93eb320e5695 SHA512 6cf9dcd99dcc0a5dfa48b916f75bc01daaf1081a523e0961db38c7d2aa9e41933e65ce0f3edb71a92121985e148eb650f93ce56bd33c979766bb631603a8fc5f
MISC metadata.xml 653 BLAKE2B 8cb2e5d7b92c99876fba8c0227e12c40af546d4a10fe108b04f47d4e718f08629ddf06af30458952e251b16310d01e1470966b14af96de39441a1879771b85a4 SHA512 30186cf5dcd94811a192207a368d5caf6c34e0c2de87f9de45d843c9c2327d9caae1f7d1ffa17a6debf9b28ef4d9f3bbb4e136c4894cb344aea59be4f8e4e406
diff --git a/dev-python/pycdio/pycdio-2.1.1-r1.ebuild b/dev-python/pycdio/pycdio-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..94f8d9a685c4
--- /dev/null
+++ b/dev-python/pycdio/pycdio-2.1.1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python OO interface to libcdio (CD Input and Control library)"
+HOMEPAGE="
+ https://savannah.gnu.org/projects/libcdio/
+ https://pypi.org/project/pycdio/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="
+ >=dev-libs/libcdio-2.0.0
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/swig
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Remove obsolete sys.path and adjust 'data' paths in examples.
+ sed -i \
+ -e "s:^sys.path.insert.*::" \
+ -e "s:\.\./data:./data:g" \
+ example/*.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest -opython_files='test-*.py'
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}