summaryrefslogtreecommitdiff
path: root/dev-python/pycares
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-27 02:00:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-27 02:00:01 +0000
commitead7697a01fd631b56240b2d58aedd98ba7f92d3 (patch)
treec73ecbedbb9db967a7dff614f5e8b79eacb79f5d /dev-python/pycares
parent403335d7014372971e9e9267493a808d08bab48e (diff)
gentoo auto-resync : 27:11:2024 - 02:00:00
Diffstat (limited to 'dev-python/pycares')
-rw-r--r--dev-python/pycares/Manifest2
-rw-r--r--dev-python/pycares/pycares-4.5.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pycares/Manifest b/dev-python/pycares/Manifest
index 194a152bcb43..83a485c79f9e 100644
--- a/dev-python/pycares/Manifest
+++ b/dev-python/pycares/Manifest
@@ -1,3 +1,5 @@
DIST pycares-4.4.0.tar.gz 821630 BLAKE2B c2bddc54db9cd6ba92d7c4fb3809609a8a3526bab68e4cf48f0fee2e7473828f70ca696be11b904e9c3f9241de8b13568cd0317c8cb305a4aca7356f1b74cfb5 SHA512 db387f21975d015e0fcb01972ffb018476d51331a7a49bb4c0bf23ccfa13dff3f8b9c21d5f11da8ece3018debf36b1cddea032ef860353203cf38ab2b3d01e8a
+DIST pycares-4.5.0.tar.gz 821554 BLAKE2B 75e178d288779876becae08af08218364f13fd6b2e03c4dc6a67e5e330e26ef17fee831d0a9329a66cc9358fcc167808379b6881a0f8e18bd76a8e6ed2587c60 SHA512 224c8807396590e07fbe10c3f26eae1a457bf4969788b432b4367898382a5c68f2d7ef33f62e31dea772491319287ff1685f3cb0eb78f9c07cec80d50864e617
EBUILD pycares-4.4.0.ebuild 1243 BLAKE2B d7cb383b426031a9a4133f2a57b6c634db5b0f70a1bbebb38971babfc232e72f1d2f520a8b59faa1809922df12410860f92775fe65f28621888cfa8bbe0187be SHA512 fc42a8f4b988710d8293ec822e0b9fac518c6e26d3637e91448c164d10c5f6822059ccee2577d6afd991a3c62ff2da73e47a57a3ba4233add9c8a0686840d0ef
+EBUILD pycares-4.5.0.ebuild 1251 BLAKE2B 2ec7b7bf73f6324eae657c8687fb7b34e8522e1f562305ca06c143c48da9daa9ce643f9cad033f63e47eb72da4de6401963526cc351d2b170df05f2aee14f8f2 SHA512 d6aca31312ac5712b9dfd1d8f336ba5cbd4f4f46bb2507fc95137e44a7d883fba38fda8483e3cfed8655d1ea12f2ea83d15422d7e4402b84f4c0bef3fc936af2
MISC metadata.xml 444 BLAKE2B a68f545c6f704176b98ebb3665e2f56e4879016ea4ffa4f342954d568d6fe76ad67bcf9d521f694b8fc0f199bff50969eb646554fff4a78f8644ac44edda0cdf SHA512 fe893795f2031639d9fa27efcb8afbb5a3e0ac2eb2a05f0465391813d60fba07372633e40136ce38eb429bae95d1ae5dccecd0aba228537553524343133dd202
diff --git a/dev-python/pycares/pycares-4.5.0.ebuild b/dev-python/pycares/pycares-4.5.0.ebuild
new file mode 100644
index 000000000000..3f74355a5b6d
--- /dev/null
+++ b/dev-python/pycares/pycares-4.5.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python interface for c-ares"
+HOMEPAGE="
+ https://github.com/saghul/pycares/
+ https://pypi.org/project/pycares/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+# Tests fail with network-sandbox, since they try to resolve google.com
+PROPERTIES="test_network"
+RESTRICT="test"
+
+DEPEND="
+ net-dns/c-ares:=
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
+"
+RDEPEND="
+ dev-python/idna[${PYTHON_USEDEP}]
+ ${DEPEND}
+ ${BDEPEND}
+"
+BDEPEND+="
+ test? (
+ dev-python/idna[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # regression due to Internet changing (probably)
+ # https://github.com/saghul/pycares/issues/187
+ tests/test_all.py::DNSTest::test_query_class_chaos
+ tests/test_all.py::DNSTest::test_idna_encoding_query_a
+ tests/test_all.py::DNSTest::test_query_txt_chunked
+ # TODO
+ tests/test_all.py::DNSTest::test_custom_resolvconf
+)
+
+export PYCARES_USE_SYSTEM_LIB=1