summaryrefslogtreecommitdiff
path: root/dev-python/pycairo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /dev-python/pycairo
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'dev-python/pycairo')
-rw-r--r--dev-python/pycairo/Manifest2
-rw-r--r--dev-python/pycairo/pycairo-1.16.1.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/pycairo/Manifest b/dev-python/pycairo/Manifest
index 098eaf38a9cd..3ec4c3f25567 100644
--- a/dev-python/pycairo/Manifest
+++ b/dev-python/pycairo/Manifest
@@ -1,5 +1,7 @@
DIST pycairo-1.15.3.tar.gz 177056 BLAKE2B cba4a212c3537d5718a73742468444b01372902d86f88558cf63ab2ec1999dac036b349d84dff0bdcae5126998c5e921f05bab54b708a29ca2381b8d1371ac44 SHA512 1fc75d193eacb976f2e5a594aa07409a0f80ccb21921065c1794961143785eed48be1966d2d2d3e2d0428f9b4e956994dd851d21f3c3cb91fbc27b007a901ce8
DIST pycairo-1.15.4.tar.gz 178436 BLAKE2B 23c5064f537b8d8be12bb64df375c1d5be8962f80adf2437115dde59c18c3755a693b0cb8b3bee248ce8c906f23acfa264f2da6e02770bc59d823beba1bc9e7b SHA512 7e785d23393a8d0c5aca9a4440eb64b0eca9a60c1a18b0dc8452edd6de9422c743d082530387bcbedd34d52377d0892ad395998e9467ba08e22c318684cbee34
+DIST pycairo-1.16.1.tar.gz 180516 BLAKE2B 0a144eb6f17bc6621b16e00ddd40784e16e5950667d57927ee238e76d4966e828d8da3d6983e09655d3eb2d3526dcb8a44da6c48e14268cd78e1d463e59b8779 SHA512 757870dd28d037d0af96308e2d1eb5d55ca2025aabda66031dc77790692e420b07802ccdbeefee430825553ed993830bc6f74de83b717e6fa876108f7b54e144
EBUILD pycairo-1.15.3.ebuild 1607 BLAKE2B 0fff3a866314ff4dcf9fdfdfaa865b504859be58ddbce3e7ffc64568d744b5ef0cf7558e045aaf1d9c474c457d9ce50c19c978b27accfe2e52e94cf00a3c9879 SHA512 a61afcf8066d8b14d1b117e7952d82d1265668005f976b20a1d53fcabf3d5bd792a62cc24b765d3113016f9b1870ad7e922d05ee017868fcaed03109866a9618
EBUILD pycairo-1.15.4.ebuild 1616 BLAKE2B f587a875f864f1d08465f421e48b2935378dfe9c2e5a6d421aa39b1d00f11c6622fae6e0fe95bc3bc79a8126b069f77599daa5a2c191ee47399d58d52fb1753d SHA512 f8fc6a76feb2a2544c558965a2004151e8a259de7466195c02a18657e614fd956b94b21c1038a5868a74c904f8fe20f3eb06c9c352b73a83688d6fcf8ff57c0b
+EBUILD pycairo-1.16.1.ebuild 1625 BLAKE2B ce04c871a936b4bbe291c36e6cc40b6e307b609a2e415e96921f8b6b44b8524bebdcb11c57575cfcfaeaaa11f96c69f232950fc960a891422c202107f061a0ed SHA512 c6dc09c531862cccbb5f5debcffe8f2bd92c6022439d36e1e2496fbb8654bf18e2db9ec92ab1064b4d561a4e453e6fbd5d21587691e74e796609f00c6091de27
MISC metadata.xml 246 BLAKE2B 3a28b3bb42a0352827a446ea608867a7782fe682458527ef441a528a22c9f951dc203639934a69ffb520f63aadce3037df28bf8c5304b3a5921b336142f9f246 SHA512 3245fb694492b2f698fb63aac02e66fb8a94fe35eabda45df4790bec043a1ea552e112315334001902f070093bb73e7b741aa3004757404aed97ebdb86cc9fbc
diff --git a/dev-python/pycairo/pycairo-1.16.1.ebuild b/dev-python/pycairo/pycairo-1.16.1.ebuild
new file mode 100644
index 000000000000..ec09aca8d651
--- /dev/null
+++ b/dev-python/pycairo/pycairo-1.16.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the cairo library"
+HOMEPAGE="https://www.cairographics.org/pycairo/ https://github.com/pygobject/pycairo"
+SRC_URI="https://github.com/pygobject/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples test xcb"
+
+# Note: xpyb is used as the C header, not Python modules
+RDEPEND="
+ >=x11-libs/cairo-1.13.1[svg,xcb?]
+"
+DEPEND="${RDEPEND}
+ xcb? ( $(python_gen_cond_dep '>=x11-libs/xpyb-1.3' 'python2*') )
+ doc? ( dev-python/sphinx )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Fix pkgconfig path
+ sed -i -e "/libdir =/s:\"lib\":\"$(get_libdir)\":" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local enable_xpyb
+ python_is_python3 || enable_xpyb=$(usex xcb "--enable-xpyb" "")
+
+ esetup.py build ${enable_xpyb}
+}
+
+python_compile_all() {
+ use doc && emake -C docs
+}
+
+python_test() {
+ local enable_xpyb
+ python_is_python3 || enable_xpyb=$(usex xcb "--enable-xpyb" "")
+
+ esetup.py test ${enable_xpyb}
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/. )
+
+ if use examples; then
+ dodoc -r examples
+ fi
+
+ distutils-r1_python_install_all
+}