summaryrefslogtreecommitdiff
path: root/dev-python/pycairo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/pycairo
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/pycairo')
-rw-r--r--dev-python/pycairo/Manifest2
-rw-r--r--dev-python/pycairo/pycairo-1.20.1.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pycairo/Manifest b/dev-python/pycairo/Manifest
index a2d133fc2ca3..bb7944768255 100644
--- a/dev-python/pycairo/Manifest
+++ b/dev-python/pycairo/Manifest
@@ -1,3 +1,5 @@
DIST pycairo-1.20.0.tar.gz 344370 BLAKE2B b72a3dfd3ad6332f6be2c0fc0650ef87d97a51881bd239421cdb6355016e952093f9fa05b7872d7cce4a50bc4bac27ff0fb4c11e446e51ada9d7c1adc019a175 SHA512 d32d008b741653d02324b206a438f5fd85f2a433201d6f8b98c8f1adc712abea611a4b5ed95c55258efb662dc579eed6b2f752b10d9fc2b6a7c8e5edd19e5266
+DIST pycairo-1.20.1.tar.gz 344639 BLAKE2B 7327a1b9aacc62eb7b2630ac2b9ce43ad7a44e60cb749b60a2973fb9036a84c1f3f4264da428d720158a5e32cd47f679d5956ebf3ce094e75d742584a68adda4 SHA512 bb2340170c1d39d50dd8ceeb1b6ceadd96ddbd27d78a8a5b7dadf7dc427558d766f65d62e1ceeae19ab200e7ffb5ad122b5e51daa8ef9bff08fcd97a44005697
EBUILD pycairo-1.20.0.ebuild 1114 BLAKE2B 9d4513890596f702d48fcf67a67dcbd3026759afd9b5e209bcd4a3c1ac80cd1afe6ee0b513806a4517c6cc4ff683337ef4a561c5cb4fceeb73bed629ab31e9bd SHA512 117dfeae67a2586aa32ad8a14eea43e895cc2ae010516234228c5509919adc3de3ccc1a9034ef05abed374ffb76d74d83a86e0b8c124ec68bdb9b5140e4a02f8
+EBUILD pycairo-1.20.1.ebuild 1122 BLAKE2B da9b18fef5d40e4435a005bc0f0d7337af55feb65b460b161f11430e488cbae83b287fae6270c8ab4770955cb58f3703e445ba4064fe293e868cfdbdfd73e5a6 SHA512 4a3b82e0baebb7b431daf0675648df00781df81e5a80f3536fd66e861f4d4dca8db92c3a0d428d9ebf9531cbefa621dac92932bb91507c30e54ca51559962281
MISC metadata.xml 310 BLAKE2B f27144a3f463297efa01ba4b6d7198f455c9e62470e56e004cb2cea621e4f1f7d3adfc45099a60fe54d670debd0cce4aa68e2b34e756df8d593a150ac040d97f SHA512 0280f0bba6101b163ec1304d7f8fbc36d00d86cd7ce6f8c671dee74f7931aa363f5887c85cd8d582d4ba0cb78753a61efdbe38e072d68511ba3a66ac36aa490b
diff --git a/dev-python/pycairo/pycairo-1.20.1.ebuild b/dev-python/pycairo/pycairo-1.20.1.ebuild
new file mode 100644
index 000000000000..1e68e62256d3
--- /dev/null
+++ b/dev-python/pycairo/pycairo-1.20.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the cairo library"
+HOMEPAGE="https://www.cairographics.org/pycairo/ https://github.com/pygobject/pycairo"
+SRC_URI="https://github.com/pygobject/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=x11-libs/cairo-1.15.10[svg]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests setup.py
+
+python_install() {
+ distutils-r1_python_install \
+ install_pkgconfig --pkgconfigdir="${EPREFIX}/usr/$(get_libdir)/pkgconfig"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ fi
+
+ distutils-r1_python_install_all
+}