summaryrefslogtreecommitdiff
path: root/dev-python/pycairo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-16 08:45:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-16 08:45:29 +0100
commit79851ef7da5ffce7aed667c8c49a1ce04333619e (patch)
treed02a27f205d4bf84ecc872e84d0580f49708a86c /dev-python/pycairo
parentdfd0139069bb79941b882fe714d38b7fc8dcdb16 (diff)
gentoo auto-resync : 16:04:2025 - 08:45:29
Diffstat (limited to 'dev-python/pycairo')
-rw-r--r--dev-python/pycairo/Manifest2
-rw-r--r--dev-python/pycairo/pycairo-1.28.0.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/pycairo/Manifest b/dev-python/pycairo/Manifest
index dc877d1c065b..baab55169dd4 100644
--- a/dev-python/pycairo/Manifest
+++ b/dev-python/pycairo/Manifest
@@ -1,3 +1,5 @@
DIST pycairo-1.27.0.tar.gz 661450 BLAKE2B cc1ef54057d02f3e25fed010c995e4fe400ccdf3a5d2f241c029ded167c5db2560a4d9c8cb09b2f0519e674b5962f2244f0570401f45743fe1ec61d5a8982227 SHA512 1b077917b1d99262da1c1d2ff85ae841dd0ff715925a5a20032162aa876576d966fc6b30c154343cc45f104cce243887de9b5f14af1e15775cb71b6c11e553a6
+DIST pycairo-1.28.0.tar.gz 662477 BLAKE2B 26ab0ab926bc209c33eeff2f7578d31ffce138111e923f6bc8e31a5e318f7ead9d0350ee5717e3774c65eb8ac9f3324ff0446c316469796dc866c3530ef2d0dc SHA512 d3fcb6641ad6dcf9b804dbc2a372f653619512e139fb7a196bb1219b00f60e79e5d60fbbddc2e6a0afb959f9fcb37f1f3c460ad6331274581cb241434865b5a5
EBUILD pycairo-1.27.0-r1.ebuild 1447 BLAKE2B 9f80ae986df29867e9e03f43268300e266ea7711bc341e4db95718b691956a5ed3410a63821bd193df32cbee37d684570fa780e6de18b63b1f6e280ea75d4881 SHA512 ee6fa50afb6c31eb28ab1551daca097f9eb7cd56d2d0c0186f2140d8c9e011fe7f17acc7caac283cad06ca428f1d28050d58d81355f317edfe47cb346564aa2d
+EBUILD pycairo-1.28.0.ebuild 1455 BLAKE2B a2d4e815829eb79f935ea53b2b1d2aec39228d4f1ce7143abc1c39c819bc4a8459bf62dbbf2af41e97d93c0ba657c7897ea0e75a4c00aa1d9039e456694cd80a SHA512 dc51f2f25332c2fa82fe1036b953ed33520ff4d0916da2c407385db9a51d0bc30bcca07b0f0aeb6f50a9499193c571f48896868ffe50c19bb1e7e4e45ffa4db9
MISC metadata.xml 368 BLAKE2B 5e0f85e23bc56113927d28072c7178d27fc058b1e90851150c55e9e713edb96dd5daa79df8423f6719032538c9448d8afa9b750961bd82a5bcfae2d5e228c6b6 SHA512 c1e81ed2f535c8050f18950a57b71aa871b965c57d1e5ca8e8a4c48ecd643bc9ec326e046c1aea9f3f41124b9fe765a0b9b46a541c28f325cae7038cea66d086
diff --git a/dev-python/pycairo/pycairo-1.28.0.ebuild b/dev-python/pycairo/pycairo-1.28.0.ebuild
new file mode 100644
index 000000000000..1f04f82bf43b
--- /dev/null
+++ b/dev-python/pycairo/pycairo-1.28.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( python3_{10..13} pypy3 pypy3_11 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit meson distutils-r1
+
+DESCRIPTION="Python bindings for the cairo library"
+HOMEPAGE="
+ https://www.cairographics.org/pycairo/
+ https://github.com/pygobject/pycairo/
+ https://pypi.org/project/pycairo/
+"
+SRC_URI="
+ https://github.com/pygobject/${PN}/releases/download/v${PV}/${P}.tar.gz
+"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="X examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=x11-libs/cairo-1.15.10[svg(+),X=]
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_compile() {
+ local emesonargs=(
+ # TODO: move that to the eclass?
+ -Dpython.bytecompile=2
+ -Dtests="$(usex test true false)"
+ )
+
+ meson_src_configure
+ meson_src_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install() {
+ meson_src_install
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ fi
+
+ distutils-r1_python_install_all
+}