summaryrefslogtreecommitdiff
path: root/dev-python/pyblake2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyblake2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyblake2')
-rw-r--r--dev-python/pyblake2/Manifest5
-rw-r--r--dev-python/pyblake2/metadata.xml15
-rw-r--r--dev-python/pyblake2/pyblake2-1.1.0.ebuild20
-rw-r--r--dev-python/pyblake2/pyblake2-1.1.2.ebuild22
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/pyblake2/Manifest b/dev-python/pyblake2/Manifest
new file mode 100644
index 000000000000..e07cdd5437a9
--- /dev/null
+++ b/dev-python/pyblake2/Manifest
@@ -0,0 +1,5 @@
+DIST pyblake2-1.1.0.tar.gz 125855 BLAKE2B 46af4c24882040bbdd221f90e06652918798e4555c0a7307a596ca4c9ed3147f00297269a44d174782c2b0402eac03ecf5387b1c5a16efb57d036730b58b2630 SHA512 e13c7e4f3a35155cbf531e337895349ec01f0ac36908a4e746cecec063601adfc8a73a7961a9c310d01d3231f44f08d2cc92e891e9cb87659bc7170b9fee6102
+DIST pyblake2-1.1.2.tar.gz 126693 BLAKE2B 01690ec32a07b7ea59d7d040523ce8cb523f18927044f2d38c0a143a344fde661498e1a4b35a0f161be7b761a324677f80e88c4a0045dc324f0d588997e884f2 SHA512 26297d788208a80c8102602135332d5ee1424711d9c693828af232b5546301c5d144680367a954d8d9765998a23b82046b157b0072fdc63305ff0088feb16e55
+EBUILD pyblake2-1.1.0.ebuild 800 BLAKE2B 5c3fa94d977b1579966283790a073aa038f26c07d420cd713cfcdd96a2da7c9c4cf3d4180f5d9bd8c51542852392c7cc7d2b3c5ea827943535c0337033119545 SHA512 b1ae954130ed64b5d9bf7ea3d97634a38d38cb1fb659a50bfd349f3d0265c65d3e0f1c3315b265a18530e912973a2b0bab5ed4993f535170579e0fc26ea3e16b
+EBUILD pyblake2-1.1.2.ebuild 860 BLAKE2B 248827c9fd719f7565df3775e159d2f25bd25871398e2bddb889862b6398aa26e695ec58f1e5c205d196b11015a7499153ba6e3c16c91e4c0c3d849731b245aa SHA512 8bbe8bffb2fa0e0d0f9d8e6fc1639ad6374e4a2b954212a4c938e65f57332fcc9d923a6d161a4c52c7a05d652138ca7d8596fe9b750a744e1213bc033e78ea4d
+MISC metadata.xml 452 BLAKE2B b5539d95846469f07dc0ec47d4c34f4ae7fa950c58d728f5ba92efb3f74d849598af1eeb7c3d3ab90a41591746e94b3d4c3ea5330c423fb340cbec4a1da28e80 SHA512 28acd5472435f8832eb8cb7587e651f428309e9a37c17cad378fe8f01c47896115c4d42ace1c6125eb99ddd30de562d42503b6dac42432b55b37775cdde7c1ff
diff --git a/dev-python/pyblake2/metadata.xml b/dev-python/pyblake2/metadata.xml
new file mode 100644
index 000000000000..98aa90fe67ab
--- /dev/null
+++ b/dev-python/pyblake2/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">dchest/pyblake2</remote-id>
+ <remote-id type="pypi">pyblake2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyblake2/pyblake2-1.1.0.ebuild b/dev-python/pyblake2/pyblake2-1.1.0.ebuild
new file mode 100644
index 000000000000..77c6ac290d84
--- /dev/null
+++ b/dev-python/pyblake2/pyblake2-1.1.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+inherit distutils-r1
+
+DESCRIPTION="BLAKE2 hash function extension module"
+HOMEPAGE="https://github.com/dchest/pyblake2 https://pypi.org/project/pyblake2/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+# pyblake2 itself allows more licenses but blake2 allows the following three
+LICENSE="|| ( CC0-1.0 openssl Apache-2.0 )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+python_test() {
+ "${EPYTHON}" test/test.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/pyblake2/pyblake2-1.1.2.ebuild b/dev-python/pyblake2/pyblake2-1.1.2.ebuild
new file mode 100644
index 000000000000..2b2d75afadf5
--- /dev/null
+++ b/dev-python/pyblake2/pyblake2-1.1.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+inherit distutils-r1
+
+DESCRIPTION="BLAKE2 hash function extension module"
+HOMEPAGE="https://github.com/dchest/pyblake2 https://pypi.org/project/pyblake2/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+# pyblake2 itself allows more licenses but blake2 allows the following three
+LICENSE="|| ( CC0-1.0 openssl Apache-2.0 )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" test/test.py || die "Tests fail with ${EPYTHON}"
+}