summaryrefslogtreecommitdiff
path: root/dev-python/pybind11
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /dev-python/pybind11
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'dev-python/pybind11')
-rw-r--r--dev-python/pybind11/Manifest4
-rw-r--r--dev-python/pybind11/pybind11-2.7.1.ebuild2
-rw-r--r--dev-python/pybind11/pybind11-2.8.0.ebuild53
3 files changed, 57 insertions, 2 deletions
diff --git a/dev-python/pybind11/Manifest b/dev-python/pybind11/Manifest
index c9601d84e592..9c5f6fb4906e 100644
--- a/dev-python/pybind11/Manifest
+++ b/dev-python/pybind11/Manifest
@@ -1,3 +1,5 @@
DIST pybind11-2.7.1.tar.gz 668217 BLAKE2B 92d857f14290ee0717bd9f9b871dcecd6c0b36209bb9879f107c8542326fb0cc42c051f3bc12a8be50df892f1e26c26b710f60ed275f0dff206e30149547f2b4 SHA512 f09f46622b394d3990ab82aa7ea15a06e298df109cd2df263ba9d6ac7fb248217df7450e1954a9679a8360335d5bbf662926a34c8b7c61b6e4c396bbdfd88305
-EBUILD pybind11-2.7.1.ebuild 1056 BLAKE2B 52fc83c133e528cd20f13a05a301445be47eb072565df795e6c8c4aab192466e003a73c470bf1a6f9bf05d0979608caebb6140e898b7a32fdfd01ca250b7de84 SHA512 73574286615b450c33f6cf73ee2719642e53b3afcbf19ba5f16c29995bba17734f0a96e0e51f56f1786449ac069e3a13c87f51e22f2424ca37a178f0395a79e9
+DIST pybind11-2.8.0.tar.gz 688544 BLAKE2B 3652ebf56cdec9c50a431915b4b59cd7c61d58be5a521dd2bea20ea9a0e56ae8782400d4460a5e32f3c3ec086709ee466b6b39c6adc5cd712da05b4016f9f2e1 SHA512 2f066ab1a3d4a22513625f52b55d7722f953007876e800b4a08d6341b9ae70f73a3b0fd57f76cee443e7b8cf0eecdaafc032a23ddad2b8bca2c8108ac4090a82
+EBUILD pybind11-2.7.1.ebuild 1055 BLAKE2B bcd6c5016c6ab9d01d275c77796885019a785633cb916d78fb206b581803f7adda6390788a565c30a3f127712b057a3ffb10a22eb5548b3027ba827fdaaec3b5 SHA512 feaceb8704a2e11f17008f3e81066d21e2e5fcc541710b1eab2be491ee6d65e1b25a7e42830058a5a2ece6b24db00f3c928d47549427071d90dd35aa91d1b688
+EBUILD pybind11-2.8.0.ebuild 1060 BLAKE2B 0ecc2b21f13ed213230f3553247f65456d4521978c51f62569bda8f15becc105e5280eb202ee999b73cfe11cf8be7952f814b1d557f7c225cf504f9dbe38dc28 SHA512 bc2dd7fb50b877e49ad723f145a5c8107db3024a4a808c190aab3083014c906121e096f078051d14aa900f1aa2f9bcf5b1425269ba4a8d48f20b8fa84deca07c
MISC metadata.xml 420 BLAKE2B 8a3480ac275b7e2893d696bf4fd0d70f41ea941fab9e24b19d8561c0efeee81024ba6fea0ab26333346f3c176d1a87b35229e31ecefc74de2e7614600a64013e SHA512 8140e933878a75968420deab189bab1decd030b5209baada2857a7659dc32980bbc46678c6612ef56e4b4f6b598579bb8227e6c7fd00fbde63a40eb13bccf86c
diff --git a/dev-python/pybind11/pybind11-2.7.1.ebuild b/dev-python/pybind11/pybind11-2.7.1.ebuild
index 4311dad05d21..6d6438979eca 100644
--- a/dev-python/pybind11/pybind11-2.7.1.ebuild
+++ b/dev-python/pybind11/pybind11-2.7.1.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/pybind/pybind11/archive/v${PV}.tar.gz -> ${P}.tar.gz
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+KEYWORDS="amd64 arm ~arm64 ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
RDEPEND="
dev-cpp/eigen:3
diff --git a/dev-python/pybind11/pybind11-2.8.0.ebuild b/dev-python/pybind11/pybind11-2.8.0.ebuild
new file mode 100644
index 000000000000..3edf9adb8aa7
--- /dev/null
+++ b/dev-python/pybind11/pybind11-2.8.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit cmake distutils-r1
+
+DESCRIPTION="AST-based Python refactoring library"
+HOMEPAGE="https://pybind11.readthedocs.io/en/stable/"
+SRC_URI="https://github.com/pybind/pybind11/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="
+ dev-cpp/eigen:3
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ export PYBIND11_USE_CMAKE=1
+
+ cmake_src_prepare
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ local mycmakeargs=(
+ # disable forced lto
+ -DPYBIND11_LTO_CXX_FLAGS=
+ -DPYBIND11_INSTALL=ON
+ -DPYBIND11_TEST=$(usex test)
+ )
+ cmake_src_configure
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ # Compilation only does anything for tests
+ use test && cmake_src_compile
+}
+
+python_test() {
+ cmake_build check
+}
+
+python_install() {
+ distutils-r1_python_install
+ cmake_src_install
+}