summaryrefslogtreecommitdiff
path: root/dev-python/pybind11
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-01 09:07:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-01 09:07:00 +0000
commit7a795be3ed6b29502cf5dccb5ea8294fc1ec2860 (patch)
treec5a028ba6f5ad04992cbc8ff1e20b5c9790b073c /dev-python/pybind11
parentb9fc63c20df1fdeead24c989c4aca4090830f9d4 (diff)
gentoo auto-resync : 01:11:2022 - 09:06:59
Diffstat (limited to 'dev-python/pybind11')
-rw-r--r--dev-python/pybind11/Manifest2
-rw-r--r--dev-python/pybind11/pybind11-2.10.1.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/pybind11/Manifest b/dev-python/pybind11/Manifest
index c1168d4cbae4..4e4c82e1599e 100644
--- a/dev-python/pybind11/Manifest
+++ b/dev-python/pybind11/Manifest
@@ -1,5 +1,7 @@
DIST pybind11-2.10.0.gh.tar.gz 716362 BLAKE2B d9d3a8a108a303721766b822d43b631396c451c8caea0ec1bd36a97850382cdaec69a4f4e5fb475bc84e2aead050f73b759320a81750a661997870e1a84383b5 SHA512 93112ce530a0652b2b4458a137b4a35f2fd8607f82ad96698ef422128d0b53e16e1d06c239ee4643b821acafae09c74eb0f72bc4ee5584aa9fcdaff4d79980d9
+DIST pybind11-2.10.1.gh.tar.gz 727880 BLAKE2B d051220f33ce44ea6d174d64a2ecfad4f7452b0f5152035cfd36950875dc451e11e8352eb80c9c01b200176c0b09fa5274504ece524e699590deac64c44d57c6 SHA512 040f109ec870516acdaebc5133ccbba9e3ed7ff93214a66997cf4b8366c209322f3c902c283040826c7e585c3ea2259caf62d90d0b475bfa33d21e459dd54df1
DIST pybind11-2.9.2.tar.gz 709521 BLAKE2B 76ae9c72faad805885eabbe4dadf1092fe814f04f2a8d834da035c7389dcc996c09a63149911aa7a5c0b70d2da9f7c32e94aaf1c941f13345e0aef40a5748dfc SHA512 c6c18e5f59873adb3692640ade26472abd257607e7bb9fd48cfd1949878811e83d6ac6eb8c8dd926622d52ca4f13e5e6a58e0abaaaa1fa814ee831ea2b515272
EBUILD pybind11-2.10.0.ebuild 1226 BLAKE2B ce22b4d19a78fd2a6aea3abb0f1c25d1f8c2365e019e545c8f9756d4ad148a28b2017cf80aebade83326182de542bc554030ef570f51b5daf4dd9d0e0dc547e7 SHA512 9e23a42ab85645cde613a09ee013540dfab8e73181fe9bdc2a7ec86433c77252c32c76c7bbcbaca65a629f2f05306dc749f53bbcb5f0807d5b6663430f2e32f3
+EBUILD pybind11-2.10.1.ebuild 1232 BLAKE2B a7095f0c72f98dd061dd0936453a05b2f0e92ba5da97f896315cf18f746d94befc45db3ff945e10c661466201bb0efe40479ea1e1aef385b27433bf08244faa9 SHA512 dd02d25faba581686b0d76f209b52d39ef4ed5a9d048a8310c7c4536773303c31801c13f5d4ad49d6ead36097084f8248dcb8a4d5698f7b051627d874f53bfcc
EBUILD pybind11-2.9.2-r1.ebuild 1223 BLAKE2B e9199c4817a2e5fdfa82deb9a9533c4eb583b06c12f5d1e67d79f3d7db062ad133001002ce47c183cd29740445e42afd446d715517eee270b0def1fe514ff47c SHA512 cc9ce91713484c07c6e417319b6a02d32bff1c5dee34042458537c4540e4a0bdf61524285dc43d2b63446d19bdee660304f4b689e8c0a48dfcaba7e2d04d2a62
MISC metadata.xml 420 BLAKE2B 8a3480ac275b7e2893d696bf4fd0d70f41ea941fab9e24b19d8561c0efeee81024ba6fea0ab26333346f3c176d1a87b35229e31ecefc74de2e7614600a64013e SHA512 8140e933878a75968420deab189bab1decd030b5209baada2857a7659dc32980bbc46678c6612ef56e4b4f6b598579bb8227e6c7fd00fbde63a40eb13bccf86c
diff --git a/dev-python/pybind11/pybind11-2.10.1.ebuild b/dev-python/pybind11/pybind11-2.10.1.ebuild
new file mode 100644
index 000000000000..391705a55c76
--- /dev/null
+++ b/dev-python/pybind11/pybind11-2.10.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit cmake distutils-r1
+
+DESCRIPTION="AST-based Python refactoring library"
+HOMEPAGE="
+ https://pybind11.readthedocs.io/en/stable/
+ https://github.com/pybind/pybind11/
+ https://pypi.org/project/pybind11/
+"
+SRC_URI="
+ https://github.com/pybind/pybind11/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-cpp/eigen:3
+"
+BDEPEND="
+ test? (
+ >=dev-cpp/catch-2.13.5
+ dev-libs/boost
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ export PYBIND11_USE_CMAKE=1
+ cmake_src_prepare
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ local mycmakeargs=(
+ # disable forced lto
+ -DPYBIND11_LTO_CXX_FLAGS=
+ -DPYBIND11_INSTALL=ON
+ -DPYBIND11_TEST=$(usex test)
+ )
+ cmake_src_configure
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ # Compilation only does anything for tests
+ use test && cmake_src_compile
+}
+
+python_test() {
+ cmake_build check
+}
+
+python_install() {
+ distutils-r1_python_install
+ cmake_src_install
+}