summaryrefslogtreecommitdiff
path: root/dev-python/pybind11
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-18 00:58:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-18 00:58:25 +0100
commit5e0a5ca921524f8859808527a57655eec16efa52 (patch)
tree7c58411b1e81478df4e20082a6adec2553c24c5c /dev-python/pybind11
parent4c16e0a214824f15f09396e359db4f1f5c086fec (diff)
gentoo auto-resync : 18:07:2023 - 00:58:24
Diffstat (limited to 'dev-python/pybind11')
-rw-r--r--dev-python/pybind11/Manifest3
-rw-r--r--dev-python/pybind11/files/pybind11-2.10.4_macOS-GCC.patch23
-rw-r--r--dev-python/pybind11/pybind11-2.10.4.ebuild3
3 files changed, 27 insertions, 2 deletions
diff --git a/dev-python/pybind11/Manifest b/dev-python/pybind11/Manifest
index d6dd4f83a65a..ab1b85fdd35f 100644
--- a/dev-python/pybind11/Manifest
+++ b/dev-python/pybind11/Manifest
@@ -1,3 +1,4 @@
+AUX pybind11-2.10.4_macOS-GCC.patch 900 BLAKE2B 22d2e59db7d9c26064cb65ba8a6847986a2c4224bb7507b5fcf8f5deb48e65976bea717d3dd1876652429c2c6e9e41875480aa182ddd0bb039799e957554d04c SHA512 d71dee88b061b48e8c707e3a67062e297ff68f7ac3b6af8fdbc0cabd278a678af1e3376193e9507ef0368ecf9572b4cf6390cc7743d17551581dd5e4acbdf699
DIST pybind11-2.10.4.gh.tar.gz 740622 BLAKE2B 7b2d86e8262581b2cc6dd720b83336206e242ef8ca99b257b01a11141ed8b127d7f35d7d573bc763dd36f2fe8c8ac91766089deb63a76e9c10029c34eec2d6d3 SHA512 7970defbb6d057a44468ed707c80bfa6ef8c9578528fbc084b03aeea20a52dbd681581f82d55ff90af11ee89693379bd79e2ab6603239ba05b0aa8da29dd93c7
-EBUILD pybind11-2.10.4.ebuild 1280 BLAKE2B 71fd073f743f76f6b56a2283531a164fad3ccd70258b6f0d91e7a18e98caf813219243ce2a120ea5c2b0cf3ad1524588203006b5fdd46b2e9de3ce251a7f11f2 SHA512 6fc04e67776147b374b9fee6e14a85028d8bebd24b1a46bef8e7637bd10672a743db4f4cc8a1f13d868126d87ab2ccb4c41a728626d3e4c42963e5afba63fdaf
+EBUILD pybind11-2.10.4.ebuild 1363 BLAKE2B 3eb66771750d56d7acee9208fd6dac13d95a83dbe81dd3a5e59f23d4323d1dee7eace4cb8925607843533a34aecf42fe0a6eae2c827879348265fece46fefee0 SHA512 9260291f7e30f4d0360bff665b29f76f5f99707e2ebdacd8f71a5c83007b5f18237fedb169bb0d13a8d22930be8fbda5d4ee3f6e961fc17d9f0d5ac916687774
MISC metadata.xml 475 BLAKE2B faf317a1197850acb0d16546a303bd50ee1bfe6fc3aaf592e6c147c6612fd20b809f1c911d79ca9a356cfa0c4166d2b155fcbd593f8b55e0d7dd75ff6444073b SHA512 5779adcc9f25c15fd999aa6c91d3144fc14535270e57925bfb8ac67f45448c144a142af2ea9a321ec6ffbf568713f663cef85a0be3d4a056e58b1782a5fc9a41
diff --git a/dev-python/pybind11/files/pybind11-2.10.4_macOS-GCC.patch b/dev-python/pybind11/files/pybind11-2.10.4_macOS-GCC.patch
new file mode 100644
index 000000000000..5bfa88348110
--- /dev/null
+++ b/dev-python/pybind11/files/pybind11-2.10.4_macOS-GCC.patch
@@ -0,0 +1,23 @@
+Break the toolchain assumption of LLVM on Prefix/macOS.
+
+At Prefix/macOS, the system compiler is GCC with libstdc++.
+
+This patch is only useful to Gentoo Prefix. We don't have plans to
+forward it upstream.
+
+Signed-off-by: Benda Xu <heroxbd@gentoo.org>
+
+Index: pybind11-2.10.4/pybind11/setup_helpers.py
+===================================================================
+--- pybind11-2.10.4.orig/pybind11/setup_helpers.py
++++ pybind11-2.10.4/pybind11/setup_helpers.py
+@@ -154,9 +154,6 @@ class Pybind11Extension(_Extension): #
+ c_cpp_flags = shlex.split(env_cflags) + shlex.split(env_cppflags)
+ if not any(opt.startswith("-g") for opt in c_cpp_flags):
+ cflags += ["-g0"]
+- if MACOS:
+- cflags += ["-stdlib=libc++"]
+- ldflags += ["-stdlib=libc++"]
+ self._add_cflags(cflags)
+ self._add_ldflags(ldflags)
+
diff --git a/dev-python/pybind11/pybind11-2.10.4.ebuild b/dev-python/pybind11/pybind11-2.10.4.ebuild
index ade4adbcd5e1..cea97d04299f 100644
--- a/dev-python/pybind11/pybind11-2.10.4.ebuild
+++ b/dev-python/pybind11/pybind11-2.10.4.ebuild
@@ -21,7 +21,7 @@ SRC_URI="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
RDEPEND="
dev-cpp/eigen:3
@@ -38,6 +38,7 @@ distutils_enable_tests pytest
python_prepare_all() {
export PYBIND11_USE_CMAKE=1
cmake_src_prepare
+ PATCHES=( "${FILESDIR}"/pybind11-2.10.4_macOS-GCC.patch )
distutils-r1_python_prepare_all
}