summaryrefslogtreecommitdiff
path: root/dev-python/pybind11
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-04 01:36:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-04 01:36:14 +0000
commit2e6b794bf4361b8ae32bb6945e84696c2e1d94ba (patch)
tree8024f09999dddfd7975287e7449255c282b62a49 /dev-python/pybind11
parented43421253416ff58a637be8932ac1d7b7b232de (diff)
gentoo auto-resync : 04:03:2023 - 01:36:13
Diffstat (limited to 'dev-python/pybind11')
-rw-r--r--dev-python/pybind11/Manifest2
-rw-r--r--dev-python/pybind11/pybind11-2.10.1.ebuild67
2 files changed, 0 insertions, 69 deletions
diff --git a/dev-python/pybind11/Manifest b/dev-python/pybind11/Manifest
index 9ec46376c4f2..98795534c2c5 100644
--- a/dev-python/pybind11/Manifest
+++ b/dev-python/pybind11/Manifest
@@ -1,5 +1,3 @@
-DIST pybind11-2.10.1.gh.tar.gz 727880 BLAKE2B d051220f33ce44ea6d174d64a2ecfad4f7452b0f5152035cfd36950875dc451e11e8352eb80c9c01b200176c0b09fa5274504ece524e699590deac64c44d57c6 SHA512 040f109ec870516acdaebc5133ccbba9e3ed7ff93214a66997cf4b8366c209322f3c902c283040826c7e585c3ea2259caf62d90d0b475bfa33d21e459dd54df1
DIST pybind11-2.10.3.gh.tar.gz 740214 BLAKE2B 967b93cbf7d1f8faad25db9a4d3e84fd33b48429cdf527c167e65faad5c01df83a5634021cf99f07adf443855d9f6bb076f0cc67b0e6555e189b794a845b533a SHA512 3894400f04cd08e2dbb14b3d696339f0364434f1d6f8bb057338ac88157ec7491b2df1e1e46ebd5abccdcd5775c5e9238de6404f0db87f64f5a1802db3a5b18c
-EBUILD pybind11-2.10.1.ebuild 1235 BLAKE2B 34a0a01fd99fbe60ae9624f7239dacc187d9b26112e289dbb9a81dafa9b19670d62640bef0c79303f961a098c41518ec2d43a93469ca82f84c5d72b6065b58a2 SHA512 7eb56942e1c770942f3607d587077756fe9bbf3c6ade2bd1a4e0d504ba6766f6998baf76076d0b672412a6df361021841f7bbdf73fc5ebcace99167c70dec43d
EBUILD pybind11-2.10.3.ebuild 1237 BLAKE2B 17590abe071c68edf93fb630c7e10c770edae992d1bac7177c4b5258a55db4f0371f518c021ad383b21d9becace91bfb288dfbd0cb60fc40ae2ea8ca22ed7b2a SHA512 47664fc3cae4088de5228e08f39c87df059f85f9f0651d4db726cc49bce961a3c44f1b3d57531b9964489c0cdfdd4d94fa1aeea1893e759438c132e814ebda9f
MISC metadata.xml 475 BLAKE2B faf317a1197850acb0d16546a303bd50ee1bfe6fc3aaf592e6c147c6612fd20b809f1c911d79ca9a356cfa0c4166d2b155fcbd593f8b55e0d7dd75ff6444073b SHA512 5779adcc9f25c15fd999aa6c91d3144fc14535270e57925bfb8ac67f45448c144a142af2ea9a321ec6ffbf568713f663cef85a0be3d4a056e58b1782a5fc9a41
diff --git a/dev-python/pybind11/pybind11-2.10.1.ebuild b/dev-python/pybind11/pybind11-2.10.1.ebuild
deleted file mode 100644
index ff9914bc8f53..000000000000
--- a/dev-python/pybind11/pybind11-2.10.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit cmake distutils-r1
-
-DESCRIPTION="AST-based Python refactoring library"
-HOMEPAGE="
- https://pybind11.readthedocs.io/en/stable/
- https://github.com/pybind/pybind11/
- https://pypi.org/project/pybind11/
-"
-SRC_URI="
- https://github.com/pybind/pybind11/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc ~x86"
-
-RDEPEND="
- dev-cpp/eigen:3
-"
-BDEPEND="
- test? (
- >=dev-cpp/catch-2.13.5
- dev-libs/boost
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- export PYBIND11_USE_CMAKE=1
- cmake_src_prepare
- distutils-r1_python_prepare_all
-}
-
-python_configure() {
- local mycmakeargs=(
- # disable forced lto
- -DPYBIND11_LTO_CXX_FLAGS=
- -DPYBIND11_INSTALL=ON
- -DPYBIND11_TEST=$(usex test)
- )
- cmake_src_configure
-}
-
-python_compile() {
- distutils-r1_python_compile
- # Compilation only does anything for tests
- use test && cmake_src_compile
-}
-
-python_test() {
- cmake_build check
-}
-
-python_install() {
- distutils-r1_python_install
- cmake_src_install
-}