summaryrefslogtreecommitdiff
path: root/dev-python/pybind11
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-16 13:45:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-16 13:45:36 +0100
commit29607d91fb1bf1c4456a0b90601ee172ea769283 (patch)
tree71a1c87ff8b0a522d0f8243a4f064f8f9b5d94e4 /dev-python/pybind11
parent22b96ae0ceb12f57b30fc2577770f565506bbac8 (diff)
gentoo auto-resync : 16:07:2022 - 13:45:35
Diffstat (limited to 'dev-python/pybind11')
-rw-r--r--dev-python/pybind11/Manifest2
-rw-r--r--dev-python/pybind11/pybind11-2.10.0.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/pybind11/Manifest b/dev-python/pybind11/Manifest
index 8127af72213a..8fe4f594a036 100644
--- a/dev-python/pybind11/Manifest
+++ b/dev-python/pybind11/Manifest
@@ -1,3 +1,5 @@
+DIST pybind11-2.10.0.gh.tar.gz 716362 BLAKE2B d9d3a8a108a303721766b822d43b631396c451c8caea0ec1bd36a97850382cdaec69a4f4e5fb475bc84e2aead050f73b759320a81750a661997870e1a84383b5 SHA512 93112ce530a0652b2b4458a137b4a35f2fd8607f82ad96698ef422128d0b53e16e1d06c239ee4643b821acafae09c74eb0f72bc4ee5584aa9fcdaff4d79980d9
DIST pybind11-2.9.2.tar.gz 709521 BLAKE2B 76ae9c72faad805885eabbe4dadf1092fe814f04f2a8d834da035c7389dcc996c09a63149911aa7a5c0b70d2da9f7c32e94aaf1c941f13345e0aef40a5748dfc SHA512 c6c18e5f59873adb3692640ade26472abd257607e7bb9fd48cfd1949878811e83d6ac6eb8c8dd926622d52ca4f13e5e6a58e0abaaaa1fa814ee831ea2b515272
+EBUILD pybind11-2.10.0.ebuild 1239 BLAKE2B 721848db4ea0e8776fbc959a55bd3d23525b3218cad8db68c6364d149844adcf81f197ce4b6dfd6828a53125dbf66a21f68f50a1c034832c5ecabb03f1053e1f SHA512 866ca07f1abb4b43a4b7a8d44f9cedcb0a333bd13d0893f0b3e17f4524321a1fa1e14d60933e186698aa26a8a1e4f63c19296fd7a6054c7f12c357558ce69dff
EBUILD pybind11-2.9.2-r1.ebuild 1230 BLAKE2B e64837a80f44d0e2f766fce42db1d5e2f1310e9ec83b6139b5f6c316ad5b7bb7b0d0ed495e5f91e2e12ef7c291321aea604af0c919d48b52aa57a6f3115413ae SHA512 102fd9df725323434138f8517de62e5accc4c5cece77f7c9d289d31eac19f6ebeff5b393f6b5a6b22bf4b3f7da81aa0ffefc219ef701995cf3e4a769a2df562a
MISC metadata.xml 420 BLAKE2B 8a3480ac275b7e2893d696bf4fd0d70f41ea941fab9e24b19d8561c0efeee81024ba6fea0ab26333346f3c176d1a87b35229e31ecefc74de2e7614600a64013e SHA512 8140e933878a75968420deab189bab1decd030b5209baada2857a7659dc32980bbc46678c6612ef56e4b4f6b598579bb8227e6c7fd00fbde63a40eb13bccf86c
diff --git a/dev-python/pybind11/pybind11-2.10.0.ebuild b/dev-python/pybind11/pybind11-2.10.0.ebuild
new file mode 100644
index 000000000000..9ea3bab5b725
--- /dev/null
+++ b/dev-python/pybind11/pybind11-2.10.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit cmake distutils-r1
+
+DESCRIPTION="AST-based Python refactoring library"
+HOMEPAGE="
+ https://pybind11.readthedocs.io/en/stable/
+ https://github.com/pybind/pybind11/
+ https://pypi.org/project/pybind11/
+"
+SRC_URI="
+ https://github.com/pybind/pybind11/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-cpp/eigen:3
+"
+BDEPEND="
+ test? (
+ >=dev-cpp/catch-2.13.5
+ >=dev-libs/boost-1.56
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ export PYBIND11_USE_CMAKE=1
+ cmake_src_prepare
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ local mycmakeargs=(
+ # disable forced lto
+ -DPYBIND11_LTO_CXX_FLAGS=
+ -DPYBIND11_INSTALL=ON
+ -DPYBIND11_TEST=$(usex test)
+ )
+ cmake_src_configure
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ # Compilation only does anything for tests
+ use test && cmake_src_compile
+}
+
+python_test() {
+ cmake_build check
+}
+
+python_install() {
+ distutils-r1_python_install
+ cmake_src_install
+}