summaryrefslogtreecommitdiff
path: root/dev-python/pyaudio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-03 13:55:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-03 13:55:12 +0100
commit0a65aa74175d9ac6570321fe11725dc30c574e08 (patch)
tree72b20e59998ee19c32c86634c05e02790faaf20f /dev-python/pyaudio
parent4b4d352fc9761396c68812d8eccc63b7b14d6558 (diff)
gentoo auto-resync : 03:08:2022 - 13:55:12
Diffstat (limited to 'dev-python/pyaudio')
-rw-r--r--dev-python/pyaudio/Manifest3
-rw-r--r--dev-python/pyaudio/pyaudio-0.2.11-r1.ebuild39
-rw-r--r--dev-python/pyaudio/pyaudio-0.2.11-r2.ebuild2
3 files changed, 42 insertions, 2 deletions
diff --git a/dev-python/pyaudio/Manifest b/dev-python/pyaudio/Manifest
index 67674e0672ce..0041498127ff 100644
--- a/dev-python/pyaudio/Manifest
+++ b/dev-python/pyaudio/Manifest
@@ -1,4 +1,5 @@
AUX pyaudio-0.2.11-python310-size_t.patch 845 BLAKE2B 68eee6ebd83440e0f42a51a1c88735f5c6a7b2b541413faadee0260c22f65baff4d922100304fe719e9a6818ec98e3ce0bb51c763c916ae76385511d0d4ae12c SHA512 a9db774bcaaeb6693871ae49ec584bf58543469cd5c166e5ecb61efc354be7fde2a4c3283c1fe070a3d9d102301fa1a5f39d844418d52cd88565e1e62348992b
DIST PyAudio-0.2.11.tar.gz 37428 BLAKE2B 18db51a651876135a6afc6c8c60e2221017a311fe1aec10497905bc35b81a73b5e9f27201431566bac3d13bcf582ec12a3b818c51f0e5e70aeb4ad177608461a SHA512 64db5542ee60837c9b07677e146fc7b060ff47c8b1c04cbb575bce79dd3ed4776c201e169ff2860f27dbe9e00a77046ba0cb925b55f7c546f8de46c6df68954e
-EBUILD pyaudio-0.2.11-r2.ebuild 1180 BLAKE2B 5f1acdc1f34c015b296593f754f21294f84084528685a852254650098dfdd80d9045aca6982ee0e69b9f0e4649fd916c22e62f7589a4fb14d80a3526b93940b8 SHA512 842b273a771572b4e04201e14987980bf02f6d1d9d30bac6223f39d74fd627ca07e46bdad3b69cf5dc15a518e3238b6004672c9f1ea18eaff7c81b7d17050784
+EBUILD pyaudio-0.2.11-r1.ebuild 1091 BLAKE2B 7ebb50ca17f473fa13ebdf973da074cb00bc161b0c2bf46701a5935a4eeb20763f5790e813ba74f6518db9a7f1a9caabffc554a80755c45bb5156691e8177d3f SHA512 41a4115bb3b8a2da4403fb7358fc3602d83cce90118770d59c31199dadd6e0f639260e62f77b1235d22f16ecca00a860910ad9c75fb8dbdf6628cc7e6f346e05
+EBUILD pyaudio-0.2.11-r2.ebuild 1182 BLAKE2B 7ee7cb3992233b3a08e79fd17fcb81ac63f6fa51fdc8ac6066b0d9ce14afe1b4c50a64eda0bb99ab2f0d4892bae33327711c64d2b8e83e01187363101b8c4614 SHA512 cf7d5d4fd000b4a32f8f6537bf525c97e17a9849acba15955e91097cb50f3a5ca9f19d58f58449842cfa8102da422cc589e936273eedfc6f40885bd96c252f36
MISC metadata.xml 629 BLAKE2B 13fcd9ca931e654d70fa328133f5c1aff9410c7c504338d7fd14f53f2ea971c5418c3f8e242d2cc35cd990c91494626379cf88e7e157a5bfc37b87c0c83bf7c8 SHA512 cc9475811d3f8265e79c80d2b7b817156942430843d23361c3ea9791730c422acd9c399755c8f6a775b6a3e9d7fb9138f22e87ebde9e7019591d68c696095d81
diff --git a/dev-python/pyaudio/pyaudio-0.2.11-r1.ebuild b/dev-python/pyaudio/pyaudio-0.2.11-r1.ebuild
new file mode 100644
index 000000000000..2af98eb2c323
--- /dev/null
+++ b/dev-python/pyaudio/pyaudio-0.2.11-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="PyAudio"
+
+DESCRIPTION="Python bindings for PortAudio"
+HOMEPAGE="http://people.csail.mit.edu/hubert/pyaudio/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+# Tests work if you have the correct HW device(s) to test. 0.2.11-r1.
+RESTRICT="test"
+
+RDEPEND="media-libs/portaudio"
+DEPEND="${RDEPEND}
+ test? ( dev-python/numpy )"
+
+distutils_enable_sphinx sphinx
+distutils_enable_tests unittest
+
+python_test() {
+ elog "These tests require an OS loopback sound device that forwards audio"
+ elog "output, generated by PyAudio for playback, and forwards it to an input"
+ elog "device, which PyAudio can record and verify against a test signal."
+
+ cd tests || die
+ # pyaudio_tests have very complicated runtime requirements, therefore skipping them.
+ "${EPYTHON}" -m unittest error_tests -v ||
+ die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/pyaudio/pyaudio-0.2.11-r2.ebuild b/dev-python/pyaudio/pyaudio-0.2.11-r2.ebuild
index 4460e98b3091..b061423018d0 100644
--- a/dev-python/pyaudio/pyaudio-0.2.11-r2.ebuild
+++ b/dev-python/pyaudio/pyaudio-0.2.11-r2.ebuild
@@ -15,7 +15,7 @@ S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
# Tests work if you have the correct HW device(s) to test. 0.2.11-r1.
RESTRICT="test"