summaryrefslogtreecommitdiff
path: root/dev-python/pyatspi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /dev-python/pyatspi
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'dev-python/pyatspi')
-rw-r--r--dev-python/pyatspi/Manifest2
-rw-r--r--dev-python/pyatspi/pyatspi-2.32.1.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pyatspi/Manifest b/dev-python/pyatspi/Manifest
index f35ff5a14f80..30c1147a991b 100644
--- a/dev-python/pyatspi/Manifest
+++ b/dev-python/pyatspi/Manifest
@@ -1,4 +1,6 @@
AUX pyatspi-2.6.0-examples-python3.patch 791 BLAKE2B ad8130ef64605915b3124dd268bb002e8e4a32c7c3e3e7f4445a5ee7e6a899b1caae25e1ecaff417d2d121063361d3dd983df08bafa666ab03aa6746fa21151c SHA512 7171f77080fed4ef235d1d3380821939d5a41e919b8509db8dcbe211d63b7b390e66389152c7275128cc8372c2a7fd1bdfaf179fc93b8fa62ed76a6edffd11ed
DIST pyatspi-2.30.0.tar.xz 310672 BLAKE2B 76d51e6ce2f39305bcda8f706b5207738d3a2c0fd7480efb77c4dab8baf8ed6eb71263375ff0c16be0087e47f7f6b5eab99c6fc8992b83bdea6e64c92c381043 SHA512 a7af81bb55dff45d1bceced645f6aeb1adc1fa2a2b61fc39d9e97b6659e474636e5ac1af9923588311e651fee57b5e31a62ea5b2977b341eda43a5a736bf27ed
+DIST pyatspi-2.32.1.tar.xz 310896 BLAKE2B acf4a0211015daf5a19a796de9e267637ae77b2f79f0c6af20bfa5eb5a0fa0d4a62cf23524348299daebd515cccb7a4a1c18226e8c04356ea6439840613242a7 SHA512 6cdddc4275770a4f89e66355e18518f5cbf1ceeee1f27298be1fb5bb8b67676eeeb81ce7f4fbb5ad617573f574e5fd5858d363c77a0e5727d637ae7275429b03
EBUILD pyatspi-2.30.0.ebuild 1297 BLAKE2B 958e2b72ab234d040d3c945a5b535fb7cba118517ae6636fe10facc73d5cd0939c390dd10e6cd90ecc5b73e28489b3ac7097b68e4751cf9c6ec89e9ef7100c4f SHA512 7140f8455184dcdde5d7899fe0716ca9f444807cb74a1d359c9a39da758f3e415ba31a93560e7852b58761e4811a4787599b1832289b117aee27eba99b4331d4
+EBUILD pyatspi-2.32.1.ebuild 1298 BLAKE2B fa43c5572a4a3b72297e7b13fbbfa0f3d6934b5435d8e2fe1a58685bc0cb860771224e7b17fcfca34ba144896739014bea17b6bc837c9cbdf5fe8a6657e7d820 SHA512 225aea4f249227cc04933f68fc1940cdef1945be5a34bd2b1ef070609eaeed4d369d42bc9caec2d8c9641d68345e01de1b75c04a9a13440472370ab16aeb1cf0
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/dev-python/pyatspi/pyatspi-2.32.1.ebuild b/dev-python/pyatspi/pyatspi-2.32.1.ebuild
new file mode 100644
index 000000000000..9476dbba39d6
--- /dev/null
+++ b/dev-python/pyatspi/pyatspi-2.32.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Python binding to at-spi library"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+# Note: only some of the tests are GPL-licensed, everything else is LGPL
+LICENSE="LGPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="" # test
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-libs/atk-2.11.2
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.90.1:3[${PYTHON_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/dbus-1
+ >=app-accessibility/at-spi2-core-2.32[introspection]
+ !<gnome-extra/at-spi-1.32.0-r1
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # https://bugzilla.gnome.org/show_bug.cgi?id=689957
+ "${FILESDIR}/${PN}-2.6.0-examples-python3.patch"
+)
+
+src_prepare() {
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure --disable-tests
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir gnome2_src_install
+
+ docinto examples
+ dodoc examples/*.py
+}