summaryrefslogtreecommitdiff
path: root/dev-python/pyatspi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
commit09351e78166b5e864197c4456ebae3f89dd0bed9 (patch)
tree41a96399f56ed3aa399006871bfce4430db84aa2 /dev-python/pyatspi
parentc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (diff)
gentoo resync : 22.01.2019
Diffstat (limited to 'dev-python/pyatspi')
-rw-r--r--dev-python/pyatspi/Manifest2
-rw-r--r--dev-python/pyatspi/pyatspi-2.26.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pyatspi/Manifest b/dev-python/pyatspi/Manifest
index 98c9a4efe89f..14a3d7388680 100644
--- a/dev-python/pyatspi/Manifest
+++ b/dev-python/pyatspi/Manifest
@@ -1,4 +1,6 @@
AUX pyatspi-2.6.0-examples-python3.patch 791 BLAKE2B ad8130ef64605915b3124dd268bb002e8e4a32c7c3e3e7f4445a5ee7e6a899b1caae25e1ecaff417d2d121063361d3dd983df08bafa666ab03aa6746fa21151c SHA512 7171f77080fed4ef235d1d3380821939d5a41e919b8509db8dcbe211d63b7b390e66389152c7275128cc8372c2a7fd1bdfaf179fc93b8fa62ed76a6edffd11ed
DIST pyatspi-2.24.0.tar.xz 298228 BLAKE2B a1c989df5431a9fdf0b35c5fa75a12b9c083c6a979052e3a621685feada611f4322195b30bc1f4f56cd35f305087756cded31a445cca07e74262ecd807926239 SHA512 ea0c3e5a5a417c4d494cfe33ccfcca1996f417e51f5ccd3508372a0df636fb186b9940d7832681af9b353aa50a9aabd64c5477fdabbc5016794a502396b3d67a
+DIST pyatspi-2.26.0.tar.xz 309780 BLAKE2B f3657052ef7c5fde35506e04e5f1a3920fed5edd1af182b3e9bff6fc0461595e9b14644c8858d6f12b1042d57231fc09ae5061129d74a1030e0c8de88364ec7b SHA512 a1aa7e608fa95bdf4c891666fe5038dd2fd7cc7e675cef4c9759ffed4f6342e3cebbc6d5fad8899c0c91eda29664a5f8ff06a1cb0ab46958c8f629cd014d3579
EBUILD pyatspi-2.24.0.ebuild 1297 BLAKE2B 232974954d137d16728d738e2ed0e4f3c206ba1c608a1e5997e9868f02a4cc6e9d825480bec8b1d3af7a9961a101f2e2514eb51ed5687dfae3369ca11a94ed5e SHA512 07a7cba527f24318267f80964953cdf5201a202db70dc096e117249cdb562a64e854056c90915ba473867443c7e94931834217c7f0fc7d21608da8cfa56ef15d
+EBUILD pyatspi-2.26.0.ebuild 1297 BLAKE2B 04b7e43b50e9a04915215118b28356c3e005a14017f2d187743bb279220ed07e45f06093d766d20f72935bbf98d7696cf0477090a9c08e49912de8be6f3f5856 SHA512 f00a7a30d13238e465ded58a54d5781e030ca45ac2facad4b93b92078a362402f6b6ae8cd69ca862ecd6125df1b0e767b9a09cb665a80c2d4de93f28361b9c58
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/dev-python/pyatspi/pyatspi-2.26.0.ebuild b/dev-python/pyatspi/pyatspi-2.26.0.ebuild
new file mode 100644
index 000000000000..25898e111ef4
--- /dev/null
+++ b/dev-python/pyatspi/pyatspi-2.26.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Python binding to at-spi library"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+# Note: only some of the tests are GPL-licensed, everything else is LGPL
+LICENSE="LGPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="" # test
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-libs/atk-2.11.2
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.90.1:3[${PYTHON_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/dbus-1
+ >=app-accessibility/at-spi2-core-2.20.2[introspection]
+ !<gnome-extra/at-spi-1.32.0-r1
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # https://bugzilla.gnome.org/show_bug.cgi?id=689957
+ "${FILESDIR}/${PN}-2.6.0-examples-python3.patch"
+)
+
+src_prepare() {
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure --disable-tests
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir gnome2_src_install
+
+ docinto examples
+ dodoc examples/*.py
+}