summaryrefslogtreecommitdiff
path: root/dev-python/pyasynchat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-18 00:10:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-18 00:10:02 +0100
commitccaccfe4f1da8c11d9fa110f6e4eb847358769d7 (patch)
treeff02c95ae3d9a1e73e2a182e268161743d81a88b /dev-python/pyasynchat
parent74e526c590f52d24a213e25f77858ae0b34ec2c8 (diff)
gentoo auto-resync : 18:06:2024 - 00:10:02
Diffstat (limited to 'dev-python/pyasynchat')
-rw-r--r--dev-python/pyasynchat/Manifest2
-rw-r--r--dev-python/pyasynchat/pyasynchat-1.0.4.ebuild11
2 files changed, 8 insertions, 5 deletions
diff --git a/dev-python/pyasynchat/Manifest b/dev-python/pyasynchat/Manifest
index d3f40add0c49..754a89bbc644 100644
--- a/dev-python/pyasynchat/Manifest
+++ b/dev-python/pyasynchat/Manifest
@@ -1,3 +1,3 @@
DIST pyasynchat-1.0.4.tar.gz 9747 BLAKE2B e38edd9e35ce31f9015b934a5d4edb96053ff239978359f13e5b74ac9b8160029556207f79a199d82085882e80d88fc8033f9085f986b48dfaa50de780576197 SHA512 d36eb16770637a311d56fe22229de5a3cdfa699ae64fbafcdd5ce9acd43270b90813fe56db14528083ee1803a43d958d0b3b6616e0bbf907a4dd4a563981a278
-EBUILD pyasynchat-1.0.4.ebuild 581 BLAKE2B 1f8605ec4e94b836185b4ea044ca876b408985a1c291fa836808661a9ddc8afc343e5005efd5faec8151141fe3762da10ebbd5e4617c46fee40d216a0ccdf36b SHA512 16262417a8eb039a0be6d06bff559f82727484a21617b7ef0793813f1e8cfa5b09ce71e4c5c773ee4b7e9b1f5641852213e4bb408842bacc039ced88e63ce365
+EBUILD pyasynchat-1.0.4.ebuild 582 BLAKE2B 5ea883cde722366d8b629aa105adcefcb417da8040477df16be5fb8f4b6b1e77a760ec4f13d8713a81c32891edc60f7281df5822f7fbb2707a2e80485474e5d7 SHA512 ae63208d944f419296db357651fe890727c12cd5131fa6a90c42a634d9d894a517e8dad445d79bdfbb6b18c1d8ecf1a1ca47a4042ddcb124545b3532849f050f
MISC metadata.xml 410 BLAKE2B 9e60dac1e4ef47dd2d5a1811c8ecb03d6b0f8ca88ca22b0717309d74e762f4807db9a240a58dff57b5bce05d6988da02a9961854a65b4442b6d45fdd0251f0e1 SHA512 efdcaf76cdb42d8949e9c5f660b28e782f13510f67f5395d5966551ac8e9c0f4272b64f4c8b6876838306d43b74d6c6ebe9e495d8f08545fc7cee2ecddf6a42f
diff --git a/dev-python/pyasynchat/pyasynchat-1.0.4.ebuild b/dev-python/pyasynchat/pyasynchat-1.0.4.ebuild
index b5a328e71004..ba48e9e8acdc 100644
--- a/dev-python/pyasynchat/pyasynchat-1.0.4.ebuild
+++ b/dev-python/pyasynchat/pyasynchat-1.0.4.ebuild
@@ -4,13 +4,13 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_12 )
+PYTHON_COMPAT=( python3_{12..13} )
inherit distutils-r1 pypi
DESCRIPTION="Make asynchat available for Python 3.12 onwards"
HOMEPAGE="
- https://github.com/simonrob/pyasynchat
+ https://github.com/simonrob/pyasynchat/
https://pypi.org/project/pyasynchat/
"
@@ -18,9 +18,12 @@ LICENSE="PSF-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~loong ppc ppc64 ~riscv sparc x86"
-RDEPEND=">=dev-python/pyasyncore-1.0.2[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/pyasyncore-1.0.2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
python_test() {
- # Can't use d_e_t unittest (bug #926964)
eunittest tests
}