summaryrefslogtreecommitdiff
path: root/dev-python/pyarrow
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-23 22:30:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-23 22:30:19 +0000
commit2d37d4dc50650d8de650e8a476233f57d972cdf6 (patch)
treee90121d54377e3cc5a76e4028035962ba97c44d5 /dev-python/pyarrow
parent191f9d51469a31970723ed9eb0aee70ffe63094e (diff)
gentoo auto-resync : 23:11:2023 - 22:30:19
Diffstat (limited to 'dev-python/pyarrow')
-rw-r--r--dev-python/pyarrow/Manifest2
-rw-r--r--dev-python/pyarrow/pyarrow-12.0.1.ebuild71
2 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/pyarrow/Manifest b/dev-python/pyarrow/Manifest
index f2c573e86415..5b5e4b7adc6e 100644
--- a/dev-python/pyarrow/Manifest
+++ b/dev-python/pyarrow/Manifest
@@ -1,5 +1,3 @@
-DIST apache-arrow-12.0.1.tar.gz 20172604 BLAKE2B bf66761d33ceb778c2f53c2e643e0c2bb4448f29eaa94d17e9815628665f4965fde28bd47fce4a5874717d2161c3f8adbb2e8a0e6658a51ae6d617e4f09d202b SHA512 551ae200551fcc73b7deddcc5f0b06633159ab1308506901a9086e4e2e34e4437f26d609fdbacba0ebe7d1fe83bdb8e92a268e9e41575d655d5b2d4fbef7a7ce
DIST apache-arrow-14.0.1.tar.gz 20968461 BLAKE2B 01a4269f98ba2a4de1d6bc29f43a4e97132f8b7bdb3c3d022e0c0ba498527003e8bec0ea0b054f19ae54749f45fe39675f651f6c9e34e815df5a9b9926512431 SHA512 31d19f0ca80349f63db74bae813256b47907f85725a9bf01ef6f32406e79828ebb4701faedb52696b6a5b3bb89ad4e136485fd5eb35d396dd42147c11d4d2713
-EBUILD pyarrow-12.0.1.ebuild 1698 BLAKE2B 0b37b3e6fcef08909f6a0b714f019c8c0d2d069215aeffd97f99f0dff76faae8125c8af492ea9b1eff84628462a874d1d0195380b49b9edce0f260a283082288 SHA512 4357e57fa47ec7e2751730a8666b09c878abcd362163b4b57ed1551e6e10505fa089a370d6439efa36066c5a065a3708237c1f87d7e0bd48964c8610fe32a047
EBUILD pyarrow-14.0.1.ebuild 1732 BLAKE2B fa80196f4222a802aa56c8d2defb12087e1927df55254adc879689cab866db380b49bd0d463f112d1666934f050ee0235ba8f316d51b43ea1b8d1c08eab6e976 SHA512 868ff4350e4810b59c4ac8f96ea745c738848d1aa47bbd6c4cbfed6b8f0aecd2454e1b8918209a9e080bdf9b49a8dab73faecd7470d624197ecfc55832b5427c
MISC metadata.xml 454 BLAKE2B aef32100cb88b74361bc57c83179ce223bab58fd2d33c0274011350f1021f8f738008a64b74995d005f9b53edf45d9e0168a38101e041297d38805529b7af416 SHA512 2b7d53db25c36faca27aa8885479396ad2b510d8fba9b421d969fd23505b5026b48a9869ab941fa8d09c2a399ed6f211d8694bc3ed05dc5bf583d7be1fc0e679
diff --git a/dev-python/pyarrow/pyarrow-12.0.1.ebuild b/dev-python/pyarrow/pyarrow-12.0.1.ebuild
deleted file mode 100644
index 7ac59fddb3d9..000000000000
--- a/dev-python/pyarrow/pyarrow-12.0.1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="Python library for Apache Arrow"
-HOMEPAGE="
- https://pypi.org/project/pyarrow/
- https://arrow.apache.org/
-"
-SRC_URI="mirror://apache/arrow/arrow-${PV}/apache-arrow-${PV}.tar.gz"
-S="${WORKDIR}/apache-arrow-${PV}/python"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="parquet snappy ssl"
-
-RDEPEND="
- ~dev-libs/apache-arrow-${PV}[compute,dataset,json,parquet?,re2,snappy?,ssl?]
- dev-python/numpy[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- <dev-python/pandas-2[${PYTHON_USEDEP}]
- dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # wtf?
- tests/test_fs.py::test_localfs_errors
- # these require apache-arrow with jemalloc that doesn't seem
- # to be supported by the Gentoo package
- tests/test_memory.py::test_env_var
- tests/test_memory.py::test_specific_memory_pools
- tests/test_memory.py::test_supported_memory_backends
-)
-
-src_compile() {
- export PYARROW_PARALLEL="$(makeopts_jobs)"
- export PYARROW_BUILD_VERBOSE=1
- export PYARROW_CXXFLAGS="${CXXFLAGS}"
- export PYARROW_BUNDLE_ARROW_CPP_HEADERS=0
- export PYARROW_CMAKE_GENERATOR=Ninja
- export PYARROW_WITH_HDFS=1
- if use parquet; then
- export PYARROW_WITH_DATASET=1
- export PYARROW_WITH_PARQUET=1
- use ssl && export PYARROW_WITH_PARQUET_ENCRYPTION=1
- fi
- if use snappy; then
- export PYARROW_WITH_SNAPPY=1
- fi
-
- distutils-r1_src_compile
-}
-
-python_test() {
- cd "${T}" || die
- epytest --pyargs pyarrow
-}