summaryrefslogtreecommitdiff
path: root/dev-python/pyannotate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-20 08:38:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-20 08:38:17 +0100
commit32fc5f4a2c2017f1f9c628fab9dcb5a54c3e6f03 (patch)
treeac4c27ddeabc815da16db33f4a2cc3451b9ad3db /dev-python/pyannotate
parentf090ac33320e52dd549b818be0c345a3bb870ae0 (diff)
gentoo auto-resync : 20:08:2022 - 08:38:17
Diffstat (limited to 'dev-python/pyannotate')
-rw-r--r--dev-python/pyannotate/Manifest3
-rw-r--r--dev-python/pyannotate/metadata.xml21
-rw-r--r--dev-python/pyannotate/pyannotate-1.2.0.ebuild20
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pyannotate/Manifest b/dev-python/pyannotate/Manifest
new file mode 100644
index 000000000000..d24b98b3a9b7
--- /dev/null
+++ b/dev-python/pyannotate/Manifest
@@ -0,0 +1,3 @@
+DIST pyannotate-1.2.0.gh.tar.gz 46148 BLAKE2B c52c93c0d27cb23b0b0683bbd5f353ba9a45714b8a50fb3a6f5aa4e67bfe71e60bc7afbee85a021ed25a7f5a1df720dc863fc6dd92d20dee0d97af72786866cf SHA512 cd755f3061f5c4320346f0198b71e4b312378a3810c5999f1d318b7427e7c55bd1bdfc4af84880bd45faf69eabccbd2684d1c18c1f9ad0661d35a377984ca063
+EBUILD pyannotate-1.2.0.ebuild 515 BLAKE2B 10c97a57092c8d04423ff39aeaeaab765a8e9d3554c9a44d3011e62b67cd7de4e4d5a0a1a9645ed06f0bc21b70dcee5f73f301ca335a9dfed82736e8167b807e SHA512 6ccb4b1ad3979c8683ecdc918e904af81b967d2f5a29f05946259b71b9dda663397d336b36f4e3da779a80058febba264d6434d38dacd41020279be6268cd67a
+MISC metadata.xml 604 BLAKE2B 72f9fad12803b851cf8dd2599471860208a0dc24bafe7f67d2b2a69be49bcd1eff6ae2c38e9b83ad2884fd6b3a44feadf72351076e7af7bfefb5523309946c25 SHA512 1a8329f48b59c4e7b1cefaeacf7c8b590f2e5a910d9513507d9d712aad955f59127bdcf44df95a6c0ac3927fcddd62eadf2b3969b9316539c129bd8204dac30a
diff --git a/dev-python/pyannotate/metadata.xml b/dev-python/pyannotate/metadata.xml
new file mode 100644
index 000000000000..4c4e5ce97e96
--- /dev/null
+++ b/dev-python/pyannotate/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>ajak@gentoo.org</email>
+ <name>John Helmert III</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pyannotate</remote-id>
+ <remote-id type="github">dropbox/pyannotate</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyannotate/pyannotate-1.2.0.ebuild b/dev-python/pyannotate/pyannotate-1.2.0.ebuild
new file mode 100644
index 000000000000..8f1e82ca06d5
--- /dev/null
+++ b/dev-python/pyannotate/pyannotate-1.2.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Auto-generate PEP-484 annotations"
+HOMEPAGE="https://github.com/dropbox/pyannotate"
+SRC_URI="https://github.com/dropbox/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/mypy_extensions[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest