summaryrefslogtreecommitdiff
path: root/dev-python/pyaml/pyaml-21.10.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-05 11:30:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-05 11:30:40 +0100
commit3023707d355581e5dc6945aa9c8f4d59e508a8b5 (patch)
tree5bf569d557ba145002d922f72eadde17410572d4 /dev-python/pyaml/pyaml-21.10.1.ebuild
parent4e777c0133d093c9c8b992c92e0f244e2055bf71 (diff)
gentoo auto-resync : 05:05:2023 - 11:30:40
Diffstat (limited to 'dev-python/pyaml/pyaml-21.10.1.ebuild')
-rw-r--r--dev-python/pyaml/pyaml-21.10.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pyaml/pyaml-21.10.1.ebuild b/dev-python/pyaml/pyaml-21.10.1.ebuild
new file mode 100644
index 000000000000..ad36eef3de6a
--- /dev/null
+++ b/dev-python/pyaml/pyaml-21.10.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYPI_PN="pyaml"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="PyYAML-based module to produce pretty and readable YAML-serialized data"
+HOMEPAGE="https://github.com/mk-fg/pretty-yaml"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ~ppc64 ~riscv x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest