summaryrefslogtreecommitdiff
path: root/dev-python/pyamg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /dev-python/pyamg
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'dev-python/pyamg')
-rw-r--r--dev-python/pyamg/Manifest5
-rw-r--r--dev-python/pyamg/files/pyamg-4.0.0-test.patch14
-rw-r--r--dev-python/pyamg/pyamg-3.2.1-r1.ebuild32
-rw-r--r--dev-python/pyamg/pyamg-4.0.0.ebuild27
4 files changed, 44 insertions, 34 deletions
diff --git a/dev-python/pyamg/Manifest b/dev-python/pyamg/Manifest
index 8cad74072d5f..2f7ff2d80a25 100644
--- a/dev-python/pyamg/Manifest
+++ b/dev-python/pyamg/Manifest
@@ -1,3 +1,4 @@
-DIST pyamg-3.2.1.tar.gz 765723 BLAKE2B 72c59c0fe93363f73d8ba4c6297920dd1ca8406b048cf0357baec5f2390bdb524421a35ef65e790be45b543e9e162067ee8f8f09327b464a4bc5c9cec368b003 SHA512 6be0dd068417389934ce97813321367920abf6f9f5e94ce2df8bd796edc797cedd492c9153b62466f7d68055a05821447dcf21578ccdfe3294766a49a9ac220e
-EBUILD pyamg-3.2.1-r1.ebuild 699 BLAKE2B 894c592309416b56a4a3b23ec9d241f8000ecf8bffd178d216e86b6b494e9a497c29ff3c0728c8f02ba90f34013169e1213c1e849275416aa918064f56a93dd4 SHA512 64bd056a6a6173072d3cc9ba7c2d582ea0c71fac786e8d73bc2a8592ef78ab7e6cc3449c922e3c58be19c6f04afd84d76eed804919ac212cef4cbe7d740c6eba
+AUX pyamg-4.0.0-test.patch 589 BLAKE2B 2b337d2815b4bf091a30fcb03b8c9270e601a0dfc5c1d3ed2a4541e8af1d026e8d56a517097d403110eb91c675cc07177b0fc96c81fa48cf51cabccd81da1112 SHA512 c6419ae72b6231015f46679a277d61755cb11cdf1a586789d6cfddbd28ec548ced6bc81c4b973011163d6be76509d26035636ba5952c8bddc3d0c66bc258142e
+DIST pyamg-4.0.0.tar.gz 717171 BLAKE2B 16483d829e8a938359827ca8ebe3093c890685244125576e05220910b66e9aeec278472134d10c589e58dfbd363930cdd7ae13d16c9b9d54c1bd5250e66f4677 SHA512 cdd27834c12ef18f023e78b5b946c06bc2c35f73cf65fc4c76da2fab75f23466e6c1a4b3dccb8506be3ada7e0bafda38122d3d7315deebc7959d2e5300d9add1
+EBUILD pyamg-4.0.0.ebuild 691 BLAKE2B dd58e37ccc7c2b7e2620d043c64fe6ff33a531dbc5e09a419a00b7c572472a8550692f2ed169de11064e60dbf7e6869e2563406c8bf8089cdc733dcb8032e1e9 SHA512 613a44f4139325aa10d12e91866f42f39016b39addec40dbaad35e6775b2ede2d13c01e7ee5dcda5e6fa46693a539ca165e660db9fa4f7ff66999bba275148ba
MISC metadata.xml 660 BLAKE2B 09f5ba733b9e679cd6435afe0e71a2382498ed2417563031c24dbb9d8630f1ea9ece9d10c2851afb411dec9694b773e495aac10e9cfe4398980f2d0c26efa370 SHA512 9900180bd0de0c9cb26205d2de5674f02405499778124c3fc21a3d3be6e7bd6602f4f619b0b983e95e30ff3f8f37e15ebfc66535db144f92e8f0c6d579e5e6f1
diff --git a/dev-python/pyamg/files/pyamg-4.0.0-test.patch b/dev-python/pyamg/files/pyamg-4.0.0-test.patch
new file mode 100644
index 000000000000..316d0a2baad4
--- /dev/null
+++ b/dev-python/pyamg/files/pyamg-4.0.0-test.patch
@@ -0,0 +1,14 @@
+Backported from: https://github.com/pyamg/pyamg/commit/6f5e549e6105e18cfff9bf4b5f1834d081fa4510
+Author: Luke Olson
+--- a/pyamg/aggregation/tests/test_smooth.py
++++ b/pyamg/aggregation/tests/test_smooth.py
+@@ -485,6 +485,9 @@ class TestEnergyMin(TestCase):
+ Bc = ml.levels[1].B
+ P = ml.levels[0].P.tocsr()
+
++ T.eliminate_zeros()
++ P.eliminate_zeros()
++
+ # P should preserve B in its range, wherever P
+ # has enough nonzeros
+ mask = ((P.indptr[1:] - P.indptr[:-1]) >= B.shape[1])
diff --git a/dev-python/pyamg/pyamg-3.2.1-r1.ebuild b/dev-python/pyamg/pyamg-3.2.1-r1.ebuild
deleted file mode 100644
index cc9224f2094e..000000000000
--- a/dev-python/pyamg/pyamg-3.2.1-r1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Algebraic multigrid solvers in Python"
-HOMEPAGE="https://pyamg.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-python_test() {
- distutils_install_for_testing
- cd "${T}" || die # need to be away source directory
- nosetests --verbose pyamg || die
-}
diff --git a/dev-python/pyamg/pyamg-4.0.0.ebuild b/dev-python/pyamg/pyamg-4.0.0.ebuild
new file mode 100644
index 000000000000..85ddd0a14093
--- /dev/null
+++ b/dev-python/pyamg/pyamg-4.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Algebraic multigrid solvers in Python"
+HOMEPAGE="https://pyamg.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]"
+# cannot be enabled by "distutils_enable_tests pytest"
+BDEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests setup.py
+
+PATCHES=( "${FILESDIR}"/${P}-test.patch )