summaryrefslogtreecommitdiff
path: root/dev-python/pyDes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/pyDes
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/pyDes')
-rw-r--r--dev-python/pyDes/Manifest3
-rw-r--r--dev-python/pyDes/metadata.xml13
-rw-r--r--dev-python/pyDes/pyDes-2.0.1.ebuild17
3 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pyDes/Manifest b/dev-python/pyDes/Manifest
new file mode 100644
index 000000000000..0c5bf895aadc
--- /dev/null
+++ b/dev-python/pyDes/Manifest
@@ -0,0 +1,3 @@
+DIST pyDes-2.0.1.tar.gz 9878 BLAKE2B 45a2d0575519afc389abe080f2c3a6751c5ee1f973e9e4370f24c5dbf9d85882e875682005eae3d749a2e11bffc3cd46868f83baa58f9e7e4feb7a25db641a14 SHA512 9d2a048dd6f629713d93d5cfcf5eaccb45a28fd3942f6837baf492bc6d9f0fcd16a1611e467231e9abfa6756d1684b0848c2190195e9e772bed2e6574327885c
+EBUILD pyDes-2.0.1.ebuild 410 BLAKE2B a46713dcf80199358c91069fe810cee071574f60242cd91dc190f678b191e7abcdef51e51d5a516020529fa52f68a3aad43856402c0f81d1c4a6aeaf366c8647 SHA512 6c085f5b156fc2c6549567fd52a8aa0a31f463718941c3ea6d6b9423a73cf97cb47e42f3153dbf466437ddc541a807e187b231c112dc7ccfbd58fed0cf336c31
+MISC metadata.xml 401 BLAKE2B d2e507ac1fbff3f6f0f61baceb9baba2b2d40e7400a1a892f2a230ba09f243236fb2d9efb619d43a8667736a1df822c31fbf00d26361636b8b0765b07329faa5 SHA512 b9dd93cbf9f77d53a9a51f96d0c0aaec3ba3d83db52e66f0e65bf075f02fc9b8593cf595f2710924203f64f70bdb4dc5143d1fb40ca6c2fc4f9f37adf3c3c555
diff --git a/dev-python/pyDes/metadata.xml b/dev-python/pyDes/metadata.xml
new file mode 100644
index 000000000000..3f3432b413f8
--- /dev/null
+++ b/dev-python/pyDes/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/twhiteman/pyDes/issues/</bugs-to>
+ <remote-id type="github">twhiteman/pyDes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyDes/pyDes-2.0.1.ebuild b/dev-python/pyDes/pyDes-2.0.1.ebuild
new file mode 100644
index 000000000000..2668e53c17dd
--- /dev/null
+++ b/dev-python/pyDes/pyDes-2.0.1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of DES and TRIPLE DES"
+HOMEPAGE="https://twhiteman.netfirms.com/des.html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"