summaryrefslogtreecommitdiff
path: root/dev-python/pyClamd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-18 20:11:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-18 20:11:57 +0000
commitb30bf80580f09f15ee6686ff818cd36d923e1291 (patch)
tree273782d0605a08ce382dcf09078d11ed800cca58 /dev-python/pyClamd
parent51e7ea94956939599972c733f5b65fe71c7eb857 (diff)
gentoo auto-resync : 18:02:2023 - 20:11:56
Diffstat (limited to 'dev-python/pyClamd')
-rw-r--r--dev-python/pyClamd/Manifest2
-rw-r--r--dev-python/pyClamd/files/pyClamd-0.4.0-remove-obsolete-bugtrack_url.diff11
-rw-r--r--dev-python/pyClamd/pyClamd-0.4.0-r4.ebuild27
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pyClamd/Manifest b/dev-python/pyClamd/Manifest
index 7961c2a07d48..942761d7e065 100644
--- a/dev-python/pyClamd/Manifest
+++ b/dev-python/pyClamd/Manifest
@@ -1,3 +1,5 @@
+AUX pyClamd-0.4.0-remove-obsolete-bugtrack_url.diff 827 BLAKE2B 785e75cf5094fd32e205eb1db5749ebf6fea1fb415aee3a1fe587864147ab6a81340b85d24313e17c5ea1d6467beb8392fe5c5c3c30ce6a9afc50f38e6d04520 SHA512 23fb59f17a498a6f10da49eb23e728366c0e6101ce588c76eec818658fad75390c6437b094bbec42b10dcca4465793862e511d311d4b3ba020f4c13f85f767ec
DIST pyClamd-0.4.0.tar.gz 11177 BLAKE2B cb69c9e1fec936d416a18658a2c3e9df4dc4684cf56c19e8a02ad9929b4c86d9985395c38a8f88f7053f81fe08fa3574c6a206bcc519a9494c2a61caf6b995b1 SHA512 b96e26729e0fe2600572534c0fa22a01238761589f1771e72a054dde9c1b8f122493c83ca04cffda167f7a0e44fbf309bdf76b8fe1de499ec50d56c677923bd4
EBUILD pyClamd-0.4.0-r3.ebuild 538 BLAKE2B 7d89a864ee11bd3b1130533323149331ad2034413832082f5e39c0eb1b1210083e919e52572473fd1d00cc66208acca5a29a2def8390ac747b03713169cf4337 SHA512 1f9df464decab577a15a6456be41a43c18aa26a29972c5e1859d5ac5ddd64bffacca879cb166f336a57b8a06de074f0a819f756a7b6be956bc180efcb5621a62
+EBUILD pyClamd-0.4.0-r4.ebuild 640 BLAKE2B 53863e074c3ca2d6523f540e0342166bb23213cdcbbcc24a636bf291538860a5cabcfcfbc5020ed8d3517f8e21a72a7d9f1d1feaafc13a7cab793840f3be562d SHA512 dd75b00654b4aea0746a07ce813cde7020eec0d1fe9bdecce2f916c7114fe1227f3d387dda6588fac39affc0b4e5be3c6d12c94b4a5447b59a74e924099b4d46
MISC metadata.xml 295 BLAKE2B cda80e8a0e2125cf0a97ab3ea3c63f588fb57afc25d1559cea145e09676c7708f2c7aa271a7cccabde61927f8a6e5e3200b6ce5b4597eb9a8065f7938fe9201a SHA512 54f6204e9620ddfa126858fd5c5ae7400245759999362f355287276df4d6a255d34322bd70e08b875bbbfceec7099b39db214008a6ea5458a74845d3a39e3952
diff --git a/dev-python/pyClamd/files/pyClamd-0.4.0-remove-obsolete-bugtrack_url.diff b/dev-python/pyClamd/files/pyClamd-0.4.0-remove-obsolete-bugtrack_url.diff
new file mode 100644
index 000000000000..446c215ba518
--- /dev/null
+++ b/dev-python/pyClamd/files/pyClamd-0.4.0-remove-obsolete-bugtrack_url.diff
@@ -0,0 +1,11 @@
+diff -Naurp a/setup.py b/setup.py
+--- a/setup.py 2017-08-28 00:05:52.000000000 +0200
++++ b/setup.py 2023-02-18 16:57:08.911936472 +0100
+@@ -27,7 +27,6 @@ setup (name = 'pyClamd',
+ author_email = 'norman@xael.org',
+ keywords='python, clamav, antivirus, scanner, virus, libclamav',
+ url = 'http://xael.org/pages/pyclamd-en.html',
+- bugtrack_url = 'https://bitbucket.org/xael/pyclamd',
+ include_dirs = ['/usr/local/include'],
+ description = 'pyClamd is a python interface to Clamd (Clamav daemon).',
+ long_description = 'pyClamd is a python interface to Clamd (Clamav daemon). By using pyClamd, you can add virus detection capabilities to your python software in an efficient and easy way. Instead of pyClamav which uses libclamav, pyClamd may be used by a closed source product.',
diff --git a/dev-python/pyClamd/pyClamd-0.4.0-r4.ebuild b/dev-python/pyClamd/pyClamd-0.4.0-r4.ebuild
new file mode 100644
index 000000000000..34ab2e3d7a34
--- /dev/null
+++ b/dev-python/pyClamd/pyClamd-0.4.0-r4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10,11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+PATCHES=( "${FILESDIR}/${P}-remove-obsolete-bugtrack_url.diff" )
+
+DESCRIPTION="python interface to Clamd (Clamav daemon)"
+HOMEPAGE="https://xael.org/pages/pyclamd-en.html"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+# Tests need clamd running and we cannot rely on that being
+# true during build
+RESTRICT="test"