summaryrefslogtreecommitdiff
path: root/dev-python/pyClamd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyClamd
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyClamd')
-rw-r--r--dev-python/pyClamd/Manifest5
-rw-r--r--dev-python/pyClamd/metadata.xml11
-rw-r--r--dev-python/pyClamd/pyClamd-0.3.17.ebuild25
-rw-r--r--dev-python/pyClamd/pyClamd-0.4.0.ebuild26
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/pyClamd/Manifest b/dev-python/pyClamd/Manifest
new file mode 100644
index 000000000000..3e5c91afe5d7
--- /dev/null
+++ b/dev-python/pyClamd/Manifest
@@ -0,0 +1,5 @@
+DIST pyClamd-0.3.17.tar.gz 10737 BLAKE2B a190809b8f652fdff6c55c73a9431fa509219b9a8d8728ac63844ab1d88e9169df8eeef96892695a8c8a60c48c7fbf938d347603676a186746c4be202b37ef34 SHA512 52eda3f5b6612d47b803e6df8a49890167805dc39a30004f979dcd828b2717ebf7fe753ad0305ab3aad00aaaf750e9e862d43a504ccdb8f7df6faceae18da4a8
+DIST pyClamd-0.4.0.tar.gz 11177 BLAKE2B cb69c9e1fec936d416a18658a2c3e9df4dc4684cf56c19e8a02ad9929b4c86d9985395c38a8f88f7053f81fe08fa3574c6a206bcc519a9494c2a61caf6b995b1 SHA512 b96e26729e0fe2600572534c0fa22a01238761589f1771e72a054dde9c1b8f122493c83ca04cffda167f7a0e44fbf309bdf76b8fe1de499ec50d56c677923bd4
+EBUILD pyClamd-0.3.17.ebuild 559 BLAKE2B 75f4e36fd9cd1a2fa48ec3562608f67926bd145a28cc3f16cf19ebd9ff6507597ed94b3ca32fc136a1788f45b1d29af13f90356e7623c94689fff194ecccfc9d SHA512 0b2ecb5064241fd07bc3b1e823fee447fe9b6a149129772843d3c7c7ae3a4bf5d22e0d0e29d4427d2d99569873d3f30096382e1f30b41ae960648aa625e28fac
+EBUILD pyClamd-0.4.0.ebuild 567 BLAKE2B 1dc635779338a0a9944f660a2a57424ceac209b9f1931e255366a1aecddd0293221d251d193b6fec8fc31465c87a6c67b0e1d76d1819d230c0941437ee001d8a SHA512 57cc8e1bfc193effe94335de13a39323596c9d901db4df7aa0ce3215ff1795b91d05aac8ce1c234e93d0b25673c206828d85345ff5fdb38919415b5bd3e26d20
+MISC metadata.xml 323 BLAKE2B 58103aaf74f241ee493b79225d841b88792d770a484885fa5eba23b8d07d5039d92d1691b2c8914964ec11a055d7ea5150a9b6f2685b9008f6ed7a3f62e638d1 SHA512 d415502fcadfae02999e34a1eb5d526e1e344ee55182ea0790556432df8a63dea1f71a0ebbe47575eafa205dd287e1d2d032de58f87cca6d1fde56154762dc61
diff --git a/dev-python/pyClamd/metadata.xml b/dev-python/pyClamd/metadata.xml
new file mode 100644
index 000000000000..ddd3880bfccf
--- /dev/null
+++ b/dev-python/pyClamd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyClamd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyClamd/pyClamd-0.3.17.ebuild b/dev-python/pyClamd/pyClamd-0.3.17.ebuild
new file mode 100644
index 000000000000..cc6551617c33
--- /dev/null
+++ b/dev-python/pyClamd/pyClamd-0.3.17.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="python interface to Clamd (Clamav daemon)"
+HOMEPAGE="https://xael.org/norman/python/pyclamd/"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e 's:/etc/clamav/clamd.conf:/etc/clamd.conf:' \
+ -i pyclamd/pyclamd.py || die
+}
diff --git a/dev-python/pyClamd/pyClamd-0.4.0.ebuild b/dev-python/pyClamd/pyClamd-0.4.0.ebuild
new file mode 100644
index 000000000000..63155321c7ec
--- /dev/null
+++ b/dev-python/pyClamd/pyClamd-0.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="python interface to Clamd (Clamav daemon)"
+HOMEPAGE="https://xael.org/pages/pyclamd-en.html"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -e 's:/etc/clamav/clamd.conf:/etc/clamd.conf:' \
+ -i pyclamd/pyclamd.py || die
+}