summaryrefslogtreecommitdiff
path: root/dev-python/py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/py
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/py')
-rw-r--r--dev-python/py/Manifest3
-rw-r--r--dev-python/py/py-1.11.0-r1.ebuild23
-rw-r--r--dev-python/py/py-1.11.0.ebuild3
3 files changed, 26 insertions, 3 deletions
diff --git a/dev-python/py/Manifest b/dev-python/py/Manifest
index 68baa81961c6..20ccdc02e78c 100644
--- a/dev-python/py/Manifest
+++ b/dev-python/py/Manifest
@@ -1,3 +1,4 @@
DIST py-1.11.0.tar.gz 207796 BLAKE2B becaafa6b9094790693bb99079a59c5a206d05dd42db1bbd75d1f9527a7a089ef3098a8b16da2c8f7aac6b682cd0687ddd454dc50930f13a860c118e9306cc94 SHA512 ce8dd791f9f6dd7e60a6caad32ff5cb816389a0840436efdedf4e0d4b0bfa09f7aea9e7c31d89903c72fe6ef17170a85af480525ba92c458ed73501a0420f2c4
-EBUILD py-1.11.0.ebuild 794 BLAKE2B 03b8e96647bffbcb8a54813defbda6170731caa3a2cc064623f776310168d488d6db0592b9832247539cb29589faaf016719a664fe29203a9735d28bad036d3a SHA512 b98f85ab177788750c1590e8c2d545884d07ced93da8151a85129d492d4eddec706de052d2200e0e4509d03e81e060d47ca3182977f2dd0f312e2d6f62287d8e
+EBUILD py-1.11.0-r1.ebuild 806 BLAKE2B 2adc15782123781bf170f0b071d7faa0fd26c7120011bea5ee20adac5e17941c2766228bfc88a961e21b54285898018f7db5559ee18197e08434d28ac4b0e274 SHA512 62d75f62c6e06e0fd555c94509e979df6ce6109bd4812561f9820a0778e71d871241020a7ea49609c2c89cc426b95377b1b91f90db3e3209ab4d1bd84597f073
+EBUILD py-1.11.0.ebuild 766 BLAKE2B 0be5dc2d4c31c415ca3c57f35e5659756caddbf30163ccff7df617f581a9f12c047d37a28826eb96bf377e441b3ac4fbdceb1a6d31cc61ef9242d008b1328ca0 SHA512 ac763f27f5dd471b07adf3d0ae4c9519fb9745685531939d9d389274359f951fd8d630182e6e6fa1eb18e1ba5ddeed123ab9cf6274db73c3f14136080fe60f75
MISC metadata.xml 396 BLAKE2B f1d0b4dee74f12247740934c228f649c55bc38397053411c711297936c2f7d6c152437e6917bcb0e05afd94ad9cffe38a7daa0e9830a77c8f834435f41ecfce1 SHA512 fb14933d9f7c397ff4b0bcfd10f26bb001da7f36547df04f29a609cd10849c1e70e1246aac53fc06fe2b3c3cd0cb1599d3f1a19a20f0ea0091ebded6f4d80c1b
diff --git a/dev-python/py/py-1.11.0-r1.ebuild b/dev-python/py/py-1.11.0-r1.ebuild
new file mode 100644
index 000000000000..44709a55860e
--- /dev/null
+++ b/dev-python/py/py-1.11.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="library with cross-python path, ini-parsing, io, code, log facilities"
+HOMEPAGE="https://py.readthedocs.io/ https://pypi.org/project/py/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+# This package is unmaintained and keeps being broken periodically.
+RESTRICT=test
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
diff --git a/dev-python/py/py-1.11.0.ebuild b/dev-python/py/py-1.11.0.ebuild
index e877c8bde96b..6bc4dafc3a51 100644
--- a/dev-python/py/py-1.11.0.ebuild
+++ b/dev-python/py/py-1.11.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -19,5 +19,4 @@ RESTRICT=test
BDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]"
-distutils_enable_sphinx doc
distutils_enable_tests pytest