summaryrefslogtreecommitdiff
path: root/dev-python/py-cpuinfo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/py-cpuinfo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/py-cpuinfo')
-rw-r--r--dev-python/py-cpuinfo/Manifest5
-rw-r--r--dev-python/py-cpuinfo/metadata.xml16
-rw-r--r--dev-python/py-cpuinfo/py-cpuinfo-3.2.0.ebuild27
-rw-r--r--dev-python/py-cpuinfo/py-cpuinfo-3.3.0.ebuild27
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/py-cpuinfo/Manifest b/dev-python/py-cpuinfo/Manifest
new file mode 100644
index 000000000000..97123251743e
--- /dev/null
+++ b/dev-python/py-cpuinfo/Manifest
@@ -0,0 +1,5 @@
+DIST py-cpuinfo-3.2.0.tar.gz 76019 BLAKE2B 2a0969911b385e51ead94a92b89a21bf6ebd6a49ce5229329265ec0611fabe1180cf4ac617c1786ab25605fbf11463e85d74a02195cf01ebc40a5f8d1350f83a SHA512 737d5a73d6991ce5cb99125951a75492f48177030986270bbe7dcc0efb4e3200c9957bfbe51bd5a7555bfa8e62db68c3a5227e47e5e6bb2115ff2c10c0bfb688
+DIST py-cpuinfo-3.3.0.tar.gz 76052 BLAKE2B ffa9d53ccca034b8b4707cc60c8c38b66bd76101e4c6c8d8bf5de743904270a4b9236c0f03192336c2fb32fefb665c5a6d5587639a408ff0bb9183b33f9c3ce7 SHA512 b31ebfb0f066303813d699a7aa5bd5b8d4e0b3b6e8422dfb4aa53c5b64d2234c5275fc293b3eb3ee72752691e023dc94fc013ccf6a0251d307c4b10619135524
+EBUILD py-cpuinfo-3.2.0.ebuild 607 BLAKE2B 428665c0adfdbdbec8d9a40a5a4c19dc052f27cf47198267ebfdbbbb37a0f8edc7ca475bbc357cf2dedf8ee1cc80d4785960d6d9b14056de8fcf620fe423a32d SHA512 4c5cf54ca30bc720cd60ed8c6df01b4d77431af87ed203868ae3bbef5cccdb517a925ca455dc333c6e350b3a194d3adfc5c265c4588c43ff0c5095b23b73f3cb
+EBUILD py-cpuinfo-3.3.0.ebuild 607 BLAKE2B 428665c0adfdbdbec8d9a40a5a4c19dc052f27cf47198267ebfdbbbb37a0f8edc7ca475bbc357cf2dedf8ee1cc80d4785960d6d9b14056de8fcf620fe423a32d SHA512 4c5cf54ca30bc720cd60ed8c6df01b4d77431af87ed203868ae3bbef5cccdb517a925ca455dc333c6e350b3a194d3adfc5c265c4588c43ff0c5095b23b73f3cb
+MISC metadata.xml 531 BLAKE2B ae246808bbc91d82d4d635474be548d3a3e5d48cf45dadfe17e13c6b3e766871106c329a1e478ce7f65478cba17bc28673b459c83b6bbe779891a7f86d605ce0 SHA512 388ada1a9c39b57369dfc9f164530a871801149d44a1439679509fc733b90f33256e8f9a5b5ef22af854e5aaa7c9e1857e87943f25f0c4e06eff2c6b64d440d4
diff --git a/dev-python/py-cpuinfo/metadata.xml b/dev-python/py-cpuinfo/metadata.xml
new file mode 100644
index 000000000000..61b8d8981414
--- /dev/null
+++ b/dev-python/py-cpuinfo/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">py-cpuinfo</remote-id>
+ <maintainer status="unknown">
+ <email>matthew.brennan.jones@gmail.com</email>
+ <name>Matthew Brennan Jones</name>
+ </maintainer>
+ <remote-id type="github">workhorsy/py-cpuinfo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/py-cpuinfo/py-cpuinfo-3.2.0.ebuild b/dev-python/py-cpuinfo/py-cpuinfo-3.2.0.ebuild
new file mode 100644
index 000000000000..d734ea9b5fa2
--- /dev/null
+++ b/dev-python/py-cpuinfo/py-cpuinfo-3.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Get CPU info with pure Python 2 & 3"
+HOMEPAGE="https://github.com/workhorsy/py-cpuinfo https://pypi.org/project/py-cpuinfo/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( ChangeLog )
+
+python_test() {
+ "${PYTHON}" test_suite.py -v || die
+}
diff --git a/dev-python/py-cpuinfo/py-cpuinfo-3.3.0.ebuild b/dev-python/py-cpuinfo/py-cpuinfo-3.3.0.ebuild
new file mode 100644
index 000000000000..d734ea9b5fa2
--- /dev/null
+++ b/dev-python/py-cpuinfo/py-cpuinfo-3.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Get CPU info with pure Python 2 & 3"
+HOMEPAGE="https://github.com/workhorsy/py-cpuinfo https://pypi.org/project/py-cpuinfo/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( ChangeLog )
+
+python_test() {
+ "${PYTHON}" test_suite.py -v || die
+}