summaryrefslogtreecommitdiff
path: root/dev-python/pushbullet-py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/pushbullet-py
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/pushbullet-py')
-rw-r--r--dev-python/pushbullet-py/Manifest1
-rw-r--r--dev-python/pushbullet-py/pushbullet-py-0.11.0.ebuild50
2 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/pushbullet-py/Manifest b/dev-python/pushbullet-py/Manifest
index 37361424b883..3abc2ef5b27f 100644
--- a/dev-python/pushbullet-py/Manifest
+++ b/dev-python/pushbullet-py/Manifest
@@ -1,4 +1,3 @@
DIST pushbullet.py-0.11.0.tar.gz 21653 BLAKE2B a6c9b6f4958ce35b63ea4043d1d4f8691885bd0aa2927af541f2080a0b0b65a7df979a497967f3adceab8ad2382448a4c6a02d1184c9d72a18d91844eb970722 SHA512 b236f30b99e5bb79eff183529716c1c8f83cfd2526fdf50d86041eb6d3fcd6670d0c4dce407ae6e50aea0fa96d6a5527af980148f0c71ef758c480f972ad9659
EBUILD pushbullet-py-0.11.0-r1.ebuild 1141 BLAKE2B 8cd7760e7d8191d6851d6ba7d0e50c5a622ba11c3b41b4f3b70afef7d60d7c773dcb8f4ba7a95f89eb35ec47094b67fb5a6cf408a822d13adc3308e89a1b5394 SHA512 c4c4bec26bd661aa8be271b22d9f74560175e492e6bdfe5a259a2c17d4abe73ad41acdd8f56bfcc0b9aa0ce6e124f641228b5361f12cbbb0d8c3140ceefd7663
-EBUILD pushbullet-py-0.11.0.ebuild 1130 BLAKE2B 614cf6a5ea5661cfb8748fc1376775c27e8d4d776229e38f2c0f26379fa33e2c5d937d7e31a18b9018ab6a65c4745a6b4e09a60cec7a8f37685a47c981be24b3 SHA512 a017d3919983d68b71b092dbb88311f27cd12fdd590afd36ec17dc45a0af7ebbcaf6ae0d1509a53df42b62f744d71569db99bc94c44a9894e3a81a5f435380a4
MISC metadata.xml 459 BLAKE2B 86e83479fde9503defd709e67ea6ba81e5dd9430e1e1b4ea6545f332979173fab9a2392528007638531c58ec205f2d45ca9817f21981b4ebd94f0f81596bde71 SHA512 cda083520abafb4b81b0691234a2bc2bbdf75f4bef69943e5243492a8d8916f9924eae5f06288a6f636ef7bf36477e198dc6a33a04e55a9fd2376a03999f91a2
diff --git a/dev-python/pushbullet-py/pushbullet-py-0.11.0.ebuild b/dev-python/pushbullet-py/pushbullet-py-0.11.0.ebuild
deleted file mode 100644
index 267422432286..000000000000
--- a/dev-python/pushbullet-py/pushbullet-py-0.11.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-DESCRIPTION="A simple python client for pushbullet.com"
-HOMEPAGE="https://github.com/randomchars/pushbullet.py"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/python-magic[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_test() {
- # skip tests which require network access
- PUSHBULLET_API_KEY= py.test \
- -k "not (test_auth or test_decryption)" \
- || die "Tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r example/.
- fi
- distutils-r1_python_install_all
-}